Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox loading is slow for the last few days

  • 7 replies
  • 2 have this problem
  • 19 views
  • Paskiausią atsakymą parašė FredMcD

more options

For the past few days, Firefox has been running painfully slowly. I have tried to reset it, reinstall it and running Glary Utilities to clean but nothing has worked so far. I also have Opera and Chrome which are running absolutely fine. The program itself starts up fine but just seems to be very slow to load pages.

I am on Windows 10 with latest updates which is run on a separate SSD drive. Everything else runs very quickly like the resource heavy NoxPlayer.

Please let me know what further details I can provide you with.

Thank you in advance!

Chosen solution

I changed the proxy settings to No proxy and then tried Auto-detect proxy settings for this network which has now resolved the issue. Thank you for the assistance.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (7)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

The problem is still there in Safe Mode.

The ping speed is really slow compared to Chrome or Opera.

Helpful?

more options

Have your ISP test your service. Is this a direct link or are using WiFi?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

The PC is linked by ethernet.

I've tried those suggestions but the issue is still there.

Why would the problem only be with Firefox and not the other browsers? I have uninstalled, cleaned the registry of anything related and reinstalled with a fresh new version and the problem still persists.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Chosen Solution

I changed the proxy settings to No proxy and then tried Auto-detect proxy settings for this network which has now resolved the issue. Thank you for the assistance.

Helpful?

more options

That was very good work. Well Done.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.