Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hmm. We’re having trouble finding that site.

  • 8 replies
  • 1 has this problem
  • 103 views
  • Paskiausią atsakymą parašė FredMcD

more options

I saw a post on this where they were instructed to go to safe mode and Viola! it works. That is fine, but it does not fix the problem.

My Firefox browser opens all links except what appears to be links from ads or forwarding links from a site to where something is being sold.

Whenever I click on one of these I get the, "Hmm. We’re having trouble finding that site." They open fine on Edge. Is there a setting on Firefox that is blocking these?

Pridėtos ekrano nuotraukos

Chosen solution

I solved my problem. I found another post here on this forum that fixed it.

The thing stopping the links from opening was Duck Duck Go Privacy Protection. Once I turned this off the links loaded fine.

Now the curious part is why or how did it block those links when I was in safe mode with no extensions running?

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (8)

more options

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

I am currently in Safe Mode. I still have the issue.

I have had this problem many times. If I reset Firefox is fixes it for a little while.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

I am now in safe mode. I am assuming by secure websites you mean those beginning with https:// like this one we are on here. This works fine, but the ones I am talk about still do not.

As I said before, the problematic sites are normally what I might call referral links. Not sure of the proper term.

For instance, when I search for something on either duck duck go or google there will may be some shopping recommendations at the top. If I click those types of links I will get the Hmm. We’re having trouble finding that site.

I have attached a screen snag. Every one of those links in shopping will do this. In fact, if I open Shopping to see them all, everyone of those links will do the same thing.

This only seems to happen on advertising type links.

Helpful?

more options

Ad blockers might be interfering with how 'ad' links work. Do a search. Find and copy one of those links and post it here.

Helpful?

more options

Helpful?

more options

Chosen Solution

I solved my problem. I found another post here on this forum that fixed it.

The thing stopping the links from opening was Duck Duck Go Privacy Protection. Once I turned this off the links loaded fine.

Now the curious part is why or how did it block those links when I was in safe mode with no extensions running?

Helpful?

more options

That was very good work. Well Done.

Contact Duck Duck Go support.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.