Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I change URL Bar settings back after FF83 update? Bookmarks & History show up inside URL bar. Also have to click twice when switching between search engines

  • 6 replies
  • 2 have this problem
  • 38 views
  • Paskiausią atsakymą parašė Jimi_107

more options
  • After I updated to Firefox 83, my bookmark and history shortcuts now up inside the URL bar instead of next to it (Picture 1) (I know this is part of the new update 83, how can I change this back?)
  • Additional settings for the URL bar show up (as they should) after I go to a new website. Usually these options are always there (Picture 2) However, all these options disappear (Picture 3) as soon as I type anything in the URL bar and these settings won't return until I open a new tab and go to a website.
  • Lastly, when switching between search engines I know have to click the search engine and then also click enter to complete the switch. (I know this can be 'solved' shift+clicking, but I would prefer for it not to take an extra action and revert back the old pre FF-83 way)

Does anyone have any how I can change it back? - Either by reverting back to FF82, or by using about:config

Pridėtos ekrano nuotraukos

All Replies (6)

more options

Solution by Reddit user: mayhem1574

https://www.reddit.com/r/firefox/comments/jvphu5/firefox_830_release_notes/gcmvb02/

Change these about:config settings

browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation = false Lets you select the search engine using the left/right arrow keys.

browser.urlbar.update2.localOneOffs = false Hides the new Bookmarks/Tabs/History search buttons.

browser.urlbar.update2.oneOffsRefresh = false Lets you start searches like before, with just 1 click.

Modified by Jimi_107

Helpful?

more options

Solution by Reddit user: mayhem1574

https://www.reddit.com/r/firefox/comments/jvphu5/firefox_830_release_notes/gcmvb02/

Change these about:config settings

browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation = false Lets you select the search engine using the left/right arrow keys.

browser.urlbar.update2.localOneOffs = false Hides the new Bookmarks/Tabs/History search buttons.

browser.urlbar.update2.oneOffsRefresh = false Lets you start searches like before, with just 1 click.

Helpful?

more options

Solution by Reddit user: mayhem1574

https://www.reddit.com/r/firefox/comments/jvphu5/firefox_830_release_notes/gcmvb02/

Change these about:config settings

browser.urlbar.update2.disableOneOffsHorizontalKeyNavigation = false Lets you select the search engine using the left/right arrow keys.

browser.urlbar.update2.localOneOffs = false Hides the new Bookmarks/Tabs/History search buttons.

browser.urlbar.update2.oneOffsRefresh = false Lets you start searches like before, with just 1 click.

Helpful?

more options

Hi

When you post a reply that contains external links then this reply needs to be examined and approved by a moderator as an anti-spam feature, so there can be a delay before this reply appears.

Helpful?

more options

Note that browser.urlbar.update prefs are only temporary available during development and may stop working at any time in future Firefox releases once a new feature is working as expected.

Helpful?

more options

So if I understand it correctly, once Firefox decides to delete certain prefs in the about:config section all the changes will revert back to 'default'. In this case, the URL bar will work in a way that I do not find pleasant.

Is there anything I can do about this right now, in order to make the changes permanent in some way? I really hope there is a solution to this as I like the way the URL bar worked in FF82 much better.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.