Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem: all email logins are showing in drop down despite setting "do not ask" and clearing cookies.

  • 2 replies
  • 1 has this problem
  • 6 views
  • Paskiausią atsakymą parašė VG_1227

more options

I am using containers, and have made every setting I can think of to keep my log-ins private. Instead, every time I go to ProtonMail I get shown every email login I have used lately, including a gmail login I only use in a gmail container! ProtonMail advise they do not store this data.

The passwords are not stored, thank goodness.

HOW is Firefox saving it? WHERE? This is actually the creepy and intrusive tracking I came to Firefox to get away from - now they seem more like the perpetrator and I have to go right out of my way to protect myself from Firefox itself. Now I guess gmail knows all my protonmail logins.

Any solutions? I hope my tone is not too exasperated, but if there was another browser option out there right now I'd be gone in minutes.

Thank you!

Firefox for Windows 10, I believe the latest version

I am using containers, and have made every setting I can think of to keep my log-ins private. Instead, every time I go to ProtonMail I get shown every email login I have used lately, including a gmail login I only use in a gmail container! ProtonMail advise they do not store this data. The passwords are not stored, thank goodness. HOW is Firefox saving it? WHERE? This is actually the creepy and intrusive tracking I came to Firefox to get away from - now they seem more like the perpetrator and I have to go right out of my way to protect myself from Firefox itself. Now I guess gmail knows all my protonmail logins. Any solutions? I hope my tone is not too exasperated, but if there was another browser option out there right now I'd be gone in minutes. Thank you! Firefox for Windows 10, I believe the latest version

All Replies (2)

more options

PS I have of course turned off the option in settings to ask to save passwords, and there are no saved logins (so even weirder my IDs are available)

more options

Can you share the screenshots of the page. and don't forget to hide your ID's.