Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Preventing unwanted animations from playing

  • 3 replies
  • 1 has this problem
  • Paskiausią atsakymą parašė ronks1

more options

Certain URLs like often include an advertising animation that can't be avoided or stopped. Or at least I haven't found a way. If there is, I and a bunch of people I mentioned this to would like to know how. Am using FFox 79.0 64-bit on Windows 10.

All Replies (3)

more options

Hello   ronks1,

Type or paste in the address bar   about:config   (press Enter)   and accept the risk.

Type or paste in the search bar   image.animation_mode   and set its value to   none.

Then close and restart Firefox.

Does that make a difference ?


more options


If this is about advertisements then maybe look at a content blocking extension like uBlock Origin.

The above mentioned pref only works for animated GIF images that are very likely not used in ads. Animations in ads are usually done via JavaScript and you would have to block this script.

Are you using Enhanced Tracking Protection as that blocks a lot of third-party content ?


more options

I modified about: config as suggested; no change. Even after restarting FF and then rebooting Windows. And I see I am using Enhanced Tracking Protection: Always On.

But what does work is: with NoScript to block the site from running scripts. Not sure what side effects that may have but I'll stick with that for the moment.


Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.