Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop URL bar from enlarging on click onf firefox 77?

  • 28 replies
  • 6 have this problem
  • 2394 views
  • Paskiausią atsakymą parašė joe80

more options

I hate it when I click on the url-field and its size change.

It wasn't there in former firefox versions and I did not miss it. It changed some time ago. Any decent software development would have introduced his new feature and provided a "classic" option to turn it off. Not so firefox. Mozilla introduced it and I had to google how to get the old behaviour back. No option.. I have to go to about:config, ignore teh warnings, find some weird options and set them to false and the mozilla turned that off too. Now the was to change it is to set up a css-file, got to about:config again to make firefox actually read that file, place some mystery css-code in there and it still does not work!

Very annoying, an outstanding example of bad practice how to introduce new features and take away users choices.

So: How to stop URL bar from enlarging on click?

All Replies (8)

more options

@cor-el You're ignoring about all @ChrisB was saying.

more options

Hi titule, this support forum has a limited scope: support forum volunteers are not the developers. We can assist you with settings and workarounds, but we don't code Firefox or prioritize development decisions.

Did you have a question for us or did you stop by to voice your displeasure?

more options

Well.. both then... How can I contact the developers to voice my displeasure?

more options

titule said

How can I contact the developers to voice my displeasure?

Can you formulate that as a specific requested change? You have many choices to submit feature suggestions, depending on your desired style of interaction:

Discussion Sites/Advocacy

Limited Length Comments

more options

This megabar an awful anti-feature. Removing even the about:config option to disable it shows Mozilla's contempt for users. It's clear there won't be a proper fix to this ever. Hopefully a more competent and respectful organization emerges from Mozilla's ashes.

more options

In version 83.0 URL bar larging on click, again  :( The old tricks (browser.urlbar.openViewOnFocus = false) not working

more options

Firefox 63+ has support for "@media (prefers-reduced-motion)" and you can create a new Number pref named ui.prefersReducedMotion on the about:config page to enable or block some animations. In Firefox 78+ this includes the location bar breakout. In Firefox 80+ this replaces the tab loading indicator with an hourglass.

  • set the value to 1 if you want to block animations
    ui.prefersReducedMotion = 1
  • set its value to 0 if you want to see animations
    ui.prefersReducedMotion = 0

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

more options

@cor-el I'm a bit confused now. Is there any difference to what you posted here answer-1338188 and answer-1330803 (where you said "that creating this ui.prefersReducedMotion pref effects more than just this case." ?

Modified by cor-el

  1. 1
  2. 2