Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Built-in pdf viewer not available

  • 10 replies
  • 1 has this problem
  • 63 views
  • Paskiausią atsakymą parašė jsauve

more options

I am running FF 77.0.1. This has been an issue for awhile however. In Options, under Applications/PDF, there is no Preview in Firefox option. I've tried quitting FF, renaming/moving handlers.json; but on re-opening the relevant section remains the same(action=0). I discovered about:config pdfjs.disable=false, previously it was set to true. Then in Options/Applications/PDF, "Firefox" is an option to open, and the action=3 in handlers.json, however the behavior of downloaded pdfs is the same (downloaded). (This is trying example pdfs from different sites). I've tried changing about:config security.cps.enable=false, no change. I've also seen a plugin to "fix content types" that shows up on this site, but it didn't change anything. From what I gather, action=3 should be Preview in Firefox, not Firefox, and all pdfs are being downloaded. Is there a way to fix this? Not seeing pdfs in browser is significantly annoying.

Chosen solution

It seems that the label has changed from "Preview in Firefox" to "Open in Firefox", so what you see should be OK.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (10)

more options

I tried a few public sights and it seems to be working. The one I am having issue with is secure, so I will try to contact them directly. It must be an issue on their end.

Helpful?

more options

Hey,

Try the following:

   Go to setting (3 bars) > options > applications.
   Under applications panel.
   Find Portable Document Format (PDF) in the list and click on it to select it.
   Click on the drop-down arrow in the Action column for the above entry and select Use PDF reader name (in Firefox) or preview in firefox. 

If PDF files are still downloaded instead of displayed, try these solutions Reset download actions

   Open your profile folder: 

Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

Under the Application Basics section, click on Show Folder. A window with your profile files will open.

Click the menu button New Fx Menu and then click Exit Close 29

Delete the mimetypes.rdf file.

Then open firefox again and see.

I hope it helps.

Helpful?

more options

I just explained that I did both of those. And mimetypes.rdf has been depreciated in favor of handlers.json for a long while now.

Helpful?

more options

Hi, jsauve

please try the following:

Click the menu button New Fx Menu and choose Options. Select the Applications panel on the left. Check "Preview in Firefox" is set for "Portable Document Format (PDF)" -- if not, change it to this. See View PDF files in Firefox or choose another viewer for a screenshot of what this page looks like.

If it is already set to that and it still won't load with the built-in viewer, please let us know.

Thanks!

Helpful?

more options

There is no option to "Preview in Firefox". The ability to open in "Firefox", which just results in downloading, was allowed when pdfjs.enable=true in about:config; which results in the handlers.json "mimetypes":"application/pdf":"action":3 being set, which is supposed to be the valid state for "Preview in Firefox". I've tried to thoroughly search the support tickets for similar cases & the offered solutions.

Helpful?

more options

hello jsauve,

Follow the step Regarded your issue.

Please try the following:

  1. Open the Firefox Options window
  2. Select the Applications tab
  3. Locate Portable Document Format (PDF) on the list of file types
  4. Change the Action to Preview In Firefox
  5. Click Ok

This should allow you to preview most files in Firefox. This will not work in all cases because some website contain codes to force the browser to download instead of preview.


i hope resolve your problem then please reply me back.


Thank you!

Helpful?

more options

@ARMAN KHAN, did you read the posts before responding? That's been established. & I cannot open pdfs, in FF, from _any_ website.

Helpful?

more options

Hi, please try the following:

Click the menu button and choose Options. Select the Applications panel on the left. Check "Preview in Firefox" is set for "Portable Document Format (PDF)" -- if not, change it to this.

See View PDF files in Firefox or choose another viewer for a screenshot of what this page looks like.

If it is already set to that and it still won't load with the built-in viewer, please let us know. Thanks!

Modified by Ankit Kumar

Helpful?

more options

Chosen Solution

It seems that the label has changed from "Preview in Firefox" to "Open in Firefox", so what you see should be OK.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Helpful?

more options

Thank you, cor-el. In my case, it seems _hardware acceleration_ was the issue. That, and they've changed the label: previously, while the label "Preview in Firefox" was still valid, "Open in Firefox", with my issue, caused infinite windows to spawn uncontrollably on that tab/pdf. I was a bit wary of it, good to know.

Helpful?

Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.