X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

After upgrade to firefox 71 I can only open links from some applications

Paskelbta

I'm on Fedora 31. Firefox was recently upgraded to 71.0 and I find a weird pattern in trying to open links from applications - possibly related to Slack:

If firefox was initially opened following a link from Slack, I can open other links from Slack, but trying to follow links from other applications (IBM Lotus Notes, or running "firefox URL" from a terminal window) fails with a "Firefox is already running" message.

If I open firefox from the desktop applications menu, the reverse happens. I can open links from Notes and a terminal, but following links from Slack fails.

I tried reinstalling firefox and slack with no success. Today I tried going back to an earlier version - firefox-70.0.1-4.fc30.x86_64.rpm - and everything seems to be okay.

It seems like something changed in firefox 71 that doesn't play well with Slack.

I'm on Fedora 31. Firefox was recently upgraded to 71.0 and I find a weird pattern in trying to open links from applications - possibly related to Slack: If firefox was initially opened following a link from Slack, I can open other links from Slack, but trying to follow links from other applications (IBM Lotus Notes, or running "firefox URL" from a terminal window) fails with a "Firefox is already running" message. If I open firefox from the desktop applications menu, the reverse happens. I can open links from Notes and a terminal, but following links from Slack fails. I tried reinstalling firefox and slack with no success. Today I tried going back to an earlier version - firefox-70.0.1-4.fc30.x86_64.rpm - and everything seems to be okay. It seems like something changed in firefox 71 that doesn't play well with Slack.
Citata

Papildomi duomenys apie sistemą

Įdiegti papildiniai

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Klausimą uždavęs asmuo

I found a work-around. Add this to ~/.bashrc, then log in again.

export MOZ_DISABLE_WAYLAND=1

You might also be able to install firefox-x11 and make that the default browser. I have many personal bash scripts that open URLs via 'firefox URL'. I probably ought to be using 'xdg-open URL'.

Until then - or until the issue is fixed - this gets me going.

I found a work-around. Add this to ~/.bashrc, then log in again. export MOZ_DISABLE_WAYLAND=1 You might also be able to install firefox-x11 and make that the default browser. I have many personal bash scripts that open URLs via 'firefox URL'. I probably ought to be using 'xdg-open URL'. Until then - or until the issue is fixed - this gets me going.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Better solution:

I found that I had an old ~/.local/share/applications/slack.desktop file that launched Slack using: Exec=env XDG_CURRENT_DESKTOP=Unity /usr/bin/slack %U

Other apps have an environment with XDG_CURRENT_DESKTOP=GNOME, which I believe is correct.

I copied /usr/share/applications/slack.desktop over the .local file. That seems to have fixed it.

Better solution: I found that I had an old ~/.local/share/applications/slack.desktop file that launched Slack using: Exec=env XDG_CURRENT_DESKTOP=Unity /usr/bin/slack %U Other apps have an environment with XDG_CURRENT_DESKTOP=GNOME, which I believe is correct. I copied /usr/share/applications/slack.desktop over the .local file. That seems to have fixed it.
Was this helpful to you?
Citata
Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.