X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Upgraded to 68.2.2: Using a 4K monitor and the menu and email pane fonts are teeny tiny.

Paskelbta

I'm running on Linux. I just upgraded to 68.2.2 and the menu fonts and email inbox fonts have shrunk on my 4K display.

I've tried custiomizing the userChrome.css file, no dice.

I've tried changing the PixelsPerPix advanced config option, no dice (it changes the amount of space for the font, but doesn't actually change the font.

Help?

I'm running on Linux. I just upgraded to 68.2.2 and the menu fonts and email inbox fonts have shrunk on my 4K display. I've tried custiomizing the userChrome.css file, no dice. I've tried changing the PixelsPerPix advanced config option, no dice (it changes the amount of space for the font, but doesn't actually change the font. Help?

Chosen solution

The background color, at least for plain text messages, can be set under .../Display/Formatting/Fonts & Colors/Colors... You may have to adjust the override setting.

Skaityti atsakymą kartu su kontekstu 0
Citata

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.87 Safari/537.36

More Information

sfhowes
  • Top 10 Contributor
Sprendimų: 1699 Atsakymų: 8253

To apply a userChrome or userContent css file in TB 68, you should toggle the preference toolkit.legacyUserProfileCustomizations.stylesheets to true in Edit/Preferences/Advanced/General/Config. editor.

There are plenty of userChrome examples:

http://www.linnhe2.free-online.co.uk/thunderbird/chrome.html

https://gist.github.com/AnthonyDiGirolamo/6032387

To apply a userChrome or userContent css file in TB 68, you should toggle the preference ''toolkit.legacyUserProfileCustomizations.stylesheets'' to true in Edit/Preferences/Advanced/General/Config. editor. There are plenty of userChrome examples: http://www.linnhe2.free-online.co.uk/thunderbird/chrome.html https://gist.github.com/AnthonyDiGirolamo/6032387
Was this helpful to you? 1
Citata

Klausimą uždavęs asmuo

Thanks for replying.

I changed legacyUserProfileCustomizations.stylesheets to true, but Thunderbird is still ignoring my userChrome.css.

userChrome.css is located in my home directory under .thunderbird/*.default/chrome.

Here is the userChrome.css I've been trying to get to work:

* Do not remove the @namespace line -- it's required for correct functioning
*/

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ /*

* Make all the default font sizes 20 pt:
*/
  • {
 font-size: 14pt !important;
 font-family: Verdana !important;

} /* change font size of menu items */ menupopup > *, popup > * {

 font-size: 18pt !important;

} /* change font size of menu items */ menubar > menu * {

 font-size: 18pt !important;

}

Is there a way to look at the log?

Thanks for replying. I changed legacyUserProfileCustomizations.stylesheets to true, but Thunderbird is still ignoring my userChrome.css. userChrome.css is located in my home directory under .thunderbird/*.default/chrome. Here is the userChrome.css I've been trying to get to work: * * Do not remove the @namespace line -- it's required for correct functioning */ @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */ /* * Make all the default font sizes 20 pt: */ * { font-size: 14pt !important; font-family: Verdana !important; } /* change font size of menu items */ menupopup > *, popup > * { font-size: 18pt !important; } /* change font size of menu items */ menubar > menu * { font-size: 18pt !important; } Is there a way to look at the log?
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1699 Atsakymų: 8253

Here is a similar file I pieced together from various sources. Tested and working in TB 68.2.2.

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

/* Menu Bar font */
menubar > menu
{ font-size: 18pt !important;
}

/* Submenus and context menus font */
menupopup,popup {
    font-size: 12pt !important;
}

/* Folder Pane font */
#folderTree > treechildren {
  font-size: 12pt !important;
  font-family: Verdana !important;
}

/*  Threads Pane font */
.tree-rows {
    font-size: 12pt !important;
    font-family: Verdana !important;
}

I think the last section will also work for the Folder Pane, if the previous section is omitted. The last declaration overrides any previous ones.

Here is a similar file I pieced together from various sources. Tested and working in TB 68.2.2. <pre> @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* Menu Bar font */ menubar > menu { font-size: 18pt !important; } /* Submenus and context menus font */ menupopup,popup { font-size: 12pt !important; } /* Folder Pane font */ #folderTree > treechildren { font-size: 12pt !important; font-family: Verdana !important; } /* Threads Pane font */ .tree-rows { font-size: 12pt !important; font-family: Verdana !important; } </pre> I think the last section will also work for the Folder Pane, if the previous section is omitted. The last declaration overrides any previous ones.

Modified by sfhowes

Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Thanks for trying, but it still isn't working.

I changed my userChrome.css file to the one you supplied but changed the fonts to huge and it hasn't changed anything.

Any idea where to go from here?

Thanks for trying, but it still isn't working. I changed my userChrome.css file to the one you supplied but changed the fonts to huge and it hasn't changed anything. Any idea where to go from here?
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1699 Atsakymų: 8253

Are you sure the userChrome.css file is in the chrome folder, which must be a subfolder of the active profile folder? Help/Troubleshooting Information, click Open Folder to open the active profile folder. You may have more than one profile folder, even if only one is used, after updating to TB 68. I can't think of any reason why the script would work in W10 but not in Linux.

Are you sure the userChrome.css file is in the chrome folder, which must be a subfolder of the active profile folder? Help/Troubleshooting Information, click Open Folder to open the active profile folder. You may have more than one profile folder, even if only one is used, after updating to TB 68. I can't think of any reason why the script would work in W10 but not in Linux.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

I just checked the profile folder as you suggested and browsed directly to userChrome.css.

The file is in the right place.

I found some legacy add ons, including one of the font changers. I disabled it. That didn't help either.

ExQuilla won't go away though. It says it will be uninstalled when I restart thunderbird, but restarting doesn't seem to be working. I wonder if there is a residual thread preventing that from working. Let me look...

That was it. There was a dead thunderbird thread hanging around and preventing the css file from being read. I killed it and now the fonts have changed. Now I need to get the preview pane to have a bigger font.

Thanks much for your help.

I just checked the profile folder as you suggested and browsed directly to userChrome.css. The file is in the right place. I found some legacy add ons, including one of the font changers. I disabled it. That didn't help either. ExQuilla won't go away though. It says it will be uninstalled when I restart thunderbird, but restarting doesn't seem to be working. I wonder if there is a residual thread preventing that from working. Let me look... That was it. There was a dead thunderbird thread hanging around and preventing the css file from being read. I killed it and now the fonts have changed. Now I need to get the preview pane to have a bigger font. Thanks much for your help.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Okay. Let me continue.

I made the mistake of trying a dark mode theme on Plasma.

Thunderbird copied it and now I can't get the preview pane to switch back to light mode. I'm guessing I need to reboot. The biggest issue is the I bar is teeny and RED so I can't see it on the dark background. I switched back to light mode using the settings in Thunderbird, but the preview pane is still in dark mode.

Also, the font in the preview pane is too small. What's the css voodoo to increase it?

You guys really need to design a plugin or just add these features to Thunderbird. Changing the look and feel is important and how it's done for thunderbird sets a high bar for average users, a bar they'll refuse to jump.

Okay. Let me continue. I made the mistake of trying a dark mode theme on Plasma. Thunderbird copied it and now I can't get the preview pane to switch back to light mode. I'm guessing I need to reboot. The biggest issue is the I bar is teeny and RED so I can't see it on the dark background. I switched back to light mode using the settings in Thunderbird, but the preview pane is still in dark mode. Also, the font in the preview pane is too small. What's the css voodoo to increase it? You guys really need to design a plugin or just add these features to Thunderbird. Changing the look and feel is important and how it's done for thunderbird sets a high bar for average users, a bar they'll refuse to jump.
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1699 Atsakymų: 8253

Fonts for the Message Pane (preview pane) are best adjusted through Edit/Preferences/Display/Formatting/Fonts & Colors/Advanced... Set the fonts and sizes with Fonts for:Latin and repeat with Fonts for:Other Writing Systems. Uncheck 'Allow messages to use other fonts'.

Another method using userContent.css:

http://forums.mozillazine.org/viewtopic.php?p=14767124&sid=f96452d1c0bb60eaef05ad7a9289015a#p14767124

Fonts for the Message Pane (preview pane) are best adjusted through Edit/Preferences/Display/Formatting/Fonts & Colors/Advanced... Set the fonts and sizes with Fonts for:Latin and repeat with Fonts for:Other Writing Systems. Uncheck 'Allow messages to use other fonts'. Another method using userContent.css: http://forums.mozillazine.org/viewtopic.php?p=14767124&sid=f96452d1c0bb60eaef05ad7a9289015a#p14767124
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Thanks!

That worked for the fonts. Now I just gotta get rid of dark mode in the preview pane.

Thanks! That worked for the fonts. Now I just gotta get rid of dark mode in the preview pane.
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1699 Atsakymų: 8253

Chosen Solution

The background color, at least for plain text messages, can be set under .../Display/Formatting/Fonts & Colors/Colors... You may have to adjust the override setting.

The background color, at least for plain text messages, can be set under .../Display/Formatting/Fonts & Colors/Colors... You may have to adjust the override setting.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

Unchecking "Use System Colors" fixed it.

It looks like it doesn't detect system color changes.

The weird thing is: I went back to try to check it again to see if it would update to system colors and I can't check the box at all now.

But, it's working for now.

I really appreciate you taking the time to help me out. Thanks so much!

Unchecking "Use System Colors" fixed it. It looks like it doesn't detect system color changes. The weird thing is: I went back to try to check it again to see if it would update to system colors and I can't check the box at all now. But, it's working for now. I really appreciate you taking the time to help me out. Thanks so much!
Was this helpful to you?
Citata
Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.