X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Security exception dialog appears on imap account with known certificate and ca

  • Atsakymų nėra
  • 1 has this problem
  • 3 peržiūros
Paskelbta

Hello everyone

I have a new installation of TB 68.1.2 on a pc running Windows 10 (let's call it PC1) and I am trying to set up an IMAP account on a local mail server.

Some background information: The server accepts TLS connections on standard port 993, using a certificated signed by my own CA, and works flawlessly with other clients. The CA certificate is correctly installed in Thunderbird on PC1, and the IMAP account is created without problems. No antivirus potentially intercepting SSL connections is running. Moreover, another machine (say PC2) with a similar configuration (OS: Win10, TB version: 68.1.0) works correctly.

The problem is that whenever TB connects to the server from PC1, a "Add security exception" dialog appears, complaining that the certificate is not valid (wrong site). To me the culprit is the string in the text field, which is "mail.mydomain.net:993": in fact, if I remove ":993" from that string TB is able to get the right certificate, but there seems to be no way to make the corrected string permanent, and the only option is to cancel the dialog window, bringing me back to the starting point.

Is this some sort of bug, or am I doing something wrong?

Thanks in advance for any help.

PS: the text in the attached images is in italian, which is my native language. "Sito errato" stands for "Wrong site".

Hello everyone I have a new installation of TB 68.1.2 on a pc running Windows 10 (let's call it PC1) and I am trying to set up an IMAP account on a local mail server. Some background information: The server accepts TLS connections on standard port 993, using a certificated signed by my own CA, and works flawlessly with other clients. The CA certificate is correctly installed in Thunderbird on PC1, and the IMAP account is created without problems. No antivirus potentially intercepting SSL connections is running. Moreover, another machine (say PC2) with a similar configuration (OS: Win10, TB version: 68.1.0) works correctly. The problem is that whenever TB connects to the server from PC1, a "Add security exception" dialog appears, complaining that the certificate is not valid (wrong site). To me the culprit is the string in the text field, which is "mail.mydomain.net:993": in fact, if I remove ":993" from that string TB is able to get the right certificate, but there seems to be no way to make the corrected string permanent, and the only option is to cancel the dialog window, bringing me back to the starting point. Is this some sort of bug, or am I doing something wrong? Thanks in advance for any help. PS: the text in the attached images is in italian, which is my native language. "Sito errato" stands for "Wrong site".
Pridėtos ekrano nuotraukos
Citata

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.