X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Firefox is not diconnecting from a website (my bank) even though the website states that I have disconnected.

Paskelbta

I am using firefox 70.0 on Imac OSX 10.11.6. When I disconnect from my banks website it states you have been disconnected. But even if I close the tab then open a new tab. Go to the banks page it takes be straight to by account as if I was never logged out. I also use Safari on the same iMac and I do not have the same problem.

I am using firefox 70.0 on Imac OSX 10.11.6. When I disconnect from my banks website it states you have been disconnected. But even if I close the tab then open a new tab. Go to the banks page it takes be straight to by account as if I was never logged out. I also use Safari on the same iMac and I do not have the same problem.
Citata

Papildomi duomenys apie sistemą

Įdiegti papildiniai

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Dinushi Dhananjani
  • Top 25 Contributor
Sprendimų: 3 Atsakymų: 176
[http://example.com https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac?&mobile=0]
Was this helpful to you? 0
Citata

Klausimą uždavęs asmuo

Thanks for taking the time to reply. Are you suggesting if I reload Firefox from scratch the problem will be solved? However When I select your link an “example domain” page opens with the following txt:-

“This domain is for use in illustrative examples in documents. You may use this domain in literature without prior coordination or asking for permission.

More information...”

More information takes me to here. https://www.iana.org/domains/reserved

What is going on? All very strange.

Thanks for taking the time to reply. Are you suggesting if I reload Firefox from scratch the problem will be solved? However When I select your link an “example domain” page opens with the following txt:- “This domain is for use in illustrative examples in documents. You may use this domain in literature without prior coordination or asking for permission. More information...” More information takes me to here. https://www.iana.org/domains/reserved What is going on? All very strange.
Was this helpful to you?
Citata
Senali Madawala
  • Top 25 Contributor
Sprendimų: 1 Atsakymų: 151

Click on the "Tools" menu and select "Options." Click on the security icon at the top of the window. Click on the "Exceptions" button and add all websites you want Firefox to allow. Click on "Allow" and then "Close" to finish the process.

https://support.mozilla.org/en-US/kb/fix-problems-connecting-websites-after-updating

Click on the "Tools" menu and select "Options." Click on the security icon at the top of the window. Click on the "Exceptions" button and add all websites you want Firefox to allow. Click on "Allow" and then "Close" to finish the process. https://support.mozilla.org/en-US/kb/fix-problems-connecting-websites-after-updating
Was this helpful to you? 0
Citata

Klausimą uždavęs asmuo

Thanks for trying but I am confused, very.

The "tools" menu has the following options Downloads, Add-ons, Sign in to sync, Web Developer and Page Info.

Under Preferences I have Privacy And Security. I have been through all the options and reloaded tabs and Firefox and the problem persists.

I cannot log out of by Banks webpage. This is infuriating as my wife and I have accounts at the same bank. Works fine in Safari

Thanks for trying but I am confused, very. The "tools" menu has the following options Downloads, Add-ons, Sign in to sync, Web Developer and Page Info. Under Preferences I have Privacy And Security. I have been through all the options and reloaded tabs and Firefox and the problem persists. I cannot log out of by Banks webpage. This is infuriating as my wife and I have accounts at the same bank. Works fine in Safari
Was this helpful to you?
Citata
jscher2000
  • Top 10 Contributor
Sprendimų: 8783 Atsakymų: 71835

Hi Andy, "Options" is the Windows name for "Preferences". However, I don't think you have a problem with blocked websites, so you can skip that suggestion.

If instead of closing the tab, you try to get into the site using the Back button (or long-press drop-down list on the Back button), does that work or is that blocked?

There are not a lot of ways this could happen:

(1) Auto-login

If you have Firefox's Password Manager enabled and your bank login saved, Firefox may be automatically logging you back in. I suggest deleting this login in that case.

On the "3-bar" menu, click Logins and Passwords to access any saved logins.

If you use another password manager, check its settings, too.

(2) Cookies not updating correctly

Two things typically happen when you log out of a well-run secure site:

(i) Your session token is invalidated, so that even if you were to present the same session cookies, the site would require a new login

(ii) The session cookies are deleted or cleared on your browser

Even if (ii) isn't happening, as long as the site does (i), it shouldn't let you come back to the site without a fresh login.

Hi Andy, "Options" is the Windows name for "Preferences". However, I don't think you have a problem with blocked websites, so you can skip that suggestion. If instead of closing the tab, you try to get into the site using the Back button (or long-press drop-down list on the Back button), does that work or is that blocked? There are not a lot of ways this could happen: (1) Auto-login If you have Firefox's Password Manager enabled and your bank login saved, Firefox may be automatically logging you back in. I suggest deleting this login in that case. On the "3-bar" menu, click Logins and Passwords to access any saved logins. ''If you use another password manager, check its settings, too.'' (2) Cookies not updating correctly Two things typically happen when you log out of a well-run secure site: (i) Your session token is invalidated, so that even if you were to present the same session cookies, the site would require a new login (ii) The session cookies are deleted or cleared on your browser Even if (ii) isn't happening, as long as the site does (i), it shouldn't let you come back to the site without a fresh login.
Was this helpful to you?
Citata
cor-el
  • Top 10 Contributor
  • Moderator
Sprendimų: 17567 Atsakymų: 158879

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

jscher2000 said

Hi Andy, "Options" is the Windows name for "Preferences". However, I don't think you have a problem with blocked websites, so you can skip that suggestion. If instead of closing the tab, you try to get into the site using the Back button (or long-press drop-down list on the Back button), does that work or is that blocked? There are not a lot of ways this could happen: (1) Auto-login If you have Firefox's Password Manager enabled and your bank login saved, Firefox may be automatically logging you back in. I suggest deleting this login in that case. On the "3-bar" menu, click Logins and Passwords to access any saved logins. If you use another password manager, check its settings, too. (2) Cookies not updating correctly Two things typically happen when you log out of a well-run secure site: (i) Your session token is invalidated, so that even if you were to present the same session cookies, the site would require a new login (ii) The session cookies are deleted or cleared on your browser Even if (ii) isn't happening, as long as the site does (i), it shouldn't let you come back to the site without a fresh login.

Hi and thanks for helping. I do not have the banks passowords saved in Firefox nor any other password manager. If I use the back button I can go back to the Banks homepage (not my account page) where I can select Are You Already A Client. This takes me straight into the previously open account without having to log in.

The only way I can prevent this is to Clear Recent History.

By the way I am in France and the Bank is one of the largest here and I havebeen using for 12+ years.

''jscher2000 [[#answer-1264257|said]]'' <blockquote> Hi Andy, "Options" is the Windows name for "Preferences". However, I don't think you have a problem with blocked websites, so you can skip that suggestion. If instead of closing the tab, you try to get into the site using the Back button (or long-press drop-down list on the Back button), does that work or is that blocked? There are not a lot of ways this could happen: (1) Auto-login If you have Firefox's Password Manager enabled and your bank login saved, Firefox may be automatically logging you back in. I suggest deleting this login in that case. On the "3-bar" menu, click Logins and Passwords to access any saved logins. ''If you use another password manager, check its settings, too.'' (2) Cookies not updating correctly Two things typically happen when you log out of a well-run secure site: (i) Your session token is invalidated, so that even if you were to present the same session cookies, the site would require a new login (ii) The session cookies are deleted or cleared on your browser Even if (ii) isn't happening, as long as the site does (i), it shouldn't let you come back to the site without a fresh login. </blockquote> Hi and thanks for helping. I do not have the banks passowords saved in Firefox nor any other password manager. If I use the back button I can go back to the Banks homepage (not my account page) where I can select Are You Already A Client. This takes me straight into the previously open account without having to log in. The only way I can prevent this is to Clear Recent History. By the way I am in France and the Bank is one of the largest here and I havebeen using for 12+ years.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

cor-el said

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.
  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.
You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Hi and thanks for helping. I have closed firefox and cleared the cookkies files as instructed. Problem still persists. I have also Refreshed Firefox, removed all Add-Ons and problem persists.

I have also logged a call with the Bank but as it works fine in Safari and I do not hold out much hope of the Bank having a solution. I might have to rsign myself to using Safari for accessing the bank.

''cor-el [[#answer-1264296|said]]'' <blockquote> If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles </blockquote> Hi and thanks for helping. I have closed firefox and cleared the cookkies files as instructed. Problem still persists. I have also Refreshed Firefox, removed all Add-Ons and problem persists. I have also logged a call with the Bank but as it works fine in Safari and I do not hold out much hope of the Bank having a solution. I might have to rsign myself to using Safari for accessing the bank.
Was this helpful to you?
Citata
jscher2000
  • Top 10 Contributor
Sprendimų: 8783 Atsakymų: 71835

Could you try expanding the details for "Clear Recent History" and using ONLY the checkbox for "Active Logins" (sorry, I don't know what it is called in French).

Could you try expanding the details for "Clear Recent History" and using ONLY the checkbox for "Active Logins" (sorry, I don't know what it is called in French). <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-11-05-07-56-20-8d8ada.png">
Was this helpful to you?
Citata
cor-el
  • Top 10 Contributor
  • Moderator
Sprendimų: 17567 Atsakymų: 158879

Actively log out or clearing the cookies for this website (domain) should log you out. Note that clearing cookies will not clear the session ID stored on the server. There can be third-party cross domain issues that cause logging out to fail.

I think that "Active logins" only applies if you login to a server using basic authentication like you do with FTP server (you get a pop-up to enter username and password). In all other cases this is done via a cookie or an authentication token possibly send via a GET parameter (session ID) appended to the URL that is send with the request.

Actively log out or clearing the cookies for this website (domain) should log you out. Note that clearing cookies will not clear the session ID stored on the server. There can be third-party cross domain issues that cause logging out to fail. I think that "Active logins" only applies if you login to a server using basic authentication like you do with FTP server (you get a pop-up to enter username and password). In all other cases this is done via a cookie or an authentication token possibly send via a GET parameter (session ID) appended to the URL that is send with the request.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

jscher2000 said

Could you try expanding the details for "Clear Recent History" and using ONLY the checkbox for "Active Logins" (sorry, I don't know what it is called in French).

Hi, Logged in this morning, disconnected, cleared only active logins suggestion, returned to to the site and straight into my open account.

So I then tried clearing each of the checkboxes in turn. When I checked just the cookies box and try to get into the Banks login page I get this EM :-

Not Found The requested URL /SEEA-pa01/devServer/INTO_FACADE ERROR: JDF_GENERIC_EXCEPTION was not found on this server.

I have raised this issue with the bank who maintain it is a local issue with my computer settings.

''jscher2000 [[#answer-1264481|said]]'' <blockquote> Could you try expanding the details for "Clear Recent History" and using ONLY the checkbox for "Active Logins" (sorry, I don't know what it is called in French). <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-11-05-07-56-20-8d8ada.png"> </blockquote> Hi, Logged in this morning, disconnected, cleared only active logins suggestion, returned to to the site and straight into my open account. So I then tried clearing each of the checkboxes in turn. When I checked just the cookies box and try to get into the Banks login page I get this EM :- ''Not Found The requested URL /SEEA-pa01/devServer/INTO_FACADE ERROR: JDF_GENERIC_EXCEPTION was not found on this server.'' I have raised this issue with the bank who maintain it is a local issue with my computer settings.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

cor-el said

Actively log out or clearing the cookies for this website (domain) should log you out. Note that clearing cookies will not clear the session ID stored on the server. There can be third-party cross domain issues that cause logging out to fail. I think that "Active logins" only applies if you login to a server using basic authentication like you do with FTP server (you get a pop-up to enter username and password). In all other cases this is done via a cookie or an authentication token possibly send via a GET parameter (session ID) appended to the URL that is send with the request.

Hi and thanks for your help. The problem only exists on FF. Safari logs me out correcty. I have logged another call with the bank but as it was dismissed as a local issue last time and as it works on Safari I do not expect them to help.

For now I will have to use Safari to access the bank. I have both browsers on the iMac so this is no great issue.

Perhaps he next release of FF will solve the problem.

''cor-el [[#answer-1264614|said]]'' <blockquote> Actively log out or clearing the cookies for this website (domain) should log you out. Note that clearing cookies will not clear the session ID stored on the server. There can be third-party cross domain issues that cause logging out to fail. I think that "Active logins" only applies if you login to a server using basic authentication like you do with FTP server (you get a pop-up to enter username and password). In all other cases this is done via a cookie or an authentication token possibly send via a GET parameter (session ID) appended to the URL that is send with the request. </blockquote> Hi and thanks for your help. The problem only exists on FF. Safari logs me out correcty. I have logged another call with the bank but as it was dismissed as a local issue last time and as it works on Safari I do not expect them to help. For now I will have to use Safari to access the bank. I have both browsers on the iMac so this is no great issue. Perhaps he next release of FF will solve the problem.
Was this helpful to you?
Citata
jscher2000
  • Top 10 Contributor
Sprendimų: 8783 Atsakymų: 71835

Naudingas atsakymas

Hi Andy, just one last reality check: does the bank demand a new login if you quit Firefox and then try to access the bank after restarting it? Or does it let you right back in again?

Hi Andy, just one last reality check: does the bank demand a new login if you quit Firefox and then try to access the bank after restarting it? Or does it let you right back in again?
Was this helpful to you? 1
Citata

Klausimą uždavęs asmuo

jscher2000 said

Hi Andy, just one last reality check: does the bank demand a new login if you quit Firefox and then try to access the bank after restarting it? Or does it let you right back in again?

Hi, No if I close FF after disconnecting from Bank I have to login in again. I do tend to leave FF open with 3 or 4 tabs open the whole time. Maybe I need to change my working practices? Or stick with Safari just for banking.

''jscher2000 [[#answer-1264802|said]]'' <blockquote> Hi Andy, just one last reality check: does the bank demand a new login if you quit Firefox and then try to access the bank after restarting it? Or does it let you right back in again? </blockquote> Hi, No if I close FF after disconnecting from Bank I have to login in again. I do tend to leave FF open with 3 or 4 tabs open the whole time. Maybe I need to change my working practices? Or stick with Safari just for banking.
Was this helpful to you?
Citata
cor-el
  • Top 10 Contributor
  • Moderator
Sprendimų: 17567 Atsakymų: 158879

Do you shutdown the computer or do you leave the computer running ?

You can set browser.sessionstore.privacy_level to 2 (never) on the about:config page to disable saving cookies via session restore in the sessionstore.js file. The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values. Note that this only applies if you close (Quit/Exit) Firefox, otherwise you need to logout and not simply close tabs.

Do you shutdown the computer or do you leave the computer running ? You can set <b>browser.sessionstore.privacy_level</b> to 2 (never) on the <b>about:config</b> page to disable saving cookies via session restore in the sessionstore.js file. The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values. Note that this only applies if you close (Quit/Exit) Firefox, otherwise you need to logout and not simply close tabs.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

cor-el said

Do you shutdown the computer or do you leave the computer running ? You can set browser.sessionstore.privacy_level to 2 (never) on the about:config page to disable saving cookies via session restore in the sessionstore.js file. The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values. Note that this only applies if you close (Quit/Exit) Firefox, otherwise you need to logout and not simply close tabs.

the Imac is rarely switched of just put to sleep. I understand what you are saying, I think. ceratinly my way of operating has not changed just the version of FF. I would rather not close FF as mentioned above, nor switch off the iMac so using a different browser for banking is probably my preferred option at the moment.

Many thanks to you all.

''cor-el [[#answer-1264828|said]]'' <blockquote> Do you shutdown the computer or do you leave the computer running ? You can set <b>browser.sessionstore.privacy_level</b> to 2 (never) on the <b>about:config</b> page to disable saving cookies via session restore in the sessionstore.js file. The browser.sessionstore.privacy_level_deferred pref is used when you do not reopen the previous session automatically via "Show my windows and tabs from last time" and uses the same values. Note that this only applies if you close (Quit/Exit) Firefox, otherwise you need to logout and not simply close tabs. </blockquote> the Imac is rarely switched of just put to sleep. I understand what you are saying, I think. ceratinly my way of operating has not changed just the version of FF. I would rather not close FF as mentioned above, nor switch off the iMac so using a different browser for banking is probably my preferred option at the moment. Many thanks to you all.
Was this helpful to you?
Citata
Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.