Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blocks New York Times login

  • 4 replies
  • 1 has this problem
  • 8 views
  • Paskiausią atsakymą parašė bwp123

more options

Login to the New York Times is in a permanent loop. You login in the usual way, and the page loads without logging you in. It tries to sell me a subscription when I already have one. I have already cleared the cache and cookies and suffered having all of my websites broken by Firefox forcing us to re-login to everything on the web over and over because we have to go through the ritual of clearing cache and cookies over and over because Firefox is always malfunctioning. I have already permanently disabled "hardware acceleration" and have done all of these multiple times, numerous times. It's undoubtedly Firefox built in security devices that are causing this block. Chrome does not cause this, but there are other reasons not to use Chrome unless I have to, which is what I now have to do because of Firefox hyper-intrusive "security" software. If I could disable all the security bloat in Firefox, I would do so. It's just impossible. It does on month after month, year after year. We are prisoners of these device builders!

All Replies (4)

more options

I should also add that it is ONLY Firefox that now blocks all "Captchas" so that if you are accessing a secure website, you must use Chrome for those as well. Same old Firefox.

more options

I also cannot log in to the Wall Street Journal anymore on Firefox.

more options

Your System Details list shows some content blocking extensions, so maybe check that.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

As is generally the case, we are told to clear cookies and eliminate the cache. We are also told to turn off Firefox hyperactive content blocking. The problem then persists. The only way to log in to the NYTimes and Wall St Journal web sites is to use Chrome. I don't understand why the people at Firefox build the browser to do this to its users. But it cannot be overcome by these methods.