X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Thunderbird - How to delete email addresses appearing in the search field that don’t show up anywhere else

Paskelbta

Thunderbird 60.7.1.

When using Thunderbird’s search field, the autocomplete offers me some email addresses that are not in the address book, nor in any emails. How to get rid of them?

Thunderbird 60.7.1. When using Thunderbird’s search field, the autocomplete offers me some email addresses that are not in the address book, nor in any emails. How to get rid of them?

Chosen solution

Some confusion here. By 'autocomplete', I thought you meant the address autocomplete in the Write window when you enter the first few letters of a contact. But it turns out you are just searching for addresses using, I think, Global Search. If you are getting obsolete results, rebuild the database and see if it still happens.

https://support.mozilla.org/en-US/kb/rebuilding-global-database

Skaityti atsakymą kartu su kontekstu 1
Citata

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

FredMcD
  • Top 10 Contributor
Sprendimų: 4147 Atsakymų: 57876

Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Delete (Mac=Shift Delete). Repeat as needed.

Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press '''Delete ''(Mac=Shift Delete). ''''' Repeat as needed.
Was this helpful to you? 0
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1416 Atsakymų: 6716

Autocomplete searches all address books, and the most likely source of obsolete addresses is Collected Addresses.

Autocomplete searches all address books, and the most likely source of obsolete addresses is Collected Addresses.
Was this helpful to you? 0
Citata

Klausimą uždavęs asmuo

@FredMcD Thank you. The question is How to get rid of unwanted autocompleted email addresses in Thunderbird main search field. What you propose merely delete the entered characters. Typing them again proposes the same email that are not in any section of the addressbok.

@sfhowes Thank you. As written in my original question "the autocomplete offers me some email addresses that are not in the address book, nor in any emails."

@FredMcD Thank you. The question is How to get rid of unwanted autocompleted email addresses in Thunderbird main search field. What you propose merely delete the entered characters. Typing them again proposes the same email that are not in any section of the addressbok. @sfhowes Thank you. As written in my original question "the autocomplete offers me some email addresses '''that are not in the address book,''' nor in any emails."
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1416 Atsakymų: 6716

Yes, but did you check other address books besides Personal Address Book? I wonder if the Directory Pane, which shows all address books, is hidden in Address Book. It's under View/Layout; press Alt if the Menu Bar is hidden.

Yes, but did you check other address books besides Personal Address Book? I wonder if the Directory Pane, which shows all address books, is hidden in Address Book. It's under View/Layout; press Alt if the Menu Bar is hidden.
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

@sfhowes

Thank you for answer. I did check all address books, Collected addresses included.

Best

@sfhowes Thank you for answer. I did check all address books, Collected addresses included. Best
Was this helpful to you?
Citata
AgnesRM Sprendimų: 8 Atsakymų: 61

Hi Depending on your setup, you might be pulling addresses from a corporate address book. Try this - Options - Composition. In the second tab - Addressing - see if there are more than one address autocompletion box checked. Uncheck all except Local Address Books. Test and see if that excludes those mystery addresses. Hope that helps, Agnes

Hi Depending on your setup, you might be pulling addresses from a corporate address book. Try this - Options - Composition. In the second tab - Addressing - see if there are more than one address autocompletion box checked. Uncheck all except Local Address Books. Test and see if that excludes those mystery addresses. Hope that helps, Agnes
Was this helpful to you?
Citata

Klausimą uždavęs asmuo

@AgnesRM

Thank you for answer.

I do not connect to a corporate address book. Let me reiterate that in this case, I use the main search field (upper right corner). These "ghost" email addresses appear even if I do not select Local Address Books in Options. They seem to come from old deleted emails, even though Thunderbird doesn’t find any email matching the email addresses the search field gives me.

@AgnesRM Thank you for answer. I do not connect to a corporate address book. Let me reiterate that in this case, I use the main search field (upper right corner). These "ghost" email addresses appear even if I do not select Local Address Books in Options. They seem to come from old deleted emails, even though Thunderbird doesn’t find any email matching the email addresses the search field gives me.
Was this helpful to you?
Citata
AgnesRM Sprendimų: 8 Atsakymų: 61

I trust you did look at the page of setting I suggested - and uncheck all boxes except Local Address to make sure Thunderbird is not storing or retrieving any other addresses anywhere else. For example it may be storing all the emails for outgoing messages forever, if that box is checked. OK, well, that's all I have to suggest. So much depends on the individual email setup and options selected. Regards, Agnes

I trust you did look at the page of setting I suggested - and uncheck all boxes except Local Address to make sure Thunderbird is not storing or retrieving any other addresses anywhere else. For example it may be storing all the emails for outgoing messages forever, if that box is checked. OK, well, that's all I have to suggest. So much depends on the individual email setup and options selected. Regards, Agnes
Was this helpful to you?
Citata
sfhowes
  • Top 10 Contributor
Sprendimų: 1416 Atsakymų: 6716

Chosen Solution

Some confusion here. By 'autocomplete', I thought you meant the address autocomplete in the Write window when you enter the first few letters of a contact. But it turns out you are just searching for addresses using, I think, Global Search. If you are getting obsolete results, rebuild the database and see if it still happens.

https://support.mozilla.org/en-US/kb/rebuilding-global-database

Some confusion here. By 'autocomplete', I thought you meant the address autocomplete in the Write window when you enter the first few letters of a contact. But it turns out you are just searching for addresses using, I think, Global Search. If you are getting obsolete results, rebuild the database and see if it still happens. https://support.mozilla.org/en-US/kb/rebuilding-global-database
Was this helpful to you? 1
Citata

Klausimą uždavęs asmuo

@AgnesRM Thank you so much for your help.

@sfhowes I was not searching for addresses using Global Search. These ghost addresses were shown while I was using the Global Search looking for emails.

Rebuilding the Global Database did the trick. Thank you so much for your help.

@AgnesRM Thank you so much for your help. @sfhowes I was not searching for addresses using Global Search. These ghost addresses were shown while I was using the Global Search looking for emails. Rebuilding the Global Database did the trick. Thank you so much for your help.
Was this helpful to you?
Citata
Užduoti klausimą

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.