X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Thunderbird not retrieving new email automatically at startup

Paskelbta

I'm running Thunderbird 60.6.1, configured for 4 accounts on the following services: - msn.com - hotmail.com - comcast.net - gmail.com Servers for all accounts are configured as IMAP.

Thunderbird is not retrieving new email automatically at startup, even though "Check for new messages at startup" is ticked for all accounts. I do see - "Looking for folder...", "Opening folder..." etc. for all accounts on the status bar, but nothing is downloaded. When I then click "Get All New Messages", email for all accounts is immediately retrieved.

The "Activity Manager" log is completely blank.

I tried disabling all add-ons and restarting, same problem. For the sake of completeness, those are:

- CardBook by Philippe V: Alternative to built-in address book, which supports the vCard standard. Thunderbird does not, and I need the ability to import contact lists in that format.

- Check and Send by H.Ogi: I'm only using the feature of this add-on that confirms that I'm indeed ready to send when composing new email.

Here's one weird thing: When I start Thunderbird in safe mode, all new messages are immediately retrieved, whether I disable all add-ons are or not.

Any ideas? Thanks in advance for any advice!

I'm running Thunderbird 60.6.1, configured for 4 accounts on the following services: - msn.com - hotmail.com - comcast.net - gmail.com Servers for all accounts are configured as IMAP. Thunderbird is not retrieving new email automatically at startup, even though "Check for new messages at startup" is ticked for all accounts. I do see - "Looking for folder...", "Opening folder..." etc. for all accounts on the status bar, but nothing is downloaded. When I then click "Get All New Messages", email for all accounts is immediately retrieved. The "Activity Manager" log is completely blank. I tried disabling all add-ons and restarting, same problem. For the sake of completeness, those are: - CardBook by Philippe V: Alternative to built-in address book, which supports the vCard standard. Thunderbird does not, and I need the ability to import contact lists in that format. - Check and Send by H.Ogi: I'm only using the feature of this add-on that confirms that I'm indeed ready to send when composing new email. Here's one weird thing: When I start Thunderbird in safe mode, all new messages are immediately retrieved, whether I disable all add-ons are or not. Any ideas? Thanks in advance for any advice!

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

More Information

Toad-Hall
  • Top 10 Contributor
Sprendimų: 1767 Atsakymų: 11886

re :When I start Thunderbird in safe mode, all new messages are immediately retrieved, whether I disable all add-ons are or not.

Safe mode will fully disable all addons automatically, plus several other things.

Safe Mode temporarily affects the following:

  • All extensions are disabled.
  • The default theme is used, without a persona.
  • The Just-in-time (JIT) JavaScript compiler is disabled.
  • If userChrome.css and userContent.css files have been created then they are ignored.
  • The default toolbar layout is used.
  • Hardware acceleration is disabled.

Are you using the default theme? If no then select the default theme and restart Thunderbird to see it is the downloaded theme effecting Thunderbird.


See if hardware acceleration is usually switched on and causing an issue.

  • 'Menu icon' > 'Options' > 'Advanced' > 'General' tab
  • uncheck the checkbox 'Use hardware acceleration when available'
  • click on 'OK'
  • Restart Thunderbird.
re :''When I start Thunderbird in safe mode, all new messages are immediately retrieved, whether I disable all add-ons are or not. '' Safe mode will fully disable all addons automatically, plus several other things. Safe Mode temporarily affects the following: * All extensions are disabled. * The default theme is used, without a persona. * The Just-in-time (JIT) JavaScript compiler is disabled. * If userChrome.css and userContent.css files have been created then they are ignored. * The default toolbar layout is used. * Hardware acceleration is disabled. Are you using the default theme? If no then select the default theme and restart Thunderbird to see it is the downloaded theme effecting Thunderbird. See if hardware acceleration is usually switched on and causing an issue. * 'Menu icon' > 'Options' > 'Advanced' > 'General' tab * uncheck the checkbox 'Use hardware acceleration when available' * click on 'OK' * Restart Thunderbird.

Klausimą uždavęs asmuo

Yes, I'm using the default theme, and I disabled hardware acceleration long ago due to some other problems it was causing me (although I can't recall exactly what those were right now).

Perhaps it's the CSS files that are causing the problem. Anything to look for there, or could they possibly be reset to defaults?

Yes, I'm using the default theme, and I disabled hardware acceleration long ago due to some other problems it was causing me (although I can't recall exactly what those were right now). Perhaps it's the CSS files that are causing the problem. Anything to look for there, or could they possibly be reset to defaults?
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3251 Atsakymų: 22414

Craig G. said

Yes, I'm using the default theme, and I disabled hardware acceleration long ago due to some other problems it was causing me (although I can't recall exactly what those were right now). Perhaps it's the CSS files that are causing the problem. Anything to look for there, or could they possibly be reset to defaults?

I would suggest you disable the check and send add-on and see if your mail still has issues. I get my mail on time on startup and that add-on is one I do not have installed. It is unlikely that custom CSS would cause this sort of an issue. I would expect it to offer issues around buttons display etc. Not total failure of the get mail on startup.

''Craig G. [[#answer-1209847|said]]'' <blockquote> Yes, I'm using the default theme, and I disabled hardware acceleration long ago due to some other problems it was causing me (although I can't recall exactly what those were right now). Perhaps it's the CSS files that are causing the problem. Anything to look for there, or could they possibly be reset to defaults? </blockquote> I would suggest you disable the check and send add-on and see if your mail still has issues. I get my mail on time on startup and that add-on is one I do not have installed. It is unlikely that custom CSS would cause this sort of an issue. I would expect it to offer issues around buttons display etc. Not total failure of the get mail on startup.

Klausimą uždavęs asmuo

Ghosts in the darkness this morning... I just started TBird normally, and out of the blue it's once again now downloading new messages immediately, even with both of the add-ons I listed above installed and enabled. Weirdness.

The following is drifting off-topic a bit, but I wanted to mention it anyway... I still wish TBird had a simple option to prompt the user that they're indeed ready to send, like just about every other email client I've ever used. It's fairly easy to press the "Send" button when you instead meant to click a button next to it.

After doing a bit of exploration, I found a few other options I can use to basically accomplish the same thing without that add-on. Although they aren't exactly what I want, they're close:

1) Disable the composition toolbar altogether, which takes the "Send" button out of the picture and forces "File -> Send Now" to be used (although Ctrl+Enter will still be active, but that's much harder to do accidently). Unfortunately, this obviously hides the other buttons as well.

2) Customize the composition toolbar, and add "Flexible Space" between "Send" and other commonly used buttons.

3) Use "File -> Send Later", but that's about worthless for my purposes since I'd need to remember to use it every time I compose email. It also does nothing to prevent clicking "Send" accidentally.

Anyway, I've uninstalled "Check and Send" and gone with option #2 instead. That will definitely make it less likely to click "Send" by accident.

Thanks for the advice all, I definitely appreciate it!

Ghosts in the darkness this morning... I just started TBird normally, and out of the blue it's once again now downloading new messages immediately, even with both of the add-ons I listed above installed and enabled. Weirdness. The following is drifting off-topic a bit, but I wanted to mention it anyway... I still wish TBird had a simple option to prompt the user that they're indeed ready to send, like just about every other email client I've ever used. It's fairly easy to press the "Send" button when you instead meant to click a button next to it. After doing a bit of exploration, I found a few other options I can use to basically accomplish the same thing without that add-on. Although they aren't exactly what I want, they're close: 1) Disable the composition toolbar altogether, which takes the "Send" button out of the picture and forces "File -> Send Now" to be used (although Ctrl+Enter will still be active, but that's much harder to do accidently). Unfortunately, this obviously hides the other buttons as well. 2) Customize the composition toolbar, and add "Flexible Space" between "Send" and other commonly used buttons. 3) Use "File -> Send Later", but that's about worthless for my purposes since I'd need to remember to use it every time I compose email. It also does nothing to prevent clicking "Send" accidentally. Anyway, I've uninstalled "Check and Send" and gone with option #2 instead. That will definitely make it less likely to click "Send" by accident. Thanks for the advice all, I definitely appreciate it!
sfhowes
  • Top 10 Contributor
Sprendimų: 1556 Atsakymų: 7445

There is an add-on to delay sending by a user-defined time:

https://support.mozilla.org/en-US/questions/1240061

There is an add-on to delay sending by a user-defined time: https://support.mozilla.org/en-US/questions/1240061
DG Sprendimų: 1 Atsakymų: 14

Thunderbird won't automatically check for emails when it opens. I have to manually tell it to check: --the "server settings" have the box checked, "Check for new messages on startup". --"hardware acceleration" is turned off. --It won't check in "safe mode", either. --I've uninstalled it and reinstalled it, but nothing fixes the problem. This just started occurring with the download of 68.1.0.

Any ideas how I can fix this problem?

Thunderbird won't automatically check for emails when it opens. I have to manually tell it to check: --the "server settings" have the box checked, "Check for new messages on startup". --"hardware acceleration" is turned off. --It won't check in "safe mode", either. --I've uninstalled it and reinstalled it, but nothing fixes the problem. This just started occurring with the download of 68.1.0. Any ideas how I can fix this problem?

Klausimą uždavęs asmuo

No concrete fixes since my OP on 3/30/19. It's definitely not being caused by any of the plugins I'm running, I've tried disabling them all, and still have the same problem.

Another curious thing: If you select "Get All New Messages" right after start-up, it still doesn't detect any new email either. You have to leave TBird running for about 5 minutes, then re-try the same thing and behold, all new message headers are downloaded.

Seems like most definitely a bug of some sort, and one I've been fighting for quite a long time now.

No concrete fixes since my OP on 3/30/19. It's definitely not being caused by any of the plugins I'm running, I've tried disabling them all, and still have the same problem. Another curious thing: If you select "Get All New Messages" right after start-up, it still doesn't detect any new email either. You have to leave TBird running for about 5 minutes, then re-try the same thing and behold, all new message headers are downloaded. Seems like most definitely a bug of some sort, and one I've been fighting for quite a long time now.

Modified by Craig G.

Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3251 Atsakymų: 22414

Have you considered your anti virus might actually be the cause? Most of themselves part in the middle of the communication process (many act as a proxy) and they are generally responsible for more mail woes than they every save folks from. Mostly because they are not considered.

The stranded safe mode diagnostic that follows is designed to test anti virus involvement.

Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 10, Windows 8, Windows 7, Windows Vista, Windows XP, OSX

If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.
Have you considered your anti virus might actually be the cause? Most of themselves part in the middle of the communication process (many act as a proxy) and they are generally responsible for more mail woes than they every save folks from. Mostly because they are not considered. The stranded safe mode diagnostic that follows is designed to test anti virus involvement. Restart the operating system in '''[http://en.wikipedia.org/wiki/Safe_mode safe mode with Networking]'''. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: [https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode Windows 10], [http://windows.microsoft.com/en-us/windows-8/windows-startup-settings-safe-mode Windows 8], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-7 Windows 7], [http://windows.microsoft.com/en-us/windows/start-computer-safe-mode#start-computer-safe-mode=windows-vista Windows Vista], [http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx?mfr=true" Windows XP], [http://support.apple.com/kb/ht1564 OSX] ; If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.

Klausimą uždavęs asmuo

I can't speak for DG, but I'm well aware of what starting Windows in safe mode accomplishes (I'm running 10). I appreciate the suggestion, but I've tried it with no joy. I've also verified the executable has complete Internet access through my firewall.

I was really hoping version 68 would finally fix this problem (haven't migrated yet), but that's what DG reports he's running, with the same issue. Disappointing.

As I wrote in my OP, when I start Tbird itself in safe mode, the problem disappears with add-ons disabled or not. The "Activity Manager" log is completely empty when started normally, which points to Tbird sitting there doing nothing until forced to retrieve new messages manually.

All that said, it's not my anti-virus program causing the problem, or anything having to do with Windows itself. If it was, it would seem that retrieving new messages wouldn't work at all. More importantly, it wouldn't explain why I can click "Get All New Messages" a few minutes after starting Tbird and everything works fine from there on out, including downloading new incoming Email automatically.

DG, if you'd like to try this yourself to see if the problem goes away, simply hold down the shift key when you launch Tbird, which will start it in safe mode. While obviously that isn't any sort of permanent fix, I'd be curious to hear if things start working normally for you as well.

I can't speak for DG, but I'm well aware of what starting Windows in safe mode accomplishes (I'm running 10). I appreciate the suggestion, but I've tried it with no joy. I've also verified the executable has complete Internet access through my firewall. I was really hoping version 68 would finally fix this problem (haven't migrated yet), but that's what DG reports he's running, with the same issue. Disappointing. As I wrote in my OP, when I start Tbird itself in safe mode, the problem disappears with add-ons disabled or not. The "Activity Manager" log is completely empty when started normally, which points to Tbird sitting there doing nothing until forced to retrieve new messages manually. All that said, it's not my anti-virus program causing the problem, or anything having to do with Windows itself. If it was, it would seem that retrieving new messages wouldn't work at all. More importantly, it wouldn't explain why I can click "Get All New Messages" a few minutes after starting Tbird and everything works fine from there on out, including downloading new incoming Email automatically. DG, if you'd like to try this yourself to see if the problem goes away, simply hold down the shift key when you launch Tbird, which will start it in safe mode. While obviously that isn't any sort of permanent fix, I'd be curious to hear if things start working normally for you as well.

Klausimą uždavęs asmuo

DG, just noticed you tried it already, sorry about that. Guess I need to read posts a little closer too. ;^)

DG, just noticed you tried it already, sorry about that. Guess I need to read posts a little closer too. ;^)

Klausimą uždavęs asmuo

Well, I now have the opposite situation as DG, at least for the moment. Version 68.1.0 appears to have gone live on the download page, and after upgrading to it my problem has disappeared.

Sorry, I didn't note what release I upgraded from (60.something), but it was the most recent as of a few days ago. I didn't uninstall or anything like that, just upgraded the existing installation in-place.

Weirdness!

Well, I now have the opposite situation as DG, at least for the moment. Version 68.1.0 appears to have gone live on the download page, and after upgrading to it my problem has disappeared. Sorry, I didn't note what release I upgraded from (60.something), but it was the most recent as of a few days ago. I didn't uninstall or anything like that, just upgraded the existing installation in-place. Weirdness!
DG Sprendimų: 1 Atsakymų: 14

Opposite with me. I downgraded to an earlier version of Thunderbird, mainly because 2 calendar add-ons were incompatible with 68.1.0. (It was maybe because of those 2 add-ons that 68.1.0 was messed up for me.)

Anyway, after copying a profile from a backup computer that was compatible with the older version of Thunderbird, everything works well, again...start-up checking for mail and my calendar add-ons. Now my problem is that Thunderbird is set NOT to upgrade to any newer versions, which is not good.

Opposite with me. I downgraded to an earlier version of Thunderbird, mainly because 2 calendar add-ons were incompatible with 68.1.0. (It was maybe because of those 2 add-ons that 68.1.0 was messed up for me.) Anyway, after copying a profile from a backup computer that was compatible with the older version of Thunderbird, everything works well, again...start-up checking for mail and my calendar add-ons. Now my problem is that Thunderbird is set NOT to upgrade to any newer versions, which is not good.