Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gmail attachments only print in code.

  • 4 replies
  • 2 have this problem
  • Paskiausią atsakymą parašė BM72

more options

When I try to print pdf attachments in Gmail, it prints all the text in code even though it appears normal on the screen. When I print the attachments in other browsers, it works fine. I tried printing gmail attachments on Firefox with other computers and other printers and it still prints in code. I tried resetting my printer in Firefox, but this did not work. Any help would be appreciated!

All Replies (4)

more options

Hi BM72, is this problem only with PDFs from Gmail or Google Drive? Or with all PDFs displayed in Firefox?

As a workaround, and for best fidelity to the original if quality matters, I suggest opening the PDF in your external PDF viewer, such as Adobe Acrobat/Reader. On Firefox's PDF viewer, you should find a download button on the black toolbar to do that:

more options

It appears to just be Gmail PDF attachments. PDF's in Google Drive are fine, as well as PDF's from other web sources. I have no done an exhaustive test, however. I did figure out the "download" work-around to open the file in Adobe Acrobat to print it. I just didn't know if there was a way to still be able to print directly from Gmail like I used to be able to. Thanks for your input!! It's much appreciated!

more options

Hmm, does yours follow the same sequence as mine?

(1) Hover the attachment and click to load the preview overlay (first screenshot attached)

(2) Click the print icon above the preview on the right side to launch the PDF into the viewer in a new tab (second screenshot attached)

(3) PDF opens in the viewer and the Print dialog shows automatically (third screenshot attached)

Mine prints OK at that point, at least to my PDF capturing program.

more options

Yes, that is exactly how I do it on all the computers I'm trying on. It's so weird.