Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Flash doesn't activate. I have to activate it on each page every time.It doesn't offer the 'always' option. Can't view videos at all on some pages.

  • 5 replies
  • 9 have this problem
  • 4385 views
  • Paskiausią atsakymą parašė FredMcD

more options

Recently pages using Adobe Flash don't load. I get a message saying "this page requires Adobe Flash" and another asking "Do you want to activate Adobe Flash" Each time I have to choose Activate but it doesn't ask if I want to enable it always, it just does it the once and next time I load the page I have to do it again. Another issue that seems to be related is that I get a message saying "You must download Adobe Flash or enable it in your browser" on some pages that I have viewed before. One I tried tonight is : http://www.bbc.com/earth/story/20141103-hermit-crab but got the "You must download Adobe Flash or enable it in your browser" message. What's up? I read in the mozilla support chat that I must enable Flash but no clue where or how to do it. Thanks in advance.

Chosen solution

Your system details shows you have the current player.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Find Shockwave Flash, and press the Options button. Uncheck Enable Adobe Flash Protected Mode.

Also, make sure the player is set to Always Active.

Skaityti atsakymą kartu su kontekstu 👍 3

All Replies (5)

more options

Chosen Solution

Your system details shows you have the current player.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Find Shockwave Flash, and press the Options button. Uncheck Enable Adobe Flash Protected Mode.

Also, make sure the player is set to Always Active.

more options

Thanks so much. The solution you offered worked but I did get a message from Firefox saying that with the latest update Adobe Flash is no longer supported so it could cause instability and other problems. The Enable in Protected Mode was not an option but I was able to set to Always Active (not recommended by Firefox) so am happy with the result. Thanks again!

more options

celi1 said

I did get a message from Firefox saying that with the latest update Adobe Flash is no longer supported

That message should only be with old blocked versions.

Please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

I am attaching several screen shots to show the thread of messages and actions. Image 1 is the message I get that prompted my original post. I saw this message on this site after reading the solution and selecting Always Activate in the Shockwave preferences. Images 2 and 3 are the pages I was directed to when I selected More Info from the Activate screen. Image 4 shows the warning in the Learn More link in the Shockwave preference panel. Image 5 shows the Shockwave preference panel. Image 6 shows my Privacy settings - I've attached because I wonder if that could have something to do with the problem?

more options

Hmm, my flash is up to date but does not have those warnings. I guess they were added to Firefox 55