Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes

  • 2 replies
  • 1 has this problem
  • 4 views
  • Paskiausią atsakymą parašė cor-el

more options

I just bought a brand new desktop PC installed with latest version of window 10 Pro, all the drivers, anti-virus software are up to date. newly installed Firefox browser which is also the latest version, downloaded from Firefox official website.>> Crashes within 5 min of using it. and it has been crashing 3 times within the first 30 min of using. Tried every possible solution there is and still crashes. Can somebody please tell me what I can do to fix it.

Crash ID: bp-0e5b434c-59a4-4f88-a590-69f551170725 Crash ID: bp-251a0730-91d8-4e80-b986-d78220170725 Crash ID: bp-e864eb4d-e05d-4051-bed5-0ad350170725

I just bought a brand new desktop PC installed with latest version of window 10 Pro, all the drivers, anti-virus software are up to date. newly installed Firefox browser which is also the latest version, downloaded from Firefox official website.>> Crashes within 5 min of using it. and it has been crashing 3 times within the first 30 min of using. Tried every possible solution there is and still crashes. Can somebody please tell me what I can do to fix it. Crash ID: bp-0e5b434c-59a4-4f88-a590-69f551170725 Crash ID: bp-251a0730-91d8-4e80-b986-d78220170725 Crash ID: bp-e864eb4d-e05d-4051-bed5-0ad350170725

All Replies (2)

more options

It shows version 54 of Firefox here. Newest is 54.0.1 Download the complete full installer of Firefox here (it is not a stub) https://www.mozilla.org/en-US/firefox/all/ Uninstall Firefox then use the above installer.

Please also find the Windows Settings and then go to Update and see if there are updates still to bring in.

Please let us know if this solved your issue or if need further assistance.

more options

The crash report signatures show the current release (54.0.1), so that is OK.

  • Firefox 54.0.1 Crash Report [@ js::GCMarker::processMarkStackTop ]

When multi-process windows in Firefox is enabled then Firefox will use more memory and may be less responsive.

You can try this to see if it has effect:

  • set dom.ipc.processCount to 1 if it is currently set to a higher value (4)
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page: via the location/address bar. You can accept the warning and click "I'll be careful" to continue.