X
Bakstelėkite čia, kad pereitumėte į mobiliąją šios svetainės versiją.

Pagalbos forumas

Options/Remote Content button missing. permissions.default.image reverts to 2

Paskelbta

After recovering my email and calendar from a MozBackup file (I know, but it was all I had when the other computer s*** the bed) I have several funky things happening but missing the ability to allow (or not) remote content is the most annoying. None of the fixes I have found have worked. Is there a way to set all Configurations to default? Does anyone have a better fix?

After recovering my email and calendar from a MozBackup file (I know, but it was all I had when the other computer s*** the bed) I have several funky things happening but missing the ability to allow (or not) remote content is the most annoying. None of the fixes I have found have worked. Is there a way to set all Configurations to default? Does anyone have a better fix?

Chosen solution

re :the Defaults - Prefs folder contains 6 .js files in addition to the channel-prefs.js file. Interesting....I was under the impression that those sort of files were put into omni.ja file to help improve performance, so I was not expecting them to be in different places. They are in the omni.ja file in my installation.

I understand that you have been installing several times, but it looks as if you have installed on top of an older one to get those files in that folder.

Please work through every stage mentioned below in the order stated. I want to be certain that you have a clean install and no local cache interfering.

  • Please close Thunderbird now.

Access this file:

  • C:\Users\<Windows user name>\AppData\Local\Thunderbird\Profiles

It will contain your profile name folder, but not the one which Thunderbird uses to contain all your profile accounts, emails, etc. Windows creates it and uses it as a cache.

  • Please delete the profile name folder usually called 'xxxxxxxx.default' where the x's are letters and numbers.


Now access :

  • C:\Users\<Windows user name>\AppData\Roaming\Thunderbird\Profiles\<Profile name>\
  • open 'prefs.js' file using Notepad and make sure there is no mention of the user_pref
  • permissions.default.image

If there is, then please carefully remove that line and save the file.

  • Delete the following files - they will be auto recreated.

- * session.json - * xulstore.json


Some time back I mentioned completely uninstalling the program Please do this again.

via Control Panel > Programs & Features.

Then check it really has gone: This should not exist..depending upon whether you use 32bit or 64bit operating system

  • C:\Program Files\Mozilla Thunderbird\

nor

  • C:\Program Files (x86)\Mozilla Thunderbird\
  • Delete any previous program downloads, which may be in your 'Downloads' folder to prevent any confusion.

Download a completely fresh installation from here:

  • choose preferred language eg: en-GB is English British
  • download the 'Thunderbird Setup 45.3.0.exe' file

Then run that file to install Thunderbird. The windows appdata > local > Thunderbird > Profile folder will auto add a new folder for the profile name and put some cache folders in it.

Finally start Thunderbird and report back on the results.

Skaityti atsakymą kartu su kontekstu 1

Papildomi duomenys apie sistemą

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

More Information

Klausimą uždavęs asmuo

After setting permissions.default.image to 1 I checked Addons again. There is no option to remove TalkBack. Screen snip attached.

After setting '''permissions.default.image''' to 1 I checked Addons again. There is no option to remove TalkBack. Screen snip attached.

Klausimą uždavęs asmuo

Could this be related or a clue: Update not working (screen snip attached) I have reinstalled several times in the process of all this troubleshooting and in response to that notice last time i got it.

Could this be related or a clue: Update not working (screen snip attached) I have reinstalled several times in the process of all this troubleshooting and in response to that notice last time i got it.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

As the remote content button issue began after using a backup - not sure how old the backup was - but it is possble something came across in that prefs.js file or another file containing preferences.

As the prefs.js file will have some sensitive data in it, I would not advise that you post info in this forum, but if you do not mind, I could take a look to see what if anything is different to mine, but it would mean you sending a copy to me at the following email address: mail at anje dot co dot uk.

Could you tell me the following: When you go into options and select the 'Config editor' to alter 'permissions.default.image' , is it set as 'default' integer 2 ?

As the remote content button issue began after using a backup - not sure how old the backup was - but it is possble something came across in that prefs.js file or another file containing preferences. As the prefs.js file will have some sensitive data in it, I would not advise that you post info in this forum, but if you do not mind, I could take a look to see what if anything is different to mine, but it would mean you sending a copy to me at the following email address: mail at anje dot co dot uk. Could you tell me the following: When you go into options and select the 'Config editor' to alter 'permissions.default.image' , is it set as ''''default'''' integer 2 ?

Klausimą uždavęs asmuo

default.image is set to 2 every time I start Thunderbird (it reverts to 2 when I close the program) I'll send you the prefs.js file

'''default.image''' is set to 2 every time I start Thunderbird (it reverts to 2 when I close the program) I'll send you the prefs.js file
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

In the Config Editor anything that is in normal print will be 'default' and anything you select as otherwise will be set as 'User set' and will be in bold print.

I'm assuming in your config editor, the 'permissions.default.image' has a 'Status' set as 'default' in normal print but has 'value' set as 2 (instead of the expected 1)

Therefore, I'm assuming when you want to change it to a value of 1, it should become bold because it is now the 'Status' should be 'user set' and then would show up in the prefs.js file.

However, the 'prefs.js' file you sent does not show the user set preference. So either it is not writing to that file or you sent me a copy of the prefs.js file after closing Thunderbird by which time something had reset the preference back to the incorrect default, so next time it starts there is nothing in the 'prefs.js' file to use.

Please try the following:

Help > Troubleshooting Infomation click on 'Show folder' button

Close Thunderbird.

create a copy of the 'prefs.js' file and store on eg: desktop as a temp backup of original.

open 'prefs.js' file using Notepad. scroll down to the line:

  • user_pref("network.predictor.cleaned-up", true);

Then add the following line below it.

  • user_pref("permissions.default.image", 1);

so you now see:

  • user_pref("network.predictor.cleaned-up", true);
  • user_pref("permissions.default.image", 1);
  • user_pref("places.database.lastMaintenance", 1472419244);

Save the file.

Start Thunderbird.

I need to know if you start Thunderbird knowing that preference is written in the 'prefs.js' file, whether it sticks and works correctly upon starting the first time.

Assuming it works, then after a while exit Thunderbird and check to see if the line you added is still in the 'prefs.js' file.

Report back on results.

In the Config Editor anything that is in normal print will be 'default' and anything you select as otherwise will be set as ''''User set' '''and will be in bold print. I'm assuming in your config editor, the 'permissions.default.image' has a 'Status' set as 'default' in normal print but has 'value' set as 2 (instead of the expected 1) Therefore, I'm assuming when you want to change it to a value of 1, it should become bold because it is now the 'Status' should be 'user set' and then would show up in the prefs.js file. However, the 'prefs.js' file you sent does not show the user set preference. So either it is not writing to that file or you sent me a copy of the prefs.js file after closing Thunderbird by which time something had reset the preference back to the incorrect default, so next time it starts there is nothing in the 'prefs.js' file to use. Please try the following: Help > Troubleshooting Infomation click on 'Show folder' button Close Thunderbird. create a copy of the 'prefs.js' file and store on eg: desktop as a temp backup of original. open 'prefs.js' file using Notepad. scroll down to the line: * user_pref("network.predictor.cleaned-up", true); Then add the following line below it. * user_pref("permissions.default.image", 1); so you now see: * user_pref("network.predictor.cleaned-up", true); * user_pref("permissions.default.image", 1); * user_pref("places.database.lastMaintenance", 1472419244); Save the file. Start Thunderbird. I need to know if you start Thunderbird knowing that preference is written in the 'prefs.js' file, whether it sticks and works correctly upon starting the first time. Assuming it works, then after a while exit Thunderbird and check to see if the line you added is still in the 'prefs.js' file. Report back on results.

Klausimą uždavęs asmuo

Initial finding (I will go through your entire troubleshooting later, when I have more time): On opening Thunderbird; default.image in config editor is bold and the value is 2. After setting default.image to 1 manually the type face is not bold. It is acting like "I" am manually setting the value to 2 on startup. Strange.

Initial finding (I will go through your entire troubleshooting later, when I have more time): On opening Thunderbird; '''default.image''' in config editor is bold and the value is 2. After setting '''default.image''' to 1 manually the type face is not bold. It is acting like "I" am manually setting the value to 2 on startup. Strange.

Klausimą uždavęs asmuo

okay, followed the troubleshooting steps you gave.

After restarting Thunderbird: user_pref("permissions.default.image", 1); was still in the 'prefs.js' file. default.image was set to 2 (bold text).

I manually set default.image to 1 and read a few emails.

Closed and reopened Thunderbird. user_pref("permissions.default.image", 1); was no longer in the 'prefs.js' file. default.image was set to 2 (bold text).

I hope I did what you wanted and that this makes things clearer. I am totally confused as to what could be altering preferences and why.

okay, followed the troubleshooting steps you gave. After restarting Thunderbird: user_pref("permissions.default.image", 1); was still in the 'prefs.js' file. '''default.image''' was set to 2 (bold text). I manually set '''default.image''' to 1 and read a few emails. Closed and reopened Thunderbird. user_pref("permissions.default.image", 1); was no longer in the 'prefs.js' file. '''default.image''' was set to 2 (bold text). I hope I did what you wanted and that this makes things clearer. I am totally confused as to what could be altering preferences and why.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

RE: config editor...... permission.default.image was set to 2 (bold text). So,we assume the Status is set to 'User Set' - even though you have not set it as such. If 'Status' said 'locked' then it would explain why it could not be altered. On the other hand if not locked then it sounds like something is setting something like a sticky pref . Usually the 'prefs.js' file saves anything that is not set as default. So as the permissions.default image default should be 1, then that would explain why it was removed from the 'prefs.js' file.

It does not explain what other file is writing to the config editor, setting it as 'User set' yet not writing that to the 'prefs.js' file unless you did not fully uninstall all versions of thunderbird before downloading and installing a fresh install (eg: installed on top) and there is a file in the 'omni.ja' file which is overriding settings.

Please try this first:

  • Help > Troubleshooting Infomation
  • click on 'Show folder' button
  • Close Thunderbird.

You should see all the contents of your profile name folder. How many 'prefs.js' files (or variants) do you see? eg; 'prefs-n.js' where the 'n' is a number?

In previous comments, you were asked if you had a 'user.js' file in the profile name folder along with the 'prefs.js' You said no. Let's create one to see if those settings get overridden as well.

Open Notepad. insert the following line:

  • sticky_pref("permissions.default.image", 1);

Save the file as : user.js in the profile name folder - same place as the 'prefs.js' file.

Restart Thunderbird.

what results do you get?

After a while restart Thunderbird and report on results.

RE: ''config editor...... permission.default.image was set to 2 (bold text). '' So,we assume the Status is set to 'User Set' - even though you have not set it as such. If 'Status' said 'locked' then it would explain why it could not be altered. On the other hand if not locked then it sounds like something is setting something like a sticky pref . Usually the 'prefs.js' file saves anything that is not set as default. So as the permissions.default image default should be 1, then that would explain why it was removed from the 'prefs.js' file. It does not explain what other file is writing to the config editor, setting it as 'User set' yet not writing that to the 'prefs.js' file unless you did not fully uninstall all versions of thunderbird before downloading and installing a fresh install (eg: installed on top) and there is a file in the 'omni.ja' file which is overriding settings. Please try this first: * Help > Troubleshooting Infomation * click on 'Show folder' button * Close Thunderbird. You should see all the contents of your profile name folder. How many 'prefs.js' files (or variants) do you see? eg; 'prefs-n.js' where the 'n' is a number? In previous comments, you were asked if you had a 'user.js' file in the profile name folder along with the 'prefs.js' You said no. Let's create one to see if those settings get overridden as well. Open Notepad. insert the following line: * '''sticky_pref("permissions.default.image", 1); ''' Save the file as : '''user.js''' in the profile name folder - same place as the 'prefs.js' file. Restart Thunderbird. what results do you get? After a while restart Thunderbird and report on results.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

PS : If you use a Windows text editor, make sure you unhide extensions for known filetypes in Folder Options, so that the file isn't really called "user.js.txt".

PS : If you use a Windows text editor, make sure you unhide extensions for known filetypes in Folder Options, so that the file isn't really called "user.js.txt".

Klausimą uždavęs asmuo

  • There is only one prefs.js file
  • There is also a prefs.zal (see attached snip)
  • followed directions and restarted Thunderbird
  • found default.image set to 2, bold text
* There is only one prefs.js file * There is also a prefs.zal (see attached snip) * followed directions and restarted Thunderbird * found default.image set to 2, bold text
Matt
  • Top 10 Contributor
  • Moderator
Sprendimų: 3362 Atsakymų: 23313

did you do the user.js file? that locks the preference. it should not be possible to modify it.

did you do the user.js file? that locks the preference. it should not be possible to modify it.

Klausimą uždavęs asmuo

from prefs folder:

from prefs folder:
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

re: 'prefs.zal' file

Please open using Notepad and see if there is any mention of 'permissions.default.image'.

re: ''''prefs.zal' file''' Please open using Notepad and see if there is any mention of 'permissions.default.image'.

Klausimą uždavęs asmuo

I can't open the prefs.zal file. It is a very unusual file type. Should it be there at all?

I can't open the '''prefs.zal''' file. It is a very unusual file type. Should it be there at all?
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

I found a mention of it to do with mozbackup.

Access the profile name folder - make sure Thunderbird is closed. Move the 'prefs.zal' file out of the profile name folder and put onto desktop so there is no way it can be used.

The prefs.zal file should not be being used, but we need to rule out if that file is causing an issue, just in case it is in some way containing the permission.default.image 2.

then restart Thunderbird and test.

I found a mention of it to do with mozbackup. * https://github.com/JasnaPaka/mozbackup/blob/master/source/zaloha.pas Access the profile name folder - make sure Thunderbird is closed. Move the 'prefs.zal' file out of the profile name folder and put onto desktop so there is no way it can be used. The prefs.zal file should not be being used, but we need to rule out if that file is causing an issue, just in case it is in some way containing the permission.default.image 2. then restart Thunderbird and test.

Modified by Toad-Hall

Klausimą uždavęs asmuo

You are right, after removing prefs.zal the problem was unchanged. I see no adverse effect from removing it so I will leave it out.

You are right, after removing prefs.zal the problem was unchanged. I see no adverse effect from removing it so I will leave it out.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

confirm: Tools > Options > Privacy Mail content; Confirm this is Not selected: 'Allow remote content in messages'

Select the 'Advanced' > 'General' tab Last thing to check in 'Config editor' Locate 'permissions.default.image' right click on that line and select 'Reset'. close about:config window click on OK

Restart Thunderbird and see if that line is still reset as if a user pref set to 2.

confirm: Tools > Options > Privacy Mail content; Confirm this is Not selected: 'Allow remote content in messages' Select the 'Advanced' > 'General' tab Last thing to check in 'Config editor' Locate 'permissions.default.image' right click on that line and select 'Reset'. close about:config window click on OK Restart Thunderbird and see if that line is still reset as if a user pref set to 2.

Klausimą uždavęs asmuo

after following your directions, the line is still reset as if a user pref set to 2.

after following your directions, the line is still reset as if a user pref set to 2.
Toad-Hall
  • Top 10 Contributor
Sprendimų: 1840 Atsakymų: 12423

Please check this: If Windows 32 bit: C:\Program Files\Mozilla Thunderbird\

If Windows 64bit: C:\Program Files(x86)\Mozilla Thunderbird\

This is where the thunderbird.exe application file is located along with a load of .dll files etc.

make sure your computer 'folder options' is set to show all extensions. Organize > folder and search options > View uncheck 'hide extensions for known file types' clickon OK

Do you see any file with an extension .cfg eg: mozilla.cfg ?

click on 'defaults' folder click on 'prefs' folder there should only be 'channel-prefs.js' file Is there any other .js file ? If yes, open that .js file using 'Notepad' or 'Wordpad'. Post an image showing contents.

Please check this: If Windows 32 bit: C:\Program Files\Mozilla Thunderbird\ If Windows 64bit: C:\Program Files(x86)\Mozilla Thunderbird\ This is where the thunderbird.exe application file is located along with a load of .dll files etc. make sure your computer 'folder options' is set to show all extensions. Organize > folder and search options > View uncheck 'hide extensions for known file types' clickon OK Do you see any file with an extension '''.cfg''' eg: mozilla.cfg ? click on 'defaults' folder click on 'prefs' folder there should only be 'channel-prefs.js' file Is there any other .js file ? If yes, open that .js file using 'Notepad' or 'Wordpad'. Post an image showing contents.

Klausimą uždavęs asmuo

I see no >cfg file in the Mozilla Thunderbird folder.

the Defaults - Prefs folder contains 6 .js files in addition to the channel-prefs.js file. Images attached.

some folders were too large to make a reasonable image from Notepad

I see no''' >cfg''' file in the '''Mozilla Thunderbird''' folder. the '''Defaults - Prefs''' folder contains 6 .js files in addition to the '''channel-prefs.js''' file. Images attached. some folders were too large to make a reasonable image from Notepad