Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

WhyYour connection is not secure notice is diplayed for yahoo.com and google.com sites on windows 10 with firefox 45.0 but sites work with IE11 and windows edge

  • 6 replies
  • 13 have this problem
  • 9 views
  • Paskiausią atsakymą parašė cor-el

more options

The following occurs with Firefox 45 but not with IE11 or Microsoft Edge

Your connection is not secure The owner of www.google.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

Your connection is not secure The owner of www.yahoo.com has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. This site uses HTTP Strict Transport Security (HSTS) to specify that Firefox only connect to it securely. As a result, it is not possible to add an exception for this certificate.

All Replies (6)

more options

hi The_CUP, please see if the steps mentioned in How to troubleshoot security error codes on secure websites apply to your problem as well...

more options

Turning off encrypted connection scanning does allow the google and yahoo web sites to work but this does not solve the problem since I cannot utilize Safe Money on financial sites with this turned off. This problem is only noticed on the yahoo and google web pages on Windows 10 with firefox only.

more options

any change when you reinstall the kaspersky cert as it is described in that article as well?

more options

If the certificate is issued by your Kaspersky security software then you have two options:

You can import the Kaspersky root certificate in the Certificate Manager under the Authorities tab. You can find "(fake)Kaspersky Anti-Virus Personal Root Certificate.cer" in this folder:

  • "C:\ProgramData\Kaspersky Lab\AVP16.0.0\Data\Cert"

When prompted, place a tick on "Trust this CA to identify websites" trust bit to make the imported certificate work as a trusted root certificate to trust websites. Note that trust bits should only be set for a trusted root certificate and never for intermediate certificates.

more options

The error still occurs and so far it seems to be isolated only to these sites and only with firefox. https://www.yahoo.com https://www.google.com https://www.irs.com All other https sites I have encountered so far work fine

more options

Did you check the issuer of the certificates in those cases?