Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF reader in Firefox is not working, what should I do?

  • 8 replies
  • 15 have this problem
  • 9157 views
  • Paskiausią atsakymą parašė clanjlo

more options

Firefox is not opening PDF files. The tab remains blank and the PDF does not open. It keeps showing a dialog box saying "Open" and "Save", but it never opens.

Modified by clanjlo

Chosen solution

No, not Open with Firefox, you need to select the "Preview in Firefox" on the Options page. If Firefox doesn't follow that, the server might not be sending "application/pdf" as the content type. As a test, do you want to try this link:

http://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf

(Apologies for the typo in the original post!)

Skaityti atsakymą kartu su kontekstu 👍 1

All Replies (8)

more options

When you get the Open/Save/Cancel dialog, then Firefox will eventually close the blank tab.

When you click Open, what application are you specifying? Please don't point the PDF back to Firefox in that dialog, since that can create an infinite loop of failure to open the document.

more options

Oh, more generally, you can select to use Firefox's internal PDF viewer or a different viewer by default, on the Options page. This article has details on how to change the setting: View PDF files in Firefox or choose another viewer.

However, Firefox is looking for the server to indicate the file type is "application/pdf" in order to apply that setting. If the server indicates some other type, then Firefox will apply a different setting, which may be a generic behavior (for example, some unknown type of binary file that needs an external viewer).


Occasionally, the settings file that Firefox uses to store download actions becomes corrupted. Since it is difficult to edit, when there is a problem, we generally suggest renaming the file and allowing Firefox to rebuild it from the Windows registry. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to mimeTypes.old (or another name of your choosing, in case you decide to roll back this experiment).

Start Firefox back up again and return to the Options page to specify your PDF preference. Does that help?

more options

Yes, it closes. But it does not open PDF files.

I tried the solution you mentioned in other post, but I got the infinite loop. Maybe I am doing something wrong. Firefox was my default PDF reader, when suddenly it stopped working.

more options

Sorry, which solution did you try? The built-in viewer is called "Preview in Firefox" and should be safe to select (no loop), although it is not as advanced as some other viewers.

more options

Thank you for your help. I tried renaming the file MimeTypes.rdf. But the problem is that none of the PDF open with Firefox now. I used Firefox for all of them, even those I have in folders. So it is not "Open with Firefox"?

more options

Chosen Solution

No, not Open with Firefox, you need to select the "Preview in Firefox" on the Options page. If Firefox doesn't follow that, the server might not be sending "application/pdf" as the content type. As a test, do you want to try this link:

http://www.jeffersonscher.com/gm/Google-Hit-Hider-by-Domain_About_v160.pdf

(Apologies for the typo in the original post!)

Modified by jscher2000

more options

You can check the value of plugin.disable_full_page_plugin_for_types on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer). Also make sure that pdfjs.disabled is set to false.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Thank you very much! Now it is woking again. The built-in PDF viewer is fine and I am happy that I can use it again.