Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I enable H.264 and Webm VP8 in Firefox 42.0?

  • 6 replies
  • 1 has this problem
  • 8696 views
  • Paskiausią atsakymą parašė okayfrog

more options

I was fumblin' around in the about:config trying to get H.264 and MSE & H.264 enabled and I did get MSE & H.264 enabled, but not H.264. I also inadvertently disabled Webm VP8. Now I am unable to see YouTube videos in HTML, webm's, or stuff like this : http://gfycat.com/FineJubilantBoubou

I just get a green screen and if the video has audio, a buzzing noise.

It's very frustrating, and I would appreciate some assistance in getting these working again. Thank you.

Chosen solution

Started up Firefox in Safe Mode. Looking at YouTube's HTML5 page, H.264 and WebM VP8 were no longer red, so that means that the problem is an extension, correct? However, when I tried the webm above, it was still green.

EDIT: Oh wow, I'm an idiot. I had the "YouTube Flash Video Player" extension enabled. So now on the YouTube page, everything's blue.

HOWEVER, webm's and HTML5 content still gives me a green screen with a ringing noise.

EDIT2: Okay, found the solution. Had to set media.fragmented-mp4.use-blank-decoder to "false" in about:config and now everything's blue on YouTube for the first time and HTML5 content is working again.

Thanks for the assistance.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (6)

more options

You can check the media.*enabled prefs on the about:config page and possibly reset user set (bold) via the right-click context menu to the default value.

  • media.webm.enabled
  • media.mediasource.*

Note that it is best to be cautious with toggling prefs to enable features that are off by default. They may be off for a reason like no proper support on your computer.

That video is available in MP4 and WebM format if I check the code in the Inspector. I get the WebM version on Linux via copy video location.

more options

Still green in webm. Webm's and HTML5 videos were working just yesterday.

more options

So the WebM link I posted above isn't working?

more options

Nope. I can hit "play," but it's still a green screen.

more options

Try to delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Chosen Solution

Started up Firefox in Safe Mode. Looking at YouTube's HTML5 page, H.264 and WebM VP8 were no longer red, so that means that the problem is an extension, correct? However, when I tried the webm above, it was still green.

EDIT: Oh wow, I'm an idiot. I had the "YouTube Flash Video Player" extension enabled. So now on the YouTube page, everything's blue.

HOWEVER, webm's and HTML5 content still gives me a green screen with a ringing noise.

EDIT2: Okay, found the solution. Had to set media.fragmented-mp4.use-blank-decoder to "false" in about:config and now everything's blue on YouTube for the first time and HTML5 content is working again.

Thanks for the assistance.

Modified by okayfrog