Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pandora.com will not load using Firefox under Windows 8.1.

  • 2 replies
  • 2 have this problem
  • 320 views
  • Paskiausią atsakymą parašė bxs02205

more options

It worked using XP. Now I have to resort to using Explorer :-( to listen to music online. I hope there is a fix for this. I started using Firefox because I didn't like Explorer. Other web sites that I go to seem to work fine.

Please tell this can be fixed.

Chosen solution

What happens when you try get the site?

Did you already try check your plugins?

Can you access the website in safe mode?

Try get the most recent Firefox version:


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu and click History button, and then Clear Recent History... .
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Skaityti atsakymą kartu su kontekstu 👍 0

All Replies (2)

more options

Chosen Solution

What happens when you try get the site?

Did you already try check your plugins?

Can you access the website in safe mode?

Try get the most recent Firefox version:


Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Click the menu button New Fx Menu and click History button, and then Clear Recent History... .
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

more options

I update Flash as suggested by Pandora and it now works great. I was REALLY hoping I didn't have to go back to Explorer; and now it doesn't look like I will have to.

Thanks for your helpl