Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

Strange black and blue bar and New Tab location bar

  • 5 biyano
  • 3 eza na bankokoso oyo
  • 493 views
  • Eyano yasuka ya ErraticFox

more options

Hello, I have a few questions that have stumped me.

[1] For some reason I have a strange black bar between my tabs and my location bar. I thought it might be a border, but I have no idea as I've tried to remove borders on a lot of selectors and still nothing. Then again, I want my tabs off the aero windows-ish part. I've put my tabs below the location bar before, but all that did was make the location bar on the aero windows-ish part for some reason.

[2] How do I change the font-style for the location bar in the new tab? Before you start typing it's in italics and I'd like to make the font-style normal. I haven't got a clue on what selector that would be to fix that.

Here's an image of that strange black bar for question [1] http://content.screencast.com/users/ErraticFox/folders/Snagit/media/6eda3571-94f9-489e-b249-935f8af11a51/02.15.2014-19.21.png

Also, here's another picture of another strange blue bar under the location bar.

http://content.screencast.com/users/ErraticFox/folders/Snagit/media/6eefffb9-0724-479c-80ce-d47245cfd58c/02.15.2014-23.43.png

Ezalaki modifié na ErraticFox

All Replies (5)

more options
more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected
more options

I don't see why you guys want me to do this? I'm trying to customize my FireFox UI. I just can't find something...

more options

Let's see, you have customized Firefox and it not longer looks good to you, and now you want advice on fixing it. Is that correct?

Maybe the problem is with your code as posted here.
http://forums.mozillazine.org/viewtopic.php?p=13364711#p13364711

    @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

    #appmenu-button {
        display:none;
    }

    #star-button {
        display:none;
    }

    .dropmarker-icon {
        display: none;
    }

    #page-proxy-favicon {
        display: none;
    }

    .urlbar-stack {

        height: 23px;
    }

    #navigator-toolbox {
        background-color: #414141 !important;
    }

    #toolbar-menubar {
        background-color: #414141 !important;
    }

    #urlbar {
        background-color: #414141 !important;
        font-family: nu !important;
        font-size: 15px  !important;
        color: #b1b1b1;
        border-radius: 0px;
        border: 0px !important;
    }



    #go-button {
        display: none;
    }

    #nav-bar {
        background-image: none !important;
        background-color: #414141 !important;
    }


    #identity-box {
        display: none;
    }

    .tabbrowser-tab[selected=true] {
        color: #b1b1b1;
        border: 1px solid #414141 !important;
        font-family: nu !important;
        background-image: none !important;
        background-color: #414141;
    }

    .tabbrowser-tab {
        height: 30px;
        color: #b1b1b1;
        border: 1px solid #535353 !important;
        font-family: nu !important;
        background-image: none !important;
        background-color: #535353;
    }

    .tabs-newtab-button {
        background-image: none !important;
        border: 1px solid #414141 !important;
    }

    .tabs-newtab-button .toolbarbutton-icon {
        list-style-image: url('http://i.imgur.com/RpBAPjm.png');
    }

    .tab-close-button {
        list-style-image: url('http://i.imgur.com/BOfIB47.png');
        -moz-image-region: auto !important;
    }

    .tab-content {
        padding-right: 10px;
    }

    #notification-popup-box {
        display: none;
    }

    .tab-icon-image {
        display: none;
    }
       
    .tab-text.tab-label {
        margin-left: 10px !important;
        margin-right: 10px !important;
    }

    #PersonalToolbar {
        display: none !important;
    }

    .textbox-input-box.urlbar-input-box {
        font-style:normal !important;
    }

    #navigator-toolbox {
        border: 0px !important;
    }
more options

I don't see how it's a problem with my code, as I don't add borders. I've taken off a border for basically anything I've seen. I even went through my code just now and didn't see anything that effected this. I even tried to had border: 0px !important; to some relevant properties and nothing changed.