Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mulongo oyo etiyamaki na archive. Tuna motuna mosusu soki osengeli na lisalisi

When I try to watch movies on FF using Netflix I get a private browsing error preventing me from doing so even though I do not have private browsing activated/turned on. Solutions?

  • 4 biyano
  • 486 eza na bankokoso oyo
  • Eyano yasuka ya jessm79

more options

When I try to play a movie on Netflix I get an error telling me that Firefox's private browsing mode is restricting Netflix from storing settings on my computer.

The suggests were to click the Tools menu and select private browsing. My private browsing was not activated.

Or to click the Tools menu at the top of the browser and select Options, then Privacy and then Remember history. This setting was also as it should.

Additionally, I went into the history and made sure the permanent private browsing was unchecked and I cleared all cookies. Still Netflix is not working.

I called Netflix and they say that everything is streaming correctly from their end and it is this computer. I can watch Netflix on other computers or my TV on this network but not this computer.

I am at a loss at how to disengage private browsing when the private browsing does not appear to be engaged.

All Replies (4)

more options

This is not something I use, but as no-one else has answered some guesses that could help, try the usual suspects:

  • try clearing your cache and cookies [[how to clear the cache]
  • you have security software, or even adblockers that are affecting the site
  • you need to allow cookies and have not done so
  • it uses FlashPlayer and needs the flash cookies, or LSO (Locally Stored Objects) enabling from Adobe Flash Players options, or the Flash Player version needs updating.
  • it uses silverlight and that needs installing or updating
  • you have other extensions interfering, use Diagnose Firefox issues using Troubleshoot Mode but do not make changes when the list appears, just click on continue.

Or looking at a recent thread /questions/864297 maybe it is just not yet set-up to recognise firefox 6 [Note Firefox 7 will be out in about a weeks time, as the standard Release]

more options

I had this problem but finally managed to fix it. I pulled up my Microsoft Silverlight program, went into the application storage tab, and deleted the one from netflix, then went back tried netflix again and it's been working fine ever since.

more options

I had this problem as well, just right click on the error, and click Silverlight, go to the Application Storage tab, and check enable application storage located on the bottom left corner. Your movies should play after that. If that doesn't work uninstall then reinstall Silverlight, make FF remember history and make sure application storage is enabled on Silverlight.

more options

Thank you so much. I tried so many thingsand this simple task is what did the trick. Thanks a lot!!