Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Issues with video buffering on Youtube specific to Firefox browser on PC

more options

Greetings,

for the past few days I've been having issues with running videos on Youtube, specifically, with my current (speed-tested) 560 Mbps internet connection, videos on Youtube will stutter, or altogether stop to buffer, even though a big part of the video is already loaded according to the preload bar. Sometimes the preload bar will also just jump back to the current video time and start loading from there anew, and sometimes it will even stutter back and forth as if it has loaded about 30 seconds, but then the preload bar will jump back and forth 10 or 20 seconds really fast (flickering).

While that is happening with the preload bar, the video will either stutter for a second and continue, or audio will continue normally while video will freeze and then continue a few seconds later (skipping forward so it's in sync with audio) or it will altogether outright stop and start buffering (the circling indicator in the middle of the video) even though sometimes the entire video has already been fully preloaded, and the connection is still going strong.

I have tried reinstalling Chrome and on that browser that issue does not happen. On Firefox I have an Addblocker, but I have tried turning it off and even removing it from Firefox, as I hear there are issues with google allowing addblockers on browsers, but it made no difference.

I have a recording of the issue with and without the addblocker but it is a big file 159 MBs.

I hope you can provide any information on how to resolve this issue, as some videos on Youtube have been unwatchable these past few days. And I really don't want to switch back to Chrome, as I like and support what you are doing with an this independent browser.

Thank you in advance for your reply.

Greetings, for the past few days I've been having issues with running videos on Youtube, specifically, with my current (speed-tested) 560 Mbps internet connection, videos on Youtube will stutter, or altogether stop to buffer, even though a big part of the video is already loaded according to the preload bar. Sometimes the preload bar will also just jump back to the current video time and start loading from there anew, and sometimes it will even stutter back and forth as if it has loaded about 30 seconds, but then the preload bar will jump back and forth 10 or 20 seconds really fast (flickering). While that is happening with the preload bar, the video will either stutter for a second and continue, or audio will continue normally while video will freeze and then continue a few seconds later (skipping forward so it's in sync with audio) or it will altogether outright stop and start buffering (the circling indicator in the middle of the video) even though sometimes the entire video has already been fully preloaded, and the connection is still going strong. I have tried reinstalling Chrome and on that browser that issue does not happen. On Firefox I have an Addblocker, but I have tried turning it off and even removing it from Firefox, as I hear there are issues with google allowing addblockers on browsers, but it made no difference. I have a recording of the issue with and without the addblocker but it is a big file 159 MBs. I hope you can provide any information on how to resolve this issue, as some videos on Youtube have been unwatchable these past few days. And I really don't want to switch back to Chrome, as I like and support what you are doing with an this independent browser. Thank you in advance for your reply.

All Replies (2)

more options

Does it still happen in Troubleshoot Mode?

Helpful?

more options

Yes, unfortunately it still happens.

Helpful?

Tuna motuna

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.