Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

Why do address bar searches open my company's homepage sometimes?

  • 5 답장
  • 2 이 문제를 만남
  • 139 보기
  • 최종 답변자: markAlpha

more options

Sometimes using the address bar as the search field, like you would in Chrome, my company's homepage opens up instead of the term being routed through my default search provider. The default homepage is not set to the company's website.

모든 댓글 (5)

more options

hello, you can try the searchreset extension. in case it does not fix the issue then the search term is probably interpreted as url & is being sent to your company's domain name server, which might be giving back the company homepage in return when it doesn't know how to resolve the address. unfortunately there is no easy way around that, you'd have to change dns servers on your system but this will likely not be allowed or even possible without admin rights...

more options

Here's a wild guess: Does it only affect one-word searches? When you enter a single term (no spaces) in the url bar, Firefox may try www.yoursearchterm.com first, rather than submitting it as a search to Google. If that matches your company, or is not found, your proxy or DNS server may be re-routing to the company home page.


Edit: I see madperson beat me to that guess.

If you want to disable that feature (domain guessing), you could try changing a preference in the about:config preference editor.

(1) In a new tab, type or paste about:config in the url bar and press Enter. Click the button agreeing to be careful.

(2) In the filter box, type or paste fixup and pause while Firefox filters the list.

(3) Double click browser.fixup.alternate.enabled to change its value from true to false. The line should turn bold.

You're done with about:config. Type a one word search in the url bar to make sure the behavior has changed to running a search.

Success?

글쓴이 jscher2000 수정일시

more options

You may have an ISP that automatically redirects you to a search page if a DNS look up fails.
That takes the control from Firefox to do the normal keyword search like a Google I'm Lucky search.
In such cases you need to contact your ISP and ask for a DNS server to opt-out of that feature.
You can also check if there is a link on the search results page to go to your ISP and opt-out.

글쓴이 cor-el 수정일시

more options

Thanks for the reply, but it's not ISP related. It has happened while connected to various internet connections.

EDIT: I guess it's not a threaded convo., so this was meant for cor-el

글쓴이 markAlpha 수정일시

more options

You are right. It's working fine now, i.e., non-URL formatted text will route as a search, but it does seem to be one word syntax that causes the derp.

Your proposed solution sounds promising, but I am a little baffled as to why it is routing to the company homepage. Is it because the computer is registered to a specific domain, hence why, if something goes wrong, it just spits out the homepage and acts like everything's fine?

I can't quite figure out what specifically causes/triggers this glitch, because it only happens periodically and the internet connection seems to be working fine otherwise at the time.

I will try the about:config adjustment when it happens again. To see if that changes the behavior.

Thank you both madperson and jascher2000 for the response

글쓴이 markAlpha 수정일시