Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

When restarting firefox after a crash, how do I stop it from re-opening all web pages that were open at the time of the crash?

  • 3 답장
  • 25 이 문제를 만남
  • 2 보기
  • 최종 답변자: cor-el

more options

When firefox crashes, or if it hangs and I have to kill it, then when I go to restart it, it tries to re-open all pages that were open at the time it crashed or was killed. This is incredibly annoying, especially if one of the visited pages caused the crash or hang. It is also really annoying if some of the web pages happened to require passwords to log in, from multiple sites. In my case this occurs as I am frequently logged into multiple online educational web sites like ucsc-extension.edu and berkleemusic.com. In the login case you get multiple login prompt pop-ups with no way to correlate which pop-up goes with which web page. If there are a lot of them then it's a hopeless mess. This behavior is something that I never ever want and it infuriates me that not only is it the default behavior, it is something that there seems to be no way to turn off, at least via the configuration menus. Am I wrong? Is there a way to turn this off? If not can somebody either make it configurable or get rid if this fantastically idiotic behavior?

I suspect there's a command line option for this but on my Mac (or most systems these days) it's sort of "unnatural" to be starting programs like browsers by means other than a provided program start-up icon, which gives you no choice about the command line options. Besides, as a default behavior the current behavior is something I cannot conceive of ever wanting. I would rather have a poke in the eye with a sharp stick.


This happened

Every time Firefox opened

== firefox crashed

모든 댓글 (3)

more options

I have the same problem running under ubuntu 10.04 LTS.

more options

You can try this. In the address bar type about:config you will be warned that this is dangerous. Search for browser.sessionstore.resume_from_crash Double click on true to toggle it to false. Exit the page. Firefox will now NOT try to reload websites after a crash.

more options

Set the pref browser.sessionstore.max_resumed_crashes to 0 on the about:config page to get the about:sessionrestore page immediately with the first restart after a crash has occurred or the Task Manager was used to close Firefox. That wil allow you to prevent the page that causes the crash from opening.

See:

https://wiki.mozilla.org/Session_Restore#Preferences
http://kb.mozillazine.org/Browser.sessionstore.max_resumed_crashes

See also http://kb.mozillazine.org/Session_Restore#Firefox_keeps_crashing_after_restoring_a_session