Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

Firefox 96.0 - "Forced" dark mode

  • 53 답장
  • 10 이 문제를 만남
  • 1051 보기
  • 최종 답변자: Paul

more options

I have been a "light theme" user for 15+ years. Since updating to 96.0 today, a dark mode spreading across Firefox has been forced onto me, including:

  • New tab background
  • Background of any tab waiting to load a page
  • Google/Youtube background
  • Settings/add-ons/password menu backgrounds
  • Automatic username/password drop-down background
  • Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link)

I am unhappy with this and wish to have my usual theme back. Can anyone please assist?

(In addition, there is some sort of white border around the current tab, which I do not like)

I have been a "light theme" user for 15+ years. Since updating to 96.0 today, a dark mode spreading across Firefox has been forced onto me, including: * New tab background * Background of any tab waiting to load a page * Google/Youtube background * Settings/add-ons/password menu backgrounds * Automatic username/password drop-down background * Background of the little box that appears on the bottom-left (the one which shows the URL when you mouse over a link) I am unhappy with this and wish to have my usual theme back. Can anyone please assist? (In addition, there is some sort of white border around the current tab, which I do not like)

글쓴이 hevinroyal 수정일시

모든 댓글 (20)

more options

Yeah it does it with new tab, and when going to most websites if it's in a new window, not all of them though. Looks like that setting to force light mode doesn't take effect fast enough to stop the dark mode coming through. Or there is some sort of battle going on between different parts of FF that want to do dark mode and light mode.

It does it with New Tab Homepage add-on disabled as well.

Can't be bothered doing a bug report; I expect someone else will.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

more options

Someone did report the flicker bug from changing "layout.css.prefers-color-scheme.content-override=1" https://bugzilla.mozilla.org/show_bug.cgi?id=1751088

도움이 되셨습니까?

more options

orgonotic-9 said

Someone did report the flicker bug from changing "layout.css.prefers-color-scheme.content-override=1" https://bugzilla.mozilla.org/show_bug.cgi?id=1751088

Thank you for finding that. Hopefully the fix will be sorted out for Firefox 87 97 due out in about 10 days. Seems it needs a bit more work.

However, if all else fails, it points toward the element you need to color if you wanted to dull the flash through userChrome.css:

/*** 
   LIGHT THEME PREFERENCE 
     layout.css.prefers-color-scheme.content-override = 1
***/

/* Set color of empty new tab before page loads to control "flash" */
#tabbrowser-tabpanels {
  background-color: #F9F9FB !important;
}


Or if you want a dark background despite a light toolbar theme:

/*** 
   DARK THEME PREFERENCE 
     layout.css.prefers-color-scheme.content-override = 0
***/

/* Set color of empty new tab before page loads to control "flash" */
#tabbrowser-tabpanels {
  background-color: #2B2A33 !important;
}


By the way, my method of testing was to create a new bookmark on the Bookmarks Toolbar for about:blank (right-click > Add Bookmark) and then Ctrl+click the bookmark to open a new tab and watch the color change between the empty tab background and the blank page.

글쓴이 jscher2000 - Support Volunteer 수정일시

도움이 되셨습니까?

more options

Just updated to 97, it didn't fix it.

Tried changing "layout.css.prefers-color-scheme.content-override" to 3 and 0, and even in dark mode it still flashes when opening a new tab.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

more options

The fix should work if you turn off using system colors on the Settings page. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Fonts and Colors section and click the Colors... button.

Uncheck the box for "Use system colors" and OK the change.

도움이 되셨습니까?

more options

Thanks, but I just tried that and it made no difference.

Tried all 3 options for "Override the colours specified by the page with your selections above" as well and that did nothing.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

more options

S.B.T.L. said

Thanks, but I just tried that and it made no difference. Tried all 3 options for "Override the colours specified by the page with your selections above" as well and that did nothing.

So if I understand correctly:

  • Your theme has dark text on the toolbars, which triggers a light background on menus and built-in pages
  • You want a dark background on web pages, so you changed layout.css.prefers-color-scheme.content-override to 0
  • On the Settings/Preferences page, Colors dialog, you unchecked the box for "Use system colors" (and did NOT select "Always" for the override)

With this combination, I get a **dark** flash before the new tab page loads, but the new tab page still has a light background. I also get a dark flash before other pages load. I'm not sure why your experience is different.

You could try using a theme with light text on the toolbars and see whether that helps.

도움이 되셨습니까?

more options

The theme is called GLASS - BLACK. It has white text, but if FF is left to do what it wants it enables dark mode for everything.

I've changed "layout.css.prefers-color-scheme.content-override" to 1 because I don't want dark-mode.

On the Settings/Preferences page, I unchecked the box for "Use system colors" and tried all 3 options of Never, Only with high contrast themes, and Always. It flashes with all options.

"With this combination, I get a **dark** flash before the new tab page loads, but the new tab page still has a light background. I also get a dark flash before other pages load. I'm not sure why your experience is different."

Firefox should not be flashing, whether on a dark or light background. (I saw a post somewhere, someone has epilepsy and they were forced to change themes because of this bug or risk having a fit.)

"You could try using a theme with light text on the toolbars and see whether that helps."

I am using a theme with light text. But that's not the point. Why should I have to change themes because FF has unleashed an update that is not ready to be released without braking things?.. Please can you just get them to put things back to how they were - and wait until they can release this new system without it braking peoples themes - or forcing people to change themes.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

more options

S.B.T.L. said

The theme is called GLASS - BLACK. It has white text, but if FF is left to do what it wants it enables dark mode for everything.

Yes, white text => dark backgrounds in many places.

Hopefully the next release will work better for you.

도움이 되셨습니까?

more options

Here is where I saw the person having to switch browsers (not themes as I thought) because of the threat of seizures. https://www.reddit.com/r/firefox/comments/s1j2jn/how_to_disable_dark_mode/

도움이 되셨습니까?

more options

If you don't want to use userChrome.css, you could try changing this preference to a colour of your choice. browser.display.background_color I wouldn't use black because that can evidently interfere with the way websites display but you could use some off-white colour.

글쓴이 Terry 수정일시

도움이 되셨습니까?

more options

Next version 97.0.1 still does it.

도움이 되셨습니까?

more options

S.B.T.L. - thanks for letting us know that version 97.0.1 still has this annoying problem, I came back here just to check for that info.

Guess I'll keep my fingers crossed for version 98!

Ugh...

도움이 되셨습니까?

more options

97.0.2 still does it.

도움이 되셨습니까?

more options

jscher2000 13 Jan 2022 "Hopefully it will come in Firefox 97-98"

With all due respect, allow me to say that Firefox either: (1) Does not care about this issue (2) Does not consider this as a priority even though this bug (yes, it is a bug more than anything) has no reason to exist

도움이 되셨습니까?

more options

hevinroyal said

jscher2000 13 Jan 2022 "Hopefully it will come in Firefox 97-98" With all due respect, allow me to say that Firefox either: (1) Does not care about this issue (2) Does not consider this as a priority even though this bug (yes, it is a bug more than anything) has no reason to exist

It means the UI people have not yet approved making a settings page control for the about:config preference so you still need to change it manually.

Have you already been using that workaround? See my first reply in this thread:

https://support.mozilla.org/en-US/questions/1363842#answer-1472881

If you thought I meant something else, that is all I meant.

도움이 되셨습니까?

more options

jscher2000 said

It means the UI people have not yet approved making a settings page control for the about:config preference so you still need to change it manually. Have you already been using that workaround? See my first reply in this thread: https://support.mozilla.org/en-US/questions/1363842#answer-1472881

So we're waiting for them to make it easier to change that setting; layout.css.prefers-color-scheme.content-override - when that setting does not fix the problem anyway... It flashes with every option of 0-3.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

more options

I had made it clear that your workaround does not addresses all my concerns, including (but not limited to):

  • Background of any tab waiting to load a page
  • Automatic username/password drop-down background

The culprit here is "browser.theme.toolbar-theme" which always gets reset to 2 when I open Firefox anew, and I am deprived of the freedom to permanently set it to the value that suits me.

I am therefore not willing to accept any compromise except for this bug to be solved. I need to be able to use the theme of my liking while being able to select a non-dark environment.

도움이 되셨습니까?

more options

hevinroyal said

The culprit here is "browser.theme.toolbar-theme" which always gets reset to 2 when I open Firefox anew, and I am deprived of the freedom to permanently set it to the value that suits me.

Firefox sets that dynamically for every new window based on the current theme used in that window. There could be a bug on file about that, but I can't recall. If you want to search: https://bugzilla.mozilla.org/

Some users are forcibly overriding/locking the preference using an Autoconfig file. You might find that in another thread.

S.B.T.L. said

So we're waiting for them to make it easier to change that setting; layout.css.prefers-color-scheme.content-override - when that setting does not fix the problem anyway... It flashes with every option of 0-3.

That is the bug I'm familiar with. There might be other bugs on file related to theme colors. Please see the Bugzilla link above if you want to search.

도움이 되셨습니까?

more options

v98.0 Still bugged.

글쓴이 S.B.T.L. 수정일시

도움이 되셨습니까?

  1. 1
  2. 2
  3. 3
질문하기

글에 답글을 달기 위해서는 계정으로 로그인해야만 합니다. 계정이 아직 없다면 새로운 질문을 올려주십시오.