Mozilla 도움말 검색

고객 지원 사기를 피하세요. 저희는 여러분께 절대로 전화를 걸거나 문자를 보내거나 개인 정보를 공유하도록 요청하지 않습니다. "악용 사례 신고"옵션을 사용하여 의심스러운 활동을 신고해 주세요.

Learn More

For accessibility, need chosen background colour applied to Settings pages

  • 8 답장
  • 7 이 문제를 만남
  • 5 보기
  • 최종 답변자: jscher2000

more options

I have changed my backgrouopnd colour so I can read those kindly web sites that do not overrule it. It's fab. But when I use Settings in Friefox, the background colour is still dazzling white. Please can Firefox use my chosen background colour for all Settings pages from now on?

And please use my chosen colour (ie do not define the page backgroupnd colour) for the whole of your Support web site?

선택된 해결법

Hi jer16, your Firefox identified itself as version 52. Are you running the Extended Support Release of Firefox 52?

With pre-57 versions of Firefox, there are a number of "legacy" extensions that allow you to modify page colors, and that might be the easiest approach.

In Firefox 57+, it's a little more work because you need to create a file on disk with custom style rules (userContent.css).

문맥에 따라 이 답변을 읽어주세요 👍 0

모든 댓글 (8)

more options

I tell Firefox not to allow websites to use their own colours, but Firefox still overrides my settings on pages like Settings and add-ons. Why?

글쓴이 nutmeg57 수정일시

more options

We are still having this problem. When I tap on the cogwheel to see FireFox Preferences, the background colour for the list of preferences is always white. This is true even though I have already used the Preferences to set my background colour to yellow and it works for sensible web sites. The Mozilla web site doesn't use my background colour, mind!

more options

선택된 해결법

Hi jer16, your Firefox identified itself as version 52. Are you running the Extended Support Release of Firefox 52?

With pre-57 versions of Firefox, there are a number of "legacy" extensions that allow you to modify page colors, and that might be the easiest approach.

In Firefox 57+, it's a little more work because you need to create a file on disk with custom style rules (userContent.css).

more options

On the more general subject of suggesting changes to future releases of Firefox, there are some places to do that:

more options

Thank you jscher2000, and you are right; I was using an earlier version and have now upgraded to 57. I looked around and found in the Color preferences an option to: Override the colors specified by the page with your selections above - which I have now set to Always.

This has fixed the problem for the Firefox preferences - thank you thank you - and I can now read them much more easily. Finding the option was of course more difficult before I has set the option, a bit Catch 22.

It also means I have yellow on the Mozilla web site. all very auspicious for other web sites. Thank you very much for drawing my attention to this. I hope it helps the other people with this problem too.

more options

I'm using Firefox 56. I don't want to downgrade to Firefox 57, because that will break Classic Theme Restorer which I need to replace all those meaningless icons by text. I have set my preferences to always use my own colour choices, but Firefox's internal pages do not respect this! Why not?

more options

Hi nutmeg57, I don't know why Firefox 56 did what it did, but it is what it is, there won't be any further tweaks to it.

You could look at the Add-ons site and see whether any of the page coloring extensions can modify the built-in pages. You may need to go to the extension's "Versions" page to find the ones that used "legacy" capabilities.

more options

Regarding this:

nutmeg57 said

I don't want to downgrade to Firefox 57, because that will break Classic Theme Restorer which I need to replace all those meaningless icons by text.

The author of the Classic Theme Restorer extension published an extensive set of custom style rules to give users some of the features of the extension in Firefox 57+. One of the many options in the Classic CSS folder is a set of rules that replaces the icons with text. The trick is finding the relevant parts and "un-commenting" the key line(s). You'll see it here on line 430 (as of this writing):

https://github.com/Aris-t2/CustomCSSforFx/blob/master/classic/userChrome.css#L428

/* @import url(./css/toolbars/toolbar_mode_text.css); /**/

If you install that full set of files, removing /* from the beginning of that line should give you text in place of icons at your next Firefox startup.

If you are NOT using that full set of files, you could use the following:

If you do not have any userChrome.css file:

(1) Create a new folder named chrome in your Firefox profile folder. That is Steps #1 - #3 on this page:

https://www.userchrome.org/how-create-userchrome-css.html

(2) I extracted the specific CTR rules for text buttons on the toolbar and saved them here:

https://www.userchrome.org/samples/userChrome-TextOnlyOnToolbar.css

Save that file somewhere and then move it into the chrome folder.

(3) Right-click > rename userChrome-TextOnlyOnToolbar.css to just userChrome.css.

(4) The next time you start Firefox, it will discover the userChrome.css file and modify the appearance of the toolbar.

If you already have a userChrome.css file:

You can copy the contents of the following rule file and paste them at the end of your existing userChrome.css file:

https://www.userchrome.org/samples/userChrome-TextOnlyOnToolbar.css

Notes:

If you have too many long label items, you can right-click > Pin to Overflow Menu to move them to the >> button list.

Screenshot: https://support.cdn.mozilla.net/media/uploads/images/2017-12-10-21-38-46-f6332c.png