Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ADD TO CART button does not appear on Amazon.com. Other buttons also do not appear, but they do in Google Chrome.

  • 9 replies
  • 4 have this problem
  • 19 views
  • Last reply by northbear

more options

When trying to add an item to the cart in Amazon, the button "Add to Cart" does not exist. The "X" to close Google Street does not appear in the street view box. In Google Chrome, the Amazon button and the x in street view are visible.

When trying to add an item to the cart in Amazon, the button "Add to Cart" does not exist. The "X" to close Google Street does not appear in the street view box. In Google Chrome, the Amazon button and the x in street view are visible.

Chosen solution

You're welcome

You can use the NoSquint extension to set font sizes (text/page zoom) and text colors on web pages.

Read this answer in context 👍 1

All Replies (9)

more options

Try to reload the webpage. If the problem repeats again the network your using is too slow.

more options

Fiber optic DSL download speed is 3MBS. Reloading page does not make the button appear.

more options

Try to download flash player or javascript engine

more options

Have Flash Player 11, and Java 6 update 30 and J2SE Runtime Environment 5.0.

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).


Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

See also:

more options

Thanks. I will give it a try and let you know the results.

more options

BINGO! Allowing the pages to choose their colors brings up the buttons.

Unfortunately, the electric white backgrounds are hard on the eyes.

Many Thanks.

more options

Chosen Solution

You're welcome

You can use the NoSquint extension to set font sizes (text/page zoom) and text colors on web pages.

Modified by cor-el

more options

Tried NoSquint. Works Great. But, I am confused (which is not unusual).

The solution to the whole problem was to allow the pages to choose their own colors, but here I am setting MY colors and the buttons still appear.