Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with popup on my website

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

I have a problem with my website on firefox. I use a popups on my site to promote the products or ask user to signups and those popups are not loading in firefox browser at my end. I have tried and tested this on multiple PCs and also asked a few of my friends to do the same from their PCs

All Replies (3)

more options

pop ups are a thing of the past. they are still used by malware writers and porn sites for malicious purposes.

my suggestion is to skip the pop ups and create a webpage that will open in new tab and provide the same info as a popup.

more options

Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of Shift.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Diagnose Firefox issues using Troubleshoot Mode)

more options

You can check the Web Console (Tools -> Web Developer) for error messages about blocked and unsafe and mixed content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

Use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log.


Firefox 42+ has a Tracking Protection feature that is enabled by default in Private Browsing mode. When you are in private browsing mode then Firefox can show a shield icon at the left end of the location/address bar that some content is blocked.

You can disable this feature in "Options/Preferences -> Privacy" or via the about:privatebrowsing page that get when you open a New Private Window.

  • Options/Preferences -> Privacy: "Use Tracking Protection in Private Windows"

You can set this pref to true on the about:config page: to see more Tracking Protection choices in "Options/Preferences -> Privacy".

  • privacy.trackingprotection.ui.enabled