On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is my applications box completely blank?

  • 10 replies
  • 3 have this problem
  • 31 views
  • Last reply by jane614

more options

After clicking a link for a pdf file I was only given the option to download it, I've always had pdfs set to automatically open in Adobe. I went into the "Applications" tab under Preferences and realized it was blank, I had no option to change settings for any content type. What would cause this to happen and how do I get all my applications back? I'm running on Firefox 44.0.2 and my OS is Windows 10

After clicking a link for a pdf file I was only given the option to download it, I've always had pdfs set to automatically open in Adobe. I went into the "Applications" tab under Preferences and realized it was blank, I had no option to change settings for any content type. What would cause this to happen and how do I get all my applications back? I'm running on Firefox 44.0.2 and my OS is Windows 10

Modified by jane614

All Replies (10)

more options

Do you use a "full" Firefox theme that affects web pages as well as the toolbar area background? Some themes are not compatible with the Options page.

If it's not a theme, your Firefox program files might have been damaged during the last update. For that we usually suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 45.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version.

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(32-bit Firefox on 64-bit Windows)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(Other systems)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement in stability?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders, but I suggest only copying what you recognize to be useful as there may be old junk in here:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Hmm, in case "completely blank" actually meant there is a box but it's empty -- allowing Firefox time to build the list which might be 3 seconds or 15 seconds -- then there might be a different issue. The file that stores your downloading handling preferences sometimes becomes corrupted. Because it is difficult to edit, we usually suggest renaming it and allowing Firefox to generate a new one with default settings. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

When you start Firefox up again, download preferences should be reset to default values. Go back to the Options page and check whether you can select your preferred handler for PDFs.

Any improvement?

more options

jscher2000 said

Do you use a "full" Firefox theme that affects web pages as well as the toolbar area background? Some themes are not compatible with the Options page. If it's not a theme, your Firefox program files might have been damaged during the last update. For that we usually suggest: Clean Reinstall We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (A) Download a fresh installer for Firefox 45.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) For maximum plugin compatibility, choose the 32-bit version. (B) Exit out of Firefox (if applicable). (C) Rename the program folder as follows: (32-bit Firefox on 64-bit Windows) C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (Other systems) C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Any improvement in stability? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders, but I suggest only copying what you recognize to be useful as there may be old junk in here:
  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

I tried this out and the issue is still there

more options

jscher2000 said

Hmm, in case "completely blank" actually meant there is a box but it's empty -- allowing Firefox time to build the list which might be 3 seconds or 15 seconds -- then there might be a different issue. The file that stores your downloading handling preferences sometimes becomes corrupted. Because it is difficult to edit, we usually suggest renaming it and allowing Firefox to generate a new one with default settings. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either
  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter
In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either:
  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit
Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old When you start Firefox up again, download preferences should be reset to default values. Go back to the Options page and check whether you can select your preferred handler for PDFs. Any improvement?

I tried this out and the issue is still there.

more options

Okay, so is this right:

  • the page is completely blank, no search bar, no list box
  • you do not use a full theme that customizes the Options page
  • a clean reinstall did not help

Have you shut down and restarted Windows since this problem began? Occasionally after system updates, Windows starts up in a mode where Firefox does not have full permissions to its settings files and very strange things happen. Before spending too much time on more troubleshooting, you might want to try restarting Windows if you haven't already.


Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Diagnose Firefox issues using Troubleshoot Mode)

more options

-The Application page pops up but all the applications have been cleared out, all that appears is a empty list box. -No theme to customize the page. -clean reinstall did not help. -Opening Firefox in safe mode did not help. -I've shut down and restarted many times.

more options

Sorry, I'm out of ideas at the moment.

more options

jscher2000 said

Sorry, I'm out of ideas at the moment.

Thanks for trying to help, appreciate it!

more options

Create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

cor-el said

Create a new profile to test if your current profile is causing the problem. See "Creating a profile": If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.
Created new profile and problem still exist..... thanks for trying to help!