Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am unable to change settings so that I don't have to allow Firefox to redirect everytime.

  • 2 replies
  • 1 has this problem
  • 1 view
  • Last reply by cor-el

more options

I get this message when I click on a link:

"firefox prevented this page from automaticaly redirecting to another page."

And I tried this:

Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

But it doesn't work. After I change the setting, instead of a window popping up that asks me to allow the redirect, I get a blank window.

Thanks

I get this message when I click on a link: "firefox prevented this page from automaticaly redirecting to another page." And I tried this: Firefox > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page" But it doesn't work. After I change the setting, instead of a window popping up that asks me to allow the redirect, I get a blank window. Thanks

All Replies (2)

more options

Hmm, perhaps the redirect was successful but the destination page did not load...

Can you tell from the address bar whether Firefox has gone to the link you clicked or to a different address?

What if you reload the blank page using Cmd+Shift+r (that bypasses the cache and forces a full reload). Does that allow you to progress further?


Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the option key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox > Preferences > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"