Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

clipboard.autocopy=false in about:config, - no effect. selecting text still copies to clipboard

  • 2 replies
  • 2 have this problem
  • 116 views
  • Last reply by adlet06

more options

I have a custom firefox extension that grabs data from the clipboard, as well as selected text from the firefox document. Problem is, every time I select text, it overrides the clipboard data with selected text data. The clipboard always mirroring my text selection. I need to disable this. Or, ensure that selected text gets sent to primary clipboard, while firefox extension accesses clipboard. (I am assuming nsIClipboard pulls data from clipboard vs primary-clipboard).

I am confident that selected text is being dumped into clipboard, and not into primary clipboard. Selected text always overrides whatever I copied using Ctrl + C command. Middle mouse click, or Ctrl + V output same thing.

I have changed the default setting in about:config to clipboard.autocopy value= false. I have restarted my system and selected text still saves to clipboard.  This issue does show up on this thread here https://bugzilla.mozilla.org/show_bug.cgi?id=854565. But it is checked as solved. Apologies if this question should have been posted there. I am using Linux Mint 17, Firefox 32.0.3

Any help greatly appreciated.

I have a custom firefox extension that grabs data from the clipboard, as well as selected text from the firefox document. Problem is, every time I select text, it overrides the clipboard data with selected text data. The clipboard always mirroring my text selection. I need to disable this. Or, ensure that selected text gets sent to primary clipboard, while firefox extension accesses clipboard. (I am assuming nsIClipboard pulls data from clipboard vs primary-clipboard). I am confident that selected text is being dumped into clipboard, and not into primary clipboard. Selected text always overrides whatever I copied using Ctrl + C command. Middle mouse click, or Ctrl + V output same thing. I have changed the default setting in about:config to clipboard.autocopy value= false. I have restarted my system and selected text still saves to clipboard. This issue does show up on this thread here https://bugzilla.mozilla.org/show_bug.cgi?id=854565. But it is checked as solved. Apologies if this question should have been posted there. I am using Linux Mint 17, Firefox 32.0.3 Any help greatly appreciated.

Chosen solution

I have solved the problem. I first updated all my software, which had no effect. Then I realized another extension may be adding this functionality. And voila! I am pretty sure Fastest Search was the culprit. I disabled the addon, although, this feature can probably be turned off.

I hope this helps any future users that face this same issue.

Read this answer in context 👍 2

All Replies (2)

more options

Chosen Solution

I have solved the problem. I first updated all my software, which had no effect. Then I realized another extension may be adding this functionality. And voila! I am pretty sure Fastest Search was the culprit. I disabled the addon, although, this feature can probably be turned off.

I hope this helps any future users that face this same issue.

more options

Had the same problem, thanks for the solution. To only disable the feature and not the entire addon use the following setting in about:config:

extensions.fastestsearch.autocopy = false