Showing questions tagged: Show all questions
  • Solved
  • Archived

After Feb ~12th, Firefox freezes until a page fully loads

Sometime after around Feb 13th, I think I might have rebooted for a Windows update and now Firefox pages completely lock up until the entire page loads. To be more specif… (read more)

Sometime after around Feb 13th, I think I might have rebooted for a Windows update and now Firefox pages completely lock up until the entire page loads.

To be more specific, I can still switch tabs, open menus, etc... but I cannot interact with anything on the page itself like click links, type in text fields, right click to get the context menu... but if I switch to another tab, I can interact with that page just fine. In addition, while the page is frozen like that, I can't use the back button either, but clicking it (or using the back button on my mouse) will make the browser go back only after the page fully loads.

Why is this bad? Some pages can take 10 to 20 seconds or even more to load! So even though I can see the link I want to go to almost immediately, I have to wait until every picture is done loading before I can click it.

In addition, things like the dropdown you get on google as you type in the search box will freeze the page when you select them. For example, I go to google, I type "Firef" then click the Firefox autocomplete. The entire page freezes for a couple of seconds before the screen is cleared and goes white and then it starts loading the next page.

Other things I've noticed, those google captcha things where you click the checkbox for "I am not a robot"; those can take over 15 seconds to load and freeze up the page PLUS clicking the checkbox ALSO freezes the page again for another 15 seconds.

This happens in safe mode too and with all addons disabled.

Asked by uglycat 2 years ago

Answered by uglycat 2 years ago

  • Solved
  • Archived

All drop-down menus do not show and right-click does nothing after a period of time

This problem started for me around 4ish months ago, but I couldn't tell you the version number I was on at the time. I'm having the exact same issue on two different phy… (read more)

This problem started for me around 4ish months ago, but I couldn't tell you the version number I was on at the time. I'm having the exact same issue on two different physical computers both running Windows 7 Pro x64, while I do not have this issue on my work computer running Windows 10 Pro x64.

The Problem:

After a period of time, sometimes 6-8 hours, sometimes 48 hours, I am no longer given any context menu's when I right-click in FireFox, either on a webpage or on the toolbar areas. This typically happens when leaving FireFox open and idle over night, then I see the problem in the morning, or some mornings it works fine and continues to throughout the day, but then stops the following day. So, for example, I am unable to Pin or Unpin tabs when this happens, nor can I right-click anywhere. Also, when I click on the Menu or Bookmarks button, nothing pops down. The button changes colors to a darker shade like it is de-pressed but the menu does not appear. This happens in drop-down menu's on websites as well - they do not appear. I am able to use the up and down arrows, or letter keys, to move around them but the drop-down is gone completely.

This is all fixed if I close FireFox and re-open it. Seemingly a timer is reset and everything works again for a while.

What I've done:

I started with simple things like unpinning my tabs, closing tabs and removing extensions but non of that worked. I then backed up and deleted my entire Firefox profile under AppData - Local but it started happening on my new profile also. Earlier this week I completely uninstalled FireFox and the update service, and deleted everything Mozilla from all three AppData folders as well as ProgramData. I rebooted and then re-installed FireFox using Ninite. I did not import any data, pin any tabs, install any add-ons or save any passwords. I was trying to be as vanilla as possible, but the problem was happening again the next morning. Yesterday I started FireFox in Safe Mode and am having the same problem running in Safe Mode.

This effort so far has been concentrated on one of my two machines experiencing this problem, as I was hoping to solve it on one and then apply the solution to the other, but I am at a loss. I can't imagine that additional Windows programs would cause this but there are a few overlapping programs between the two.

I have Microsoft Security Essentials and MalwareBytes Premium installed on this primary machine having the issues, whereas I do not have MalwareBytes installed on the other machine also having this issue. I thought the Web Protection may be interfering but I don't believe so now.

One other similarity is that both computers are non-domain and the primary account used on both is a non-admin account purposely (I try not to run as admin unless absolutely necessary, for obvious reasons). I'm wondering if possibly not running as an admin is causing an issue somehow? I will try temporarily making myself an admin tonight and leave FireFox in Safe Mode idle again to see if anything has changed.

Other than that, would you have any ideas or things I may be able to try? I'm open to anything at this point, I just want this fixed! I don't want to move to Chrome. :(

Asked by jondrum418 2 years ago

Answered by Tonnes 2 years ago

  • Solved
  • Archived

FF59 delays many page (URL) changes by up to 2 min

FIRST--your "Troubleshooting information: [green] Automatically add" button does NOT work!!! I clicked it only to get a nonexistent page message, and, when I back arrowe… (read more)

FIRST--your "Troubleshooting information: [green] Automatically add" button does NOT work!!! I clicked it only to get a nonexistent page message, and, when I back arrowed to get back to my message here, IT WAS GONE--a half box of message lost and now blank again. (The question was persistent--why not the message so far as well?) I'm spitting nails because I have to try to remember the exact details of what I said so I don't miss any important information for you!

Starting with FF59, there are often (not always) significant delays in switching from one page (URL) to another. The case that is particularly irksome to me is switching between my two Gmail accounts, which I do often during a day. Prior to v59, such page switching was nearly instantaneous. (I tested this on Google Chrome to see if this was a Google issue or even a general Internet issue. However, Chrome behaved nearly instantaneously, just the way FF used to prior to v59. That points to FF as the culprit in this problem.) Nor does this problem occur only once during the page switch--it actually occurs TWICE! I decided to time this once: (1) 54 seconds until the moving dot stopped, when I ought to be at my destination; (2) but it was only a blank screen, so I clicked the reload icon; and (3) 53 seconds later the Gmail account selection page finally appeared. That was a total of nearly 2 minutes when it used to be nearly instantaneous! (And this happens EVERY TIME when switching to the other Gmail account!) Additionally, while all of this was going on, "s3.amazonaws.com" and "fileserver.xyz..." (and once a third one that I don't remember) would appear at the lower left during (1) and (3). Why in the world is FF going to these sites and slowing the process? I used to LOVE (and brag to friends about) "full-featured Firefox" versus "crippled Chrome", but I've had to stop giving such advice for the moment because of this particular issue with v59. This delay issue occurs not only with Gmail but also with some other page switching, too--but I have not been able to notice any pattern. I hope that v60+ can resolve this FF problem!!

Asked by harveyh 2 years ago

Answered by harveyh 2 years ago

  • Solved
  • Archived

Firefox running slowly after newest update

After the recent update in May 2018, my Firefox is running slowly. Pages are not loading as quickly as before and streaming video is freezing to the point it is unwatchab… (read more)

After the recent update in May 2018, my Firefox is running slowly. Pages are not loading as quickly as before and streaming video is freezing to the point it is unwatchable.

Asked by dpreston68 2 years ago

Answered by dpreston68 2 years ago

  • Solved
  • Archived

Firefox will not load.

Firefox will not load. I installed Kaspersky Internet Security and everything was working fine until it wasn't. I then uninstalled Kaspersky, but Firefox would still not … (read more)

Firefox will not load. I installed Kaspersky Internet Security and everything was working fine until it wasn't. I then uninstalled Kaspersky, but Firefox would still not load.

Since I love Firefox I restored my computer to a previous state and that fixed everything, so then I installed a different Kaspersky product and everything was perfect. Now the problem is back again.

I don't know if the problem is on Kaspersky side or Firefox, but I would prefer not to restore again and I have no more troubleshooting ideas.

Firefox starts in Windows safe mode. When I double click on the Firefox icon the mouse indicates FF is loading, but then it doesn't start. Chrome starts fine. Contacted Kaspersky, but their first troubleshooting tip did not work. Under Event viewer I can see crash details for Firefox, but I can't interpret them and I don't know if they are related to FF not loading.

I'm okay with unintelligible Firefox and then reinstalling, but I do not want to lose my bookmarks, themes, add-ons, etc.

Any ideas would be appreciated!

Asked by Another_user 4 years ago

Answered by Phoxuponyou 4 years ago

  • Solved
  • Archived

Firefox is totally slow and not responding

Hi! I need a little help. My FF is totally slow. I don't know where the problem is. I have open only a few tabs and it is loading too long, maybe 20 seconds and more and … (read more)

Hi!

I need a little help. My FF is totally slow. I don't know where the problem is. I have open only a few tabs and it is loading too long, maybe 20 seconds and more and also "not responding" for a couple of seconds. I have never had these problems in such a way. FF was slow many times in 10 years of my using of this browser, but this is extreme for me. I tried to get rid of any unnecessary plugins and extensions, it helped for a few days and come again. Then I tried, for me the last solution, restarting/reseting FF to factory defaults... it also helped perfectly, but only for a few days and come again and I'm here, frustrated from FF. This problems I have on more computers and PC's are pretty new. 2x different HP ProBook 455 G2 with AMD A8 APUs and 1x HP ProBook 450 G2 with i3 Intel, if this could help. Plugins and extensions are only basic as I say, so this can't be a problem in my opinion.

Thank you very much for every respond.

Asked by biggie 4 years ago

Answered by biggie 4 years ago

  • Solved
  • Archived

Sudenly, for the past 4 days, Wikipedia conects very slowly, gets stuck half-way, etc.; pther websites work fine

For the past several days, while all other websites work as fine as before on Firefox, Wikipedia works very badly: it responds very slowly and often gets stuck half-way b… (read more)

For the past several days, while all other websites work as fine as before on Firefox, Wikipedia works very badly: it responds very slowly and often gets stuck half-way before opening a page. I have tried several solutions but the problem recurs. On a different platform, Safari is connecting fine. Any suggestions?

Asked by DBCK 5 years ago

Answered by cor-el 5 years ago

  • Solved
  • Archived

Firefox 40.3 will not start but older versions will

Firefox 40.0.3 will not start or open. I Uninstaller and put on 36.0.3 and it runs. Once I go to the About tab it automatically downloads the latest version. Then when I… (read more)

Firefox 40.0.3 will not start or open. I Uninstaller and put on 36.0.3 and it runs. Once I go to the About tab it automatically downloads the latest version. Then when I click on the Firefox icons nothing happens. I have repeated this process several times with the same results. XP Pro SP3

Asked by kenx1ster 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

firefox opens from icon and appears in toolbar. cannot get it to open from toolbar

Firefox opens when I click on the icon. The FIREFOX icon appears in the toolbar and I cannot get it to open from there. I click on it and the browser is in the icon but I… (read more)

Firefox opens when I click on the icon. The FIREFOX icon appears in the toolbar and I cannot get it to open from there. I click on it and the browser is in the icon but I cannot get it to open fully. I have removed and installed 2 new installs and same problem. The only thing that has changed on my computer is I added a new monitor. IE does open correctly

Asked by wellknown 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Firefox page hangs, busy indicator, very low cpu, on some sites. I have an example.

Firefox 41.0, Win 10 Pro x64. Recently (possibly before V41) Firefox pages hang with very low cpu on some sites. Firefox itself is not hung, but for that tab, the clock i… (read more)

Firefox 41.0, Win 10 Pro x64. Recently (possibly before V41) Firefox pages hang with very low cpu on some sites. Firefox itself is not hung, but for that tab, the clock indicator keeps ticking. I'm opening the problem while another tab is experiencing the problem. Some data from the web site is usually displayed (background?). Perhaps there is a redirect/redisplay of some sort (complete guess). Note: In this case, the web site is grayed out. Example: https://www.code42.com/store/ Problem occurred when I navigated to the above URL. Also occurred when I pasted the URL. Works in Chrome Version 45.0.2454.101 m. Works in Edge 20.10240.16384.0

Note: right now, as I try to upload an image, the upload doesn't complete. Clock ticks.

I'm going to try to submit this anyway.

Asked by SteveSzalai 4 years ago

Answered by SteveSzalai 4 years ago

  • Solved
  • Archived

how do i fix my home page image suddenly stopped showing up and i have just a blank page?

due to slowness of loading, i was reloading my home page....repeatedly, i'm afraid. now, not only does my home page image not show up, but it's not even asking me if i w… (read more)

due to slowness of loading, i was reloading my home page....repeatedly, i'm afraid. now, not only does my home page image not show up, but it's not even asking me if i wanna set a cookie. not sure why this is. works on my ipad, my friends' browsers (PC/mobile), my husband's ipad and mac laptop...i've looked around in options and on help forums and can't even find anyone else having this problem. seems like firefox isn't talking to my web hoster? dunno. 41.0.1 version. i'll try updating now. maybe that'll fix it. anyway, thanx for any help anyone can give.

Asked by mrs_vw 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Firefox runs very slowly after Windows 10 update

On Saturday 12 December, Windows 10 spent an age updating itself, with several reboots. Since then, browsing has been intolerably slow with Firefox, although my internet… (read more)

On Saturday 12 December, Windows 10 spent an age updating itself, with several reboots. Since then, browsing has been intolerably slow with Firefox, although my internet connection is still fine (working fast from my smartphone and using Microsoft Edge). I have two PCs and both seem to have been affected in the same way. Using Task Manager, I see that Firefox is using lots of CPU nearly all the time - often over 50%. Even typing and scrolling is very slow, not just downloading. I have turned off all my add-ins and plug-ins, run in safe mode, restarted and reinstalled Firefox to no effect. Until now, I would have said Firefox was the fastest browser. I think Firefox updated itself to version 42.0 several days ago, so I a suspicious that this slowdown has happened just after a Windows update.

Asked by Bercelet 4 years ago

Answered by Bercelet 4 years ago

  • Solved
  • Archived

Constant Blinking, 1-Second Long, Not-Responding Errors

Basically whenever I do virtually anything now on FF it constantly "blinks". For example if I'm on Youtube it will randomly go to desktop for a split-second while the FF … (read more)

Basically whenever I do virtually anything now on FF it constantly "blinks". For example if I'm on Youtube it will randomly go to desktop for a split-second while the FF taskbar on top is still visible but "not responding" and then less than a second later everything's fine.

I tried disabling add-ons, disabling hardware acceleration, doing a complete fresh restart, nothing seems to have fixed it.

Asked by muffinoffun 4 years ago

Answered by muffinoffun 4 years ago

  • Solved
  • Archived

Keyboard seems to not work for several minutes on newly opened tab / site

Firefox version: 58.0.2 (64-bit) OS: Ubuntu 16.04.3 LTS When I open new tab or call some site from bookmarks etc. keyboard seems to not work for a while... I noticed that… (read more)

Firefox version: 58.0.2 (64-bit) OS: Ubuntu 16.04.3 LTS

When I open new tab or call some site from bookmarks etc. keyboard seems to not work for a while... I noticed that although cursor seems to be in the in the input item which I clicked with mouse - it actually looks like it moving very rapidly between other input columns. Most obvious it is in gmail - but generally this problem is the same for all newly opened websites. I had to wait for at least 30 seconds but usually more - after this time problem is gone and I can input text without any problems. I tried to google for solution but so far without any useful results....

Asked by josmac69 2 years ago

Answered by josmac69 2 years ago

  • Solved
  • Archived

Can't backup bookmarks. The bookmarked sign on bookmarked pages dissapears few moments after every launch. Sync is stuck on syncing. Can't add new bookmarks.

After starting Firefox, Sync starts and gets stuck on "Syncing" till I restart. Ever page shows as bookmarked for a while and then they all turn into not bookmarked. Back… (read more)

After starting Firefox, Sync starts and gets stuck on "Syncing" till I restart. Ever page shows as bookmarked for a while and then they all turn into not bookmarked. Backups won't be saved. Changes to bookmarks and adding new ones won't work either. Have tried a new profile, deleting xulstore.json and places.sqlite and have also tried safe-mode and all of them together. The sync is still in a loop. I have about 56000 bookmarks(I know that's a lot!) but it didn't use to take more than a few seconds. And not being able to see the last sync time by hovering really sucks as well btw.

Asked by Garshasb 10 months ago

Answered by cor-el 10 months ago

  • Solved
  • Archived

Can anyone help me set up my Add-Ons to minimize Crashes, hanging, and freezing of web pages?

Below, is a screen shot of my Computer's Properties. I realize my PC is old. I'll admit, that I should know more about this stuff than I do, but I am so frustrated, I'm r… (read more)

Below, is a screen shot of my Computer's Properties. I realize my PC is old. I'll admit, that I should know more about this stuff than I do, but I am so frustrated, I'm ready to simply uninstall Firefox, and go back to Chrome. Basically all I do online, is read News, Sports, and play a few games. I can't help but feel, that I have conflicting Add-ons which are causing me all these issues, but for the life of me, I cannot figure out the right combination of them to get my Browser to run smoothly.

Constantly the Debugging Script box pops up, or Shockwave crashes, or the page I'm on simply starts hanging and freezing. I shouldn't need to be clearing my History/Cache daily, but I do, and even this is only a temporary fix. After a half an hour, I'm right back to all the issues again. Thanks in Advance!

Asked by Mikey7a 4 years ago

Answered by FredMcD 4 years ago

  • Solved
  • Archived

Firefox slowed to a crawl after updating Norton Security.

Updated to latest version of Norton. FF hung up ("not responding" msg) every time a new tab was opened. Refreshed FF; now tabs work fine, but FF is extremely slow. Pa… (read more)

Updated to latest version of Norton. FF hung up ("not responding" msg) every time a new tab was opened. Refreshed FF; now tabs work fine, but FF is extremely slow. Pages that used to takt one second or less to load now take from two to ten minutes.

Asked by Bowkie 4 years ago

Answered by cor-el 4 years ago

  • Solved
  • Archived

My website works slow on Mozilla

Hello, Mozilla is faster than google chrome and whenever i use to browse website mozilla works faster. However i have a website https://bloggerwalk.com which works slows… (read more)

Hello,

Mozilla is faster than google chrome and whenever i use to browse website mozilla works faster. However i have a website https://bloggerwalk.com which works slows on mozilla as compared to google chrome. Is this a browser issue or my website issue.

Thanks and Regards

Asked by dnbucket88 1 year ago

Answered by FredMcD 1 year ago

  • Solved
  • Archived

Why is FireFox so slow

I currently have version 72.0.2 and it is so slow. I suspected an ISP problem although I have fibre optics but I just have to compare FIreFox with another browser to see … (read more)

I currently have version 72.0.2 and it is so slow.

I suspected an ISP problem although I have fibre optics but I just have to compare FIreFox with another browser to see that FireFox is the problem.

For instance, on the same site, I can call up a different page in around 5 seconds with FireFox whereas the same change of page takes well under 2 seconds with the Avast Browser.

Opening 3 tabs simultaneously in FireFox when I launch it takes YONKS whereas it used to load all 3 pages in a blink.

I already have add ons like "Disable HTML5 Autoplay" installed to speed up things.

What is the solution please?

Asked by SafeTex 6 months ago

Answered by FredMcD 6 months ago