Showing questions tagged: Show all questions

Stop tabbar moving when opening a new tab

Current behavior: When I have a lot of tabs open, more than fit on the tabbar at current browser width, and I open a new (blank) tab, the tab is open to the right of the… (read more)

Current behavior: When I have a lot of tabs open, more than fit on the tabbar at current browser width, and I open a new (blank) tab, the tab is open to the right of the current tab which is good, but the entire tabbar is also moved/scrolled/animated to position the newly opened tab to the left edge of the window, hiding the tab I came from out of view (to the left). I find this unnecessary and annoying.

Desired behavior: Don't move the tabbar at all when opening a new tab. Instead, only move the tabs that are to the right of the current tab, to the right, to make room for the new tab.

Is there a preference or a combination of them that would stop the tabs moving when unnecessary?

Firefox did behave this way before, I don't remember exactly when it changed. I'd say it wad a recent change, but I'm a long term user :)

Asked by prkos 2 months ago

Html5 error in live videos on youtube

Good morning, I've been using firefox for a long time, and i never had a problem like this. I use Linux with firefox 75.0 the most current version. And every time I try t… (read more)

Good morning, I've been using firefox for a long time, and i never had a problem like this. I use Linux with firefox 75.0 the most current version. And every time I try to watch a live video on youtube I get the following error message: "Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video. "

I've tried it in safe mode but it still didn't work, what puzzled me most was the fact that normal videos are played normally as they should. Unfortunately to watch some lives I had to start chrome because everything works as it should. Thanks in advance.

Att: Juaski

Asked by daironrjuraski 2 months ago

Fade in/out youtube full screen animation and no title bar

I have two problems. One is that when I am in browser full screen mode and I am on youtube and go full screen video, the fade in/out animation is not working. The other p… (read more)

I have two problems. One is that when I am in browser full screen mode and I am on youtube and go full screen video, the fade in/out animation is not working. The other problem is that when I untick title bar in customize it doesn't work. I am running Firefox 75 on Linux Deepin.

Asked by leandrovaschetti 2 months ago

Cannot access forgotten/deleted website

Some time ago I removed a website form the New Tab Top Sites list. I'm pretty sure I did it via the '. . . > Delete from history' option. At the time I got a warning m… (read more)

Some time ago I removed a website form the New Tab Top Sites list. I'm pretty sure I did it via the '. . . > Delete from history' option. At the time I got a warning message similar to 'This action cannot be undone'.

That was fine, but since then I cannot visit the website directly via the address bar or via the link that tends to appear in New Tab > Top Sites. What I've been doing is searching on DuckDuckGo then clicking that link, which works fine. That search is conveniently on my Top Sites list. I can access the site direct in another browser.

I recently had to reset my password for the site and now the reset link doesn't work. All the help I've found doesn't mention any problem like this.

How do I unforget/undelete/unblock this site? Help!

Asked by gryph 2 months ago

Why is Firefox caching my site?

Hello, I have deployed a new version of my site (internal, sorry) and Firefox keeps caching it although I don't see the reason for it. This is the info about it in 'about… (read more)

Hello, I have deployed a new version of my site (internal, sorry) and Firefox keeps caching it although I don't see the reason for it.

This is the info about it in 'about:cache' (I deployed a new version at 10:20):

key: https://[URL-OF-THE-SITE]/ fetch count: 6 last fetched: 2020-05-05 10:17:05 last modified: 2020-05-05 10:23:31 expires: 2020-05-05 11:04:08 Data size: 5758 B Security: This is a secure document.

[...]

request-method: GET

response-head:

HTTP/2 200 OK server: nginx/1.17.4 date: Tue, 05 May 2020 07:13:10 GMT content-type: text/html content-length: 5758 last-modified: Mon, 04 May 2020 12:43:21 GMT etag: "5eb00de9-167e" accept-ranges: bytes referrer-policy: no-referrer strict-transport-security: max-age=31536000 X-Firefox-Spdy: h2

original-response-headers:

server: nginx/1.17.4 date: Tue, 05 May 2020 07:13:10 GMT content-type: text/html content-length: 5758 last-modified: Mon, 04 May 2020 12:43:21 GMT etag: "5eb00de9-167e" accept-ranges: bytes referrer-policy: no-referrer strict-transport-security: max-age=31536000 X-Firefox-Spdy: h2 ctid: 1 uncompressed-len: 0 net-response-time-onstart: 315 net-response-time-onstop: 319

In the Firefox Developer Tools I always get "5,62KB (raced)" (see attached image) and looking at my server logs, it does actually fetch the page, but it still shows an old version. The content supplied by the server is definitely the new version and other browsers don't seem to have this problem.

Thanks in advance for your help!

Edit: The etag has changed between the two versions.

Asked by shlintopf 2 months ago

Installed language package but it does not work.

I've tried to install the German language package, but it doesn't appear in the language menu, and the Canadian and British English are also not available, although there… (read more)

I've tried to install the German language package, but it doesn't appear in the language menu, and the Canadian and British English are also not available, although there all preinstalled. What can I do? (Firefox 75.0 for Ubuntu)

Asked by Anybest 2 months ago

Firefox automatically scrolls down to the end of the page

I'm using Firefox 76 on Arch Linux. Since 2 days my Firefox scrolls automatically after some minutes of usage. Before that everything worked fine. I didn't install anyth… (read more)

I'm using Firefox 76 on Arch Linux. Since 2 days my Firefox scrolls automatically after some minutes of usage. Before that everything worked fine. I didn't install anything new nor did I install a new extension.

Same happens in Safe-Mode. I've also tested a different browser to make sure that it's not a hardware issue with my mouse.

Asked by Fabian 2 months ago

Picture in picture no longer go fullscreen

Hello The picture in picture feature have a regression on Firefox 76. In Firefox 75 I could set the video full-screen with picture-in-picture feature by double clicking o… (read more)

Hello

The picture in picture feature have a regression on Firefox 76. In Firefox 75 I could set the video full-screen with picture-in-picture feature by double clicking on the video window., at least in Linux (Xubuntu 18.04 64bits), on windows for some reason it didn't work. Now on Linux, with Firefox 76, this do not work anymore (not tested on windows).

Also, having a button to do it would be nice too.

Thanks.

Asked by youpjk10 2 months ago

exited from fullscreen video after change workspace

Using xmonad window manager; 1. Open firefox, and play fullscreen youtube video on workspace-1. 2. Change view (firefox still on workspace-1) to workspace-2. 3. Change vi… (read more)

Using xmonad window manager; 1. Open firefox, and play fullscreen youtube video on workspace-1. 2. Change view (firefox still on workspace-1) to workspace-2. 3. Change view to workspace-1. Problem: The video that still playing will automatically exit from fullscreen, where it suppose to be still playing fullscreen.

Note: - This happen with xmonad window manager, but not with awesome window manager. - This probelm not happen with chromium web browser on xmonad. - Same problem still happen with firefox safe-mode (addons disable). - Same problem still happen with default xmonad configuration.

Versions tested: - Firefox 75.0 - xmonad 0.15

Asked by Muhammad Najib 2 months ago

How to make firefox save the volume levels set by pulseaudio (pavucontrol)?

I'm using Firefox 76 on Arch Linux. Typically, I set the volume levels for applications using pavucontrol, the pulseaudio utility. When I'm watching any sort of media str… (read more)

I'm using Firefox 76 on Arch Linux. Typically, I set the volume levels for applications using pavucontrol, the pulseaudio utility.

When I'm watching any sort of media stream in Firefox, Youtube for example, I'll adjust the volume of the stream using the "Firefox: Audio Stream" slider that shows up in pavucontrol's playback section. This works fine. My problem however, is that when I scroll back and forth in the video, refresh the page, or move to another video in the playlist, the slider in pavucontrol immediately jumps back up to 100%, ignoring the value I had just previously set. I want to know how to make the change I made in pavucontrol persist.

This can be mitigated by using the in browser volume controls (the youtube volume slider), but these are usually quite small and don't offer as much control as the pavucontrol sliders do. Something else to note is that if I go into Firefox's about:config and set media.volume_scale to a value greater than 1, the pavucontrol sliders begin to act how I would like them to (not resetting to 100%). However, upon doing this audio streams now start at 0% volume, and the in-browser "mute" button is broken (sets the volume to 0, but won't change it back).

Is there any way to achieve this behavior in Firefox? Literally every other browser I've tried just doesn't mess with my audio settings, so it's quite frustrating. This problem has persisted for years.

Asked by Ryan 2 months ago

Firefox 76 no longer plays netflix videos

After upgrading to firefox 76, I am no longer able to play netflix videos. However, I downloaded and running 75, I can play netflix videos. I am using Linux Mint 19.3 Tri… (read more)

After upgrading to firefox 76, I am no longer able to play netflix videos.

However, I downloaded and running 75, I can play netflix videos.

I am using Linux Mint 19.3 Tricia 19.3

Asked by Blue C 2 months ago

Why can't I run skype in firefox web browser in linuxmint?

I am using linuxmint 19.3 and 76.0 version of firefox(32 bit).When I try to use skype on firefox web browser, the message reads "Browser not supported. Use Microsoft Edge… (read more)

I am using linuxmint 19.3 and 76.0 version of firefox(32 bit).When I try to use skype on firefox web browser, the message reads "Browser not supported. Use Microsoft Edge or Google Chrome to access Skype for Web experience. Alternatively you can use Skype Web Control or download Skype on your desktop computer." Is there any way I can use skype in firefox?

Asked by My Firefox 2 months ago

Cannot launch downloaded files from Firefox on ubuntu 20.04

I have a fresh install of Ubuntu 20.04 with default installed Firefox 76 .02. OS has all updates and patches applied. Right out of the box the Downloads Panel in Firefo… (read more)

I have a fresh install of Ubuntu 20.04 with default installed Firefox 76 .02. OS has all updates and patches applied.

Right out of the box the Downloads Panel in Firefox is not working for me like it used to. After downloading files from different websites, ex. .csv or .pdf, etc., the Downloads Panel asks whether to Save or Open. If I select Save it saves to ~/Downloads but then if I click on the folder or right-click to view the folder contents Firefox now brings up a dialog titled "Launch Application" and has a choose button to search for other Application. I'm not sure why Firefox is asking me to select a new launch application when it should be able to determine that for basic file types that should already be registered in the OS like PDF and CSV. If I select "choose" and try to find a preinstalled app from /usr/bin it says Permission Denied.

Firefox process is running under my personal userid which is an administrator account.

I've tried removing and reinstalling Firefox using Ubuntu Software app. I've logged out of my Firefox account and tried that way. I've created new firefox profiles and reverted to default, restart, still does the same things.

So basically I am unable to launch any downloaded files from Firefox's Downloads Panel, or even launch Ubuntu's Files app so I can view the download.

Any suggestions?

Asked by Whistle 2 months ago

Where does stuff downloaded from web apps opened as SSB (--ssb) go in Linux?

For instance: I open whatsapp.com as a web app in a site specific browser instance using firefox --ssb https://web.whatsapp.com Firefox works well for this. However, if I… (read more)

For instance:

I open whatsapp.com as a web app in a site specific browser instance using firefox --ssb https://web.whatsapp.com

Firefox works well for this. However, if I receive a Whatsapp message with a pdf attachment and I click on it, firefox only says the attachment has been downloaded but does not say where and I cannot find the file in any obvious location.

Without --ssb, in the same whatsapp web app clicking on an attachment triggers firefox to show a window saying whether to open the file with an application or download it and in the latter case, FF either downloads to the default download location or asks me where to download (depending on my settings).

Asked by sergio.callegari 2 months ago

Why does Firefox block loading of a resource at inline (“script-src”).

I have content security policy headers defined for my site. However, I have nothing defined for script-src. When I load a certain page from my site in Firefox 76.0 I see … (read more)

I have content security policy headers defined for my site. However, I have nothing defined for script-src. When I load a certain page from my site in Firefox 76.0 I see the following messages in the console:

Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). 8 utils.js:35:9 Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). 2 gps.js:231:11 Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). 4 utils.js:35:9 Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). gps.js:231:11 Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”). 3 utils.js:35:9

When I load the same page in Chromium, I see no such messages in the console.

Furthermore, there are no utils.js and gps.js scripts in the source of the loaded page. Finally, I see no problems with the display or the functionality of the page. Clearing all the cookies and the caches (local and server) has no impact on this issue. There are many other javascripts on the page, both inline and not, which do not appear to be affected but the existing settings.

So, my questions: 1) Why do these messages appear? 2) Is this an issue that I need to fix or can I safely ignore it? 3) what do the numbers after the script names mean? (gps.js:231:11 utils.js:35:9)

Asked by Ambyo 1 month ago

YouTube Live video is not playing

I am trying to play live videos on youtube but its not playing at all. it saying this following error Your browser does not currently recognize any of the video formats a… (read more)

I am trying to play live videos on youtube but its not playing at all. it saying this following error Your browser does not currently recognize any of the video formats available. Click here to visit our frequently asked questions about HTML5 video.

Asked by Najm Us Saqib 1 month ago

Why does site asks me to accept privacy policy again on every new tab I open within this site?

I am a new Linux user with an installation of Ubuntu 18.04 and firefox is the default browser. When I visit a site I am asked to accept the site's privacy policy.Once thi… (read more)

I am a new Linux user with an installation of Ubuntu 18.04 and firefox is the default browser.

When I visit a site I am asked to accept the site's privacy policy.Once this is done, I click a page within this site to open in a new tab and in the new tab I am asked again to accept the site's privacy policy! This happens in all new tabs I open within a site.

I have tried disabling enhanced tracking protection completely or for specific sites (the "shield" sign to the left of the site address) but there is no change. I would imagine it is a matter of the site not finding a cookie in my machine, so it doesn't recognize that I have visited the site again and treats me as a new visitor, right?

I have fiddled with all firefox privacy and security settings but there is no change as well.

Please enlighten me :)

thanks in advance

Asked by greenguru1978 1 month ago

I am running CentOS 7 with dark theme, and when opening forms in firefox, the text box background and the letters inside them are both colored black

I am running CentOS 7 with dark theme, and when opening forms in firefox, the text box background and the letters inside them are both colored black making it impossible … (read more)

I am running CentOS 7 with dark theme, and when opening forms in firefox, the text box background and the letters inside them are both colored black making it impossible to write any thing inside the text box.

Though the problem is not with every website, only a few and definitely when I when filling Credit/Debit card details for online payment. I am also proving a screen shot from opensourceforu.com website, which is their subscription form, which I cannot fill because everything in the text bos is dark. The subscription page url is "https://subscribe.efyindia.com/electronicsforu/subscription/giftsOSFY.asp"

So, what can be done, to either change the color of the background or of the text to solve this problem.

Asked by Nilesh 1 month ago

How to stop FF auto-resetting my keyboard when cursor enters a password field?

My system auto-loads a custom keyboard map (via Xmodmap or xkbcomp) on login. As long as the cursor does not enter a password field on a page displayed in FF, the key map… (read more)

My system auto-loads a custom keyboard map (via Xmodmap or xkbcomp) on login. As long as the cursor does not enter a password field on a page displayed in FF, the key map remains functional until I logout.

After a recent FF update, whenever the cursor does enter a password field in FF, the keyboard map is blown away (returns to standard qwerty). This creates an incredibly annoying workflow: Enter password >> Halt >> Manually reload keymap >> Resume

No other browser or program does this so I'm sure it's a FF problem. I've already started migrating all password-entry sites to Chrome, but this is a workaround. How to fix? .. (FF 76.0, Ubuntu 18.04.4)

Asked by Bill 1 month ago