Showing questions tagged: Show all questions

Firefox crashes at start. libxul.so: undefined symbol: PR_DuplicateEnvironment Couldn't load XPCOM

After update Fedora 31: firefox -safe-mode XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so: /usr/lib64/firefox/libxul.so: undefined symbol: PR_DuplicateEnvironm… (read more)

After update Fedora 31:

firefox -safe-mode XPCOMGlueLoad error for file /usr/lib64/firefox/libxul.so: /usr/lib64/firefox/libxul.so: undefined symbol: PR_DuplicateEnvironment Couldn't load XPCOM.

uname -a Linux localhost.localdomain 5.4.18-200.fc31.x86_64 #1 SMP Fri Feb 7 14:50:05 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux


dnf reinstall firefox and remove/install are not help

Asked by saa15 2 months ago

Opinion wanted

I am using Opensuse 15.0 and also 15.1. Haven't made a complete move over yet. There is a recurring situation when 4GB rx and 4GB tx movement that I cannot account for hi… (read more)

I am using Opensuse 15.0 and also 15.1. Haven't made a complete move over yet. There is a recurring situation when 4GB rx and 4GB tx movement that I cannot account for hits my 15.0 about once a month. Today it happened again. Using vnstat, I found it happened between 10.00 - 11.00. :

h  rx (MiB)   tx (MiB)      h  rx (MiB)   tx (MiB)      h  rx (MiB)   tx (MiB) 

13 0.00 0.00 21 3.67 0.57 05 0.00 0.00 14 0.00 0.00 22 24.49 2.24 06 0.00 0.00 15 34.60 1.85 23 0.00 0.00 07 0.00 0.00 16 175.23 9.05 00 0.00 0.00 08 193.93 9.07 17 0.00 0.00 01 0.00 0.00 09 0.00 0.00 18 0.00 0.00 02 0.00 0.00 10 3,939.97 4,090.57 19 0.00 0.00 03 0.00 0.00 11 31.14 2.34 20 0.00 0.00 04 0.00 0.00 12 7.60 1.06 I was merely surfing, no download. Searched the cookies, one site i cannot recognize came out; "consensu.org". Did a search, there were several, example: https://cmp.teads.mgr.consensu.org/index.html, that served blank pages in firefox. Is there anything odd here? Is there a way I can extract all the cookies with date & time so that I can check against previous occurrences of the 4GB data movements (I have a few records).

Asked by lims3148 2 days ago

  • Archived

Firefox stop working

I'm running Firefox 26 on OpenSUSE 13.1 64bits. I got problem in Firefox 26 to use IBM Lotus iNotes and the recommandation is to revert to Firefox 24 ESR. I tried to do t… (read more)

I'm running Firefox 26 on OpenSUSE 13.1 64bits. I got problem in Firefox 26 to use IBM Lotus iNotes and the recommandation is to revert to Firefox 24 ESR. I tried to do this, but it didn't work.

Now i uninstall all Firefox and installed the latest version (26) again. Now Firefox won't load any web-page. It just saying "Connecting..." but nothing happens. No timeout nor error-mesg.

If i run Firefox in terminal, i get this message; (process:3072): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed


I also backed up the profile og recreated a new profil. I suspect that the version 24.2 ESR did some change to files, but i uninstalled everything, rebooted and installed new. Still it doesn't work :-(

What is wrong!?

Asked by ronnysimonsen 6 years ago

Last reply by guigs 6 years ago

  • Solved
  • Archived

How to build browser and locale packages for Ubuntu/Debian

Since Ubuntu Mozilla Daily ppa is no longer regularly updated (see https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa ), I want to build my own self-signed Firefox … (read more)

Since Ubuntu Mozilla Daily ppa is no longer regularly updated (see https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa ), I want to build my own self-signed Firefox packages similar to the ones created by Ubuntu Mozilla Daily; but I can't find anywhere the way they are built.

Actually I successfully compile Firefox, so I need just the necessary informations in order to build a deb package with it.

Thank you

Asked by izietto 6 years ago

Answered by patrickmc 6 years ago

  • Solved
  • Archived

after using the terminal,wireless connection is gone

Yesterday I was looking online to see how can I transfer pictures,files from my Nexus 7 tablet to my desktop computer with the usb cable.. I've found several support foru… (read more)

Yesterday I was looking online to see how can I transfer pictures,files from my Nexus 7 tablet to my desktop computer with the usb cable.. I've found several support forums like this one I'm using right now,someone has already asked a question like mine so I followed the best answer, I typed the commands in the terminal as the helper suggested,then I restarted my desktop pc,after that it didn't connect any more,it connects wireless usually,but since yesterday no connection:( I still have the page/link that shows the answer I've followed (the top one) :

http://askubuntu.com/questions/207569/how-do-i-connect-a-nexus-7-to-transfer-files

thank you!!

Asked by mediterranean 6 years ago

Answered by patrickmc 6 years ago

  • Archived

How to upgrade to latest version on Ubuntu 10.10 LTSP server

I run Ubuntu 10.10 LTSP server/client network and DO NOT want to upgrade Ubuntu... too much trouble, nobody can guarantee it will not hammer my LTSP install and besides, … (read more)

I run Ubuntu 10.10 LTSP server/client network and DO NOT want to upgrade Ubuntu... too much trouble, nobody can guarantee it will not hammer my LTSP install and besides, Unity is awful. I need newer Firefox due to some frequently used web pages, so I need an install procedure that will not hammer anything. It's a mission critical user environment. If anybody has positive experience with Firefox upgrade in similar environment please advise.

Asked by InterpreDemon 6 years ago

Last reply by patrickmc 6 years ago

  • Archived

html5 audio

How i can configure audio output in html5? Firefox html5 plays only on first ALSA sound card ignoring my ~/.asoundrc in home directory. But other sounds like plugins Flas… (read more)

How i can configure audio output in html5? Firefox html5 plays only on first ALSA sound card ignoring my ~/.asoundrc in home directory. But other sounds like plugins Flash and other according to ~/.asoundrc work fine for me in firefox. My system: Debian Jessie x86_64 Browser: firefox v28.0 x86_64 Audio: ALSA only (no pulseaudio, no OSS, no phonon ... etc)

Problem only with html5 audio

Asked by EuPhobos 6 years ago

Last reply by guigs 6 years ago

  • Archived

I have been phished and can't adjust settings without them being sent to an automatic redirected site

opened an email over a month ago from a friend. I got phished. Two days ago they sent the same email under my address and conversed with the recipients, impersonating m… (read more)

opened an email over a month ago from a friend. I got phished. Two days ago they sent the same email under my address and conversed with the recipients, impersonating me to assure them it was safe and give further instruction. The have also tried to gain further access info to one of my credit cards. I have changed my password, but when I attempt to secure it Firefox notifies me the information will automatically be redirected to a site. can't perform the administration.

Asked by Jim888 5 years ago

Last reply by FredMcD 5 years ago

  • Archived

Spell checker switching languages

This has gone on for awhile and is really getting annoying. There have been times I have had to reset the language 4 times in about an hour. Anything I type in email, on… (read more)

This has gone on for awhile and is really getting annoying. There have been times I have had to reset the language 4 times in about an hour. Anything I type in email, on line forms or forums it does it, not every email but if I write a couple it will switch on one of them. I don't know if its web sites I go to or my location in Korea that does it. Usually Canada or UK English. I am using Mageia 4 and FF 38.2.0 Is there a fix for this?

Asked by duder 4 years ago

Last reply by John99 4 years ago

  • Archived

I would like to wrap the text in my tabs to more than one line

Hi everybody. As already mentioned, i would like to wrap the tab-titles to more lines so i am able to display more information of the title. Unfortunately i cannot find a… (read more)

Hi everybody.

As already mentioned, i would like to wrap the tab-titles to more lines so i am able to display more information of the title. Unfortunately i cannot find a way to do this except the more or less poor addon "tabtweak". I have tried manipulating the style via userChrome.css but all of my efforts wont have any effect on the length/overflow of the displayed text.

Here is what i have tried so far:

/*@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

.tabbrowser-tab:not([pinned]) .tab-text {

                               border: !important; 
                               word-wrap: break-word !important;
                               word-break: normal !important; 
                               white-space: wrap !important; 
                               height: 3em !important;
                               overflow-y: visible !important; 
                               overflow-x: visible !important; 
                               overflow: visible !important;
                               text-overflow: visible !important;
                               display: inline-table !important; 
                               max-width: none !important;}

It would be awesome if someone is able to help out here. Soultice

Asked by soultice 4 years ago

Last reply by guigs 4 years ago

  • Archived

Linux - fullscreen flash video opens on wrong monitor

When i click fullscreen button on a flash video (for example video embedded from Vimeo) it opens fullscreen on the wrong monitor. Not the one on which the action has been… (read more)

When i click fullscreen button on a flash video (for example video embedded from Vimeo) it opens fullscreen on the wrong monitor. Not the one on which the action has been started, but on my laptop built in screen. Extremely annoying as I can't get fullscreen flash running on my external monitor , which I use as my main one. In Chrome it works correctly (but I know it uses Pepper). I'm running Firefox 40.0.3, on Fedora 21 (Linux 4.1.6 . Gnome 3.14).

Asked by Przemas 4 years ago

Last reply by guigs 4 years ago

  • Archived

Show all possible PDF applications

I have written several local shell scripts to handle how to open a PDF. When Firefox asks me how to open a PDF, I would like to see all of them in the dropdown menu. Howe… (read more)

I have written several local shell scripts to handle how to open a PDF. When Firefox asks me how to open a PDF, I would like to see all of them in the dropdown menu. However, I can only see the one that I had previously selected, so whenever I want to use another one, I have to click "Other..." and go through my filesystem to their respective paths. Is there a way to permanently make several applications appear in that dropdown menu?

Asked by jowi 4 years ago

Last reply by cor-el 4 years ago

  • Archived

Addons keep getting disabled when switching between Linux and Windows (Using the same profile data).

I am dual booting Windows and Linux on my laptop. Both operating systems have Firefox Developer Addition installed. I have my Firefox profile folder on a partition which … (read more)

I am dual booting Windows and Linux on my laptop. Both operating systems have Firefox Developer Addition installed. I have my Firefox profile folder on a partition which both Linux and Windows can read, and both installs of Firefox use that profile. The problem is, whenever I switch operating systems, all my addons get disabled and I have to manually re-enable them.

Why is it doing this, and how can I keep this from happening?

I know I could just use Firefox Sync, but it is so much more convenient to have all my open tabs on both operating systems exactly the same.

Thanks!

Asked by IsaacG 4 years ago

Last reply by UNeverNo 4 years ago

  • Archived

malware installed after 42.0 update

I had a big night writing lab reports last night (so much fun). However during that time Firefox updated to 42.0. When I turned on my computer this morning I was receivin… (read more)

I had a big night writing lab reports last night (so much fun). However during that time Firefox updated to 42.0. When I turned on my computer this morning I was receiving an error message "from Microsoft Internet Explorer" which was very obviously malware. It came up with an error code of PORNDROID9007QD1 and would persistently make a high pitched beeping noise. It gave two options: "Leave page" and "stay on page" (no browser was open).

I did not do any questionable browsing or downloading. I have virus protection installed, and I'm also very security conscious having been on the internet for most of my life and know dodgy content when I see it. I don't download music, movies, or programs.

I can only find one other person with this issue online (http://www.wilderssecurity.com/threads/code-porndroid9007qd1-insufficient-privileges-to-post-in-browser-hijacks-forum.381267/) and they only got this issue the other day as well. From reading there it appears to be a javascript bug originating in Chrome, but I don't use Chrome. Yes, I have a Chromium browser installed (Maelstrom) but have not used it in months.

I'm thinking this might be a new threat that just hasn't been identified yet, but the only thing that changed on my computer last night was Firefox updating.

Has anyone else had this issue?

Asked by NoSyt 4 years ago

Last reply by NoSyt 4 years ago

  • Archived

Firefox 43.0 slow at contacting websites

Hi everybody, I am having a little problem with Firefox on my Ubuntu, and I was wondering if someone could help me. The problem is that my Firefox started to act very slo… (read more)

Hi everybody,

I am having a little problem with Firefox on my Ubuntu, and I was wondering if someone could help me. The problem is that my Firefox started to act very slow after the v43.0 update. I am using Ubuntu 14.04 LTS 64bit.

Every page that I try to open takes about 5-30 seconds to load, and sometimes it doesn't load at all (displays that connection was restarted, or blank tab). I tought it was problem with my OS, so I started up Windows Vista in virtualbox with Firefox v42 (it wasn't updated yet), and went to compare it. And really the Firefox 42 on my Vista in Virtualbox was A LOT faster when opening pages (almost instantly) than Firefox 43.0 on my host OS - Ubuntu.

Then I updated the Firefox on Vista virtualbox from 42 to the version 43.0.2., and it was OK, the speed was the same as before. So no problems on the Virtualbox with the 43. But on host OS, my Ubuntu 14.04, Firefox 43.0 is very slow when loading any page. I read something about nvidia network manager on Firefox reddit, but I am not sure if I do have that program on my Ubuntu. I have laptop with optimus technology and I am using only Intel GPU, so Nvidia should not be the problem, right?

I also checked for updates, to see is there Firefox v43.0.2. for Linux also, but no new updates were found. I am huge fan of Firefox, but this is annoying, browsing the web is simply imoposible. It's even worse when you know that everything it's working fine on Virtualbox, but not on host OS. I tried opening my test pages on Ubuntu browser (based on Chromium) and it worked ok, the load speed was almost the same as on virtualbox. So that leads me to the conclusion - is it something wrong with Ubuntu or Firefox, and can it be fixed?

Note: The problem is that Firefox is slow to "contact" the site. It's like it is testing does website even exists, or does the connection works or something like that. So the problem is in contacting the page, beacuse sometimes it showes nothing, just blank tab, or error message: "Connection was restarted".

I would really be greaful for any help. Thanks!

Asked by NaneK 4 years ago

Last reply by guigs 4 years ago

  • Archived

Corrupted profile works only some times

I have a my Firefox profile and a copy of its folder. After a certain amount of time launching Firefox with this profile, the history and cookies are missing in the brows… (read more)

I have a my Firefox profile and a copy of its folder. After a certain amount of time launching Firefox with this profile, the history and cookies are missing in the browser, as well as some other preferences and data. What I do is that I close Firefox, delete the profile folder, duplicate the copy to a new copy and rename the original copy to match the profile folder name. The next time I launch Firefox history and cookies are here again. Then after 3 or 4 launches, they've disappeared again, so here I go again with the copies.

I don't know what causes the profile folder not to work after a few launches. One time the history was there again even after rebooting the computer, most of the time it disappears after a few hours (after a few relaunches of Firefox).

The profile originally became corrupted when I performed a cold shutdown of my computer while Firefox was open. I remember that when I booted again, my profile was well; it was at the next Firefox launch that the data was missing. I opened the sqlite files with the sqlite3 command line and they looked clean. Next time I launched Firefox the data was available again. I made a copy of the folder in case of, and there I am with the merry-go-round of copies.

Asked by SU001 4 years ago

Last reply by guigs 4 years ago

  • Archived

scrolling with mouse wheel causes page to jump back to last page visited or forward if it has already jumped back

Using Firefox 44.0.2 on Ubuntu 14.04 everything had been working before an update. Now trying to scroll through any web with the mousewheel seems to trigger the same act… (read more)

Using Firefox 44.0.2 on Ubuntu 14.04 everything had been working before an update.

Now trying to scroll through any web with the mousewheel seems to trigger the same action as the back or forward buttons would be used for.

( I have seen it happen on reddit.com and http://openjdk.java.net/jeps/286 )

I have tried disabling gestures as was described here:

https://support.mozilla.org/en-US/questions/915174

I tried setting all the mousewheel actions to 0 as described here.

https://support.mozilla.org/en-US/questions/943700

This page https://support.mozilla.org/en-US/questions/1111123 suggests setting middlemouse.contentLoadURL to false, but for me it was already false.

I am triggering the back/forward jumps accidentally so often that Firefox is almost unusable.

Asked by wshackle 4 years ago

Last reply by Michal Stanke 4 years ago

  • Archived

After Login I cant click anything, only Ctrl+(Click) is responding in Firefox Developer Edition, this is happening in Unity after I installed GNOME separately

I use Ubuntu 14.04 LTS recently I installed GNOME environment alongside Unity to check it out. The Firefox Developer Edition works fine in GNOME and worked fine in Unity … (read more)

I use Ubuntu 14.04 LTS recently I installed GNOME environment alongside Unity to check it out. The Firefox Developer Edition works fine in GNOME and worked fine in Unity till now, after I log out of GNOME and log into Unity, nothing on the browser window is responding, that is with left click nothing, right click opens the window options. When I use Ctrl + Left/Right Click it starts working properly but its becoming a trouble when I have multiple tabs for the same thing. I refreshed it and disabled all Add Ons, even then I tried safe mode, it still is the same! What should I do?

Asked by dibbadu 4 years ago

Last reply by John99 4 years ago

  • Archived

How do stop FireFox from offering to reset my profile?

Every time I restart FireFox (seems to be longer than FF's check for "Haven't started in awhile") or run it on a machine I haven't used ineractively for awhile, it offers… (read more)

Every time I restart FireFox (seems to be longer than FF's check for "Haven't started in awhile") or run it on a machine I haven't used ineractively for awhile, it offers to delete my add-ons, add-on settings and about:config settings. How do I make it stop offering to do that?

Asked by Abscissa256 4 years ago

Last reply by cor-el 4 years ago