Showing questions tagged: Show all questions

How do I adjust the deceleration of kinetic scrolling?

I'm trying out Firefox 85.0 on Wayland (not XWayland) on Ubuntu 20.10. When scrolling a page and letting go, the kinetic scrolling is taking off like a rocket, as though … (read more)

I'm trying out Firefox 85.0 on Wayland (not XWayland) on Ubuntu 20.10. When scrolling a page and letting go, the kinetic scrolling is taking off like a rocket, as though the average user is more interested in reading a random paragraph 5 km down the page as opposed to scrolling half a page down to the next paragraph...

Everything works fine in macOS -- no insane speeds there.

How do I fine-tune this?

Preferrably I'd like to fine-tune the actual scroll acceleration since that part of the experience is also way off and about 20x faster than it needs to be for 99.9% of all scroll actions. If that would solve the above problem by decreasing the speed while increasing the deceleration upon release of the scroll gesture, then even better.

Asked by onetimename 2 months ago

How do I adjust the precision scrolling speed?

Firefox 85.0 in Wayland (not XWayland) scrolls far too fast when I use scroll gestures on my trackpad. I believe I have the same problem on XWayland too. Since the value… (read more)

Firefox 85.0 in Wayland (not XWayland) scrolls far too fast when I use scroll gestures on my trackpad. I believe I have the same problem on XWayland too.

Since the values are not properly adjusted out of the box I'm assuming that they can't be adjusted properly beforehand, but then I'm confused as to why I can't seem to easily find where to adjust them myself, considering that that's necessary by design.

I can't find these settings anywhere. How do I do this?

Asked by onetimename 2 months ago

Geolocation does not work.

Hello Firefox Community. Since a month I have almost constant problems with geolocation. It worked for couple of days but now it is not working at all. I suspect a probl… (read more)

Hello Firefox Community.

Since a month I have almost constant problems with geolocation. It worked for couple of days but now it is not working at all. I suspect a problem with API key – what ever it is.

First of all geoloction service stopped working when geo.provider.network.url was setup to Google service.

https://www.googleapis.com/geolocation/v1/geolocate?key=%GOOGLE_LOCATION_SERVICE_API_KEY%

This transforms into:

https://www.googleapis.com/geolocation/v1/geolocate?key=AIzaSyCJysf0qByNCVmZhH4cE1LxPZ20hJT3ipg

And as you can see, it returns just 404 Not Found.

I found the info that I can change it to:

https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%

and… it also does not work. I can lookup what is the link (without variable):

https://location.services.mozilla.com/v1/geolocate?key=27e30dd8-ba74-4ef0-86c6-9fceab8a7089

And this time when I enter this link I can see an error: 400 Bad Request:

Missing or wrong API key.

Can you help me setting this correctly and having geolocation working again?

Asked by J.Wasielewski 2 months ago

Firefox 2FA "Enable" screen will not accept code generated by authenticator app after scanning

After a phone repair, I had to sign in to my Firefox account. It wanted my 2FA code but these had gone from my Google Authenticator app. So I witched of Firefox 2FA on my… (read more)

After a phone repair, I had to sign in to my Firefox account. It wanted my 2FA code but these had gone from my Google Authenticator app. So I witched of Firefox 2FA on my computer, and signed into my Firefox account on my phone. Then I wanted to re-enable 2FA. But after scanning the QR code in the authenticator app, the Firefox 2FA screen would not accept the code generated by the app. I have tried this with Google Authenticator and Authy. Same problem.

Asked by dboneham 2 months ago

Hide context menu icons

Hello, Is there any way of customising the menus (such as context/right-click menus)so that they do not display any kind of icons? For example the burger menu has icons … (read more)

Hello,

Is there any way of customising the menus (such as context/right-click menus)so that they do not display any kind of icons?

For example the burger menu has icons for "Print" and other items.

This is inconsistent with my desktop environment (GNOME) and all of my other desktop apps (which follow the default GTK settings that disable such icons)

Another minor thing is underlining certain characters in those menus (for keyboard shortcuts, I think), for some of the items. This is another inconsistency which is also disabled system-wide by default in GNOME.

Is there some way of disabling these? Maybe an about:settings config that I didn't find yet?

Asked by Horațiu Mlendea 2 months ago

Open external link in tab only when the window is on the same virtual desktop

For controlling the behavior when openning an external link (from a different program) there is `browser.link.open_newwindow.override.external`. It can be configured to a… (read more)

For controlling the behavior when openning an external link (from a different program) there is `browser.link.open_newwindow.override.external`. It can be configured to always open a new window, or always open a new tab in the last active window.

However, I use multiple virtual desktops on linux and when I open a link (from anywhere, really), I'd like it to be opened on the current virtual desktop but also in an existing window if there is one. It should almost be as if the firefox on each virtual desktop behaves independently for this purpose though I don't think actually doing that (one firefox instance per virtual desktop) would be a solution since I do need to move tabs/windows around fairly often as well.

Is there a way to do that with some settings?

Asked by yuyichao 2 months ago

video playback issue with fresh install of ubuntu

hi, i just installed ubuntu 20.04 LTS. I am not running any extensions or add-ons, just default settings. I can't play any youtube video that is considered 'live'. I can … (read more)

hi, i just installed ubuntu 20.04 LTS. I am not running any extensions or add-ons, just default settings. I can't play any youtube video that is considered 'live'. I can watch any other video on youtube, however. For the 'live' videos, I get a message: 'Your browser can't play this video, learn more' And when I click learn more, it says my browser is up to date. I tried streaming other videos from websites like crunchyroll.com and none work. I followed some suggestions to clear cache, turn on video/audio settings, etc. but nothing is working. Please assist. thanks.

Asked by sktrinh12 2 months ago

Firefox isn't syncing properly

Hello Should Firefox be syncing between installations on different platforms? On my Windows Firefox, I have the CamelCamelCamel extension and the Facebook containers exte… (read more)

Hello

Should Firefox be syncing between installations on different platforms?

On my Windows Firefox, I have the CamelCamelCamel extension and the Facebook containers extension, but on Linux those aren't being picked up!

What am I missing? When I force it to Sync on Manjaro Linux, it says it is all synced up, but those extensions I mentioned aren't coming through!

Thanks

Asked by ciwan1859 2 months ago

FF 78.8.0ESR can't load NYT homepage

Hi! Updated FF on my Linux box today & now the NYT homepage can't be loaded. Altho' the WaPo homepage seems to load faster, the NYT just times out in mid-render, prob… (read more)

Hi!

Updated FF on my Linux box today & now the NYT homepage can't be loaded. Altho' the WaPo homepage seems to load faster, the NYT just times out in mid-render, probably due to the site's heavy javascript. FF doesn't pop up any error messages, alas.

I'm assuming the new FF is simply allergic to the NYT's clunky code. But still. . .any tips, tricks, workarounds or hints to fix?

Ty!

Asked by frelkins 2 months ago

claiming they belong to priemna@mvr.bg, organised 24/7 group broke the add-on.

relate "claiming they belong to priemna@mvr.bg, organised 24/7 group broke the add-on." to - 1/ Igor Petrovich 2/ Igor Markovski 3/ Stela from Geo Milev 4/ ff-bg.net 5/ a… (read more)

relate "claiming they belong to priemna@mvr.bg, organised 24/7 group broke the add-on." to -

1/ Igor Petrovich 2/ Igor Markovski 3/ Stela from Geo Milev 4/ ff-bg.net 5/ add-ons 6/ 8211046345 7/ 200428387 8/ slusham 9/ .org 10/ Cherni vrah 1, abv.bg, testuser22 11/ Belneyski, secretary@dps.bg and Cherni vrah to Black Sea

Asked by mareshki teximbank.bg 2 months ago

'*' Bookmarks shortcut shows non-bookmark result first

Hello, Recently I observed following behavior: Ctrl+L to select addres bar. "* " to trigger bookmark shortcuts. I type few letters of my query. The seeked bookmark i… (read more)

Hello,

Recently I observed following behavior:

  1. Ctrl+L to select addres bar.
  2. "* " to trigger bookmark shortcuts.
  3. I type few letters of my query.
  4. The seeked bookmark is shown second on the list. The first results is a nonbookmarked history item.

See attached image for an example.

The issue is this: Why on earth would I bother with the "* " prefix if I wanted a non-bookmark result?

This seems be a recent change. Can this be disabled somehow? Thanks!

Asked by extremegf 2 months ago

NFS mounted home directory caused a hang condition in firefox. Repeatable when creating ebay listing

I am using centos 8.2 with it's firefox 78.7.0esr (64-bit) I also have my home directory mounted via NFS using the automounter system. In general firefox works fine in th… (read more)

I am using centos 8.2 with it's firefox 78.7.0esr (64-bit) I also have my home directory mounted via NFS using the automounter system.

In general firefox works fine in this configuration. However, when I get on Ebay and try creating a listing, firefox will hang when adding photos and/or moving the photo order. My NFS server will then start complaining about 'failed to contact remote rpcbind.

I try to close firefox and it doesn't It then will ask about a script running to long and offer to close. It won't I wait quite some time and it doesn't close About now the whole system is locked up and I may be able to get to the reboot menu I reboot and it won't because the process is hung. I usually have to power cycle to get things back.

I think if I waited for the automounter to time-out firefox may close at that time.

So the questions are: Is this supposed to work in an NFS environment? What is going on to cause the hang? Are there environment variables to move "some directory" to the local disk drive if that is the problem?

I sure hope someone can answer this for me. Thanks Warren

Asked by warrendodge 2 months ago

Firefox sync not working correctly?

Hi all - having an issue with Firefox sync... I have a Windows desktop, a Linux desktop, two Linux laptops and an Android phone...all running Firefox and signed into the … (read more)

Hi all - having an issue with Firefox sync...

I have a Windows desktop, a Linux desktop, two Linux laptops and an Android phone...all running Firefox and signed into the same Firefox account.

I've got them all set to sync bookmarks, but I've noticed that I'll often add a bookmark, organize it into a folder on one machine and then it will either never sync onto my other machines, or it will simply sync into the Bookmarks Menu rather than into whatever folder I had organized it into on all my other machines...

Is there a way to get it working properly on all my machines?

Thanks!

Asked by Darkstrike 2 months ago