Showing questions tagged: Show all questions

Ctrl+Shift+T opening new tabs instead of restoring closed ones

I'm facing a bewildering problem with Ctrl+Shift+T, which has only started in the past few hours and persisted through troubleshooting. In short, it's opening a default … (read more)

I'm facing a bewildering problem with Ctrl+Shift+T, which has only started in the past few hours and persisted through troubleshooting.

In short, it's opening a default new tab when I press that combination, rather than reopening the last closed tab, as is its normal function. The problem is not that the tabs themselves are lost -- the "Reopen Closed Tab" drop-down menu entry is still available on right-click, and seems to function as expected. Similarly, I checked about:config to see if there was a problem with sessionstore or sessionrestore, both of which are at their default settings and can't be causing this. Rather, something about the combination itself is no longer working.

I ran Firefox in Troubleshoot Mode to see if any of my settings were causing this. The problem persisted there, so that doesn't seem to be the case.

A little over a month ago, I got a new phone and synced up my desktop and mobile (Android) Firefox tabs, which I hadn't done previously. This is really the only thing I can think of that would lead to any issues, but it's impossible to match the timeframes -- I noticed this problem today, five hours ago. (The failure for ctrl+shift+t to work includes tabs that were opened from mobile sync.) I make heavy use of this keyboard shortcut and would've noticed it earlier if it started earlier.

Something about Ctrl+Shift+T itself is not properly being 'translated'. Ctrl+T works as expected (opens a blank tab), which is the same thing the Shift version is doing. Both my Ctrl and Shift keys are working fine in other respects (e.g. shift key capitalizes letters and adds special characters), so it's not keyboard hardware. It's not "inconsistent" -- it consistently works for everything else, and consistently doesn't work for this.

I'm using Firefox 122.0 on Windows 11.

Asked by vaticidalprophet 2 months ago

Last reply by cor-el 1 month ago

Can't disable number input arrows in forms

Hi, As the subject says, i cannot remove the up and down arrows from forms that have a numerical input even though autofill/history options are cleared and disabled. I'v… (read more)

Hi,

As the subject says, i cannot remove the up and down arrows from forms that have a numerical input even though autofill/history options are cleared and disabled. I've even tried deleting cookies, cache, site data and so on, to no avail. I've also tried a clean terminal with no extensions installed and i have the same issue. Other browsers do not have this issue on the exact same form. I am at a loss, any assistance would be appreciated.

Asked by MrTweaks 1 month ago

Last reply by TyDraniu 1 month ago

All logins fail to load from logins.json, with error NS_ERROR_FAILURE

Hi, My saved passwords are not showing up. I followed the advice on this post, by setting signon.debug and doing about:logins. Here are the errors shown in the console:… (read more)

Hi,

My saved passwords are not showing up. I followed the advice on this post, by setting signon.debug and doing about:logins. Here are the errors shown in the console:

LoginManager: Getting a list of all logins asynchronously. LoginManager.sys.mjs:395:14 Login storage: Returning 502 logins for specified origin with options [object Object] storage-json.sys.mjs:704:10 Login crypto: Failed to decrypt cipher text of length 92 with error NS_ERROR_FAILURE. crypto-SDR.sys.mjs:179:12

   ->
   decrypt resource://gre/modules/crypto-SDR.sys.mjs:197
   decryptLogins resource://gre/modules/storage-json.sys.mjs:966
   map self-hosted:221
   #decryptLogins resource://gre/modules/storage-json.sys.mjs:948
   InterpretGeneratorResume self-hosted:1465
   AsyncFunctionNext self-hosted:852

Then that last mesage is repeated another 501 times.

Any idea what is wrong. I have only one profile the default one. Firefox is up to date at 122.0.1 on iMac 12.7.3

Thank you David

Asked by dch888 1 month ago

Last reply by cor-el 1 month ago

Search with Startpage in address bar

I have Startparge set as my default search engine. I used to type directly into the address bar (see first image). Press Enter, and the Startpage results page for this … (read more)

I have Startparge set as my default search engine. I used to type directly into the address bar (see first image).

Press Enter, and the Startpage results page for this search phrase would show up. Somehow, this has now changed. I press Enter, but the result is just the Startpage home page, with a blank search box (see second image). So I then have to type the same phrase in again in Startpage's own box. This just trips me up.

The crazy thing is that this only happens sometimes - but more often than not. I haven't seen it work right for weeks: I just did it now to make screenshots, and it worked wrong. I just did it again and it worked as expected: pressing Enter took me to Startpage's results.

Any clues how to change settings to fix this?

Asked by sebthirlway 1 month ago

Last reply by zeroknight 1 month ago

Does having inactive tabs, such as news articles with embedded videos playing, consume data?

In my location, my only option for internet access is a mobile hotspot with limited data. Consequently, I am always mindful of my data usage when using my laptop. Despite… (read more)

In my location, my only option for internet access is a mobile hotspot with limited data. Consequently, I am always mindful of my data usage when using my laptop. Despite primarily browsing static pages, email, and other low-data activities, I often find my data usage higher than anticipated. The main culprit comes to mind to be videos embedded in news articles. Sometimes, with multiple tabs open, I switch to an inactive tab only to find a video playing. Although I've configured my Firefox preferences not to autoplay videos, it seems that YouTube videos still override these settings.

So, my question is, when a tab is inactive, does Firefox stop all data transfer for that tab in the background? And if not, what are the solutions to stop any background data other than continually closing all tabs?


Also, any suggestions on this topic are appreciated, especially from and to users who also live in remote areas without fiber, DSL, etc.

Asked by Terra Civis 1 month ago

Last reply by cor-el 1 month ago

Cannot upload photos / videos to Facebook anymore.

For some reason I can no longer upload any photos or videos to Facebook, via messenger or direct to a page / groups. I used to be able to do this previously as I was a us… (read more)

For some reason I can no longer upload any photos or videos to Facebook, via messenger or direct to a page / groups. I used to be able to do this previously as I was a user of the marketplace. My system is a modern build gaming PC running Windows 11 and using proprietrry antivirus software. I have tried mozilla troubleshooting mode, resetting firefox, removing addons, removing or halting any add block software and much more. I am at the end of my tether and will consider leaving the browser after over a decade as it is causing me issues with the groups I frequent as I cannot find a work around. It also replicates the same when I am on my android device and operating via the browers on their which is of course synced to the PC.

Many thanks and I look forward to a response that may help.

Asked by John Ritson 2 months ago

Last reply by hmza21257 1 month ago

Losing faith in mozilla updates breaking the functionality of adblockers and other plugins

You can't roll out an update when Basos is on an all out ad war with adblocker and make non-backwards incompatible changes. this is ridiculous. I have lost all faith in… (read more)

You can't roll out an update when Basos is on an all out ad war with adblocker and make non-backwards incompatible changes. this is ridiculous.

I have lost all faith in updating the browser and will continue to stay on my current version since it took me a considerable amount of time to get my adblockers working again.

Asked by Dennis Merrell 1 month ago

Last reply by cor-el 1 month ago

It appears I have "Silk Privacy Pass" in firefox and I never put it there - I can't remove it

I've discovered it has something to do with Amazon. I didn't know I had it until I just migrated to Windows 10 and a new firefox update occurred. Even then, my only cl… (read more)

I've discovered it has something to do with Amazon.

I didn't know I had it until I just migrated to Windows 10 and a new firefox update occurred.

Even then, my only clue is a little orange "triangle" that shows up at the top line of the 'hamburger' menu at the top right on the screen. When I clicked on it, I got a message saying "Silk Privacy Pass wants to update".

I went to my installed extensions/themes screen and there is nothing about a silk extension or add-on.

It also showed up when I looked in the startup configuration and it showed it was loading during startup there. I disabled it. But today I just got the orange triangle again an hour ago wanting me to let it update.

I want it gone!! Especially when it showed up on my system without my asking or knowingly agreeing to it.


FWIW, I also ran Agent Ransack (search utility) on the drives and "Silk" does not come up as a file name for an app, DLL or any other file.

Asked by Owen McDonald 1 month ago

Last reply by jscher2000 - Support Volunteer 1 month ago

Videos Not Playing Since Update Firefox Release 122.0.1

Since the new update for some reason, videos on some websites are no longer loading as they used to. The big sites like YouTube and Netflix are fine though others are giv… (read more)

Since the new update for some reason, videos on some websites are no longer loading as they used to. The big sites like YouTube and Netflix are fine though others are giving error codes.

(Error Code: 102630) is a common one, even after going through the guides online to get it working nothing works.

The other thing I've noticed is: Error code: SSL_ERROR_RX_RECORD_TOO_LONG This also comes up on some web players. Same again, nothing works trying to fix it.

Something changed during update 122.0.1 ?? Any Help or Ideas would be great. :)

Asked by Fox1001 1 month ago

Last reply by cor-el 1 month ago

Why do changing ads on Washington Post keep freezing my computer screen (Macs 12.7.2)? I don't have an ad blocker installed.

I thought I could turn off my ad blocker just for the Washington Post, but I discovered upon searching that I don't have an ad blocker installed. So why does the page fre… (read more)

I thought I could turn off my ad blocker just for the Washington Post, but I discovered upon searching that I don't have an ad blocker installed. So why does the page freeze up when the ad at the side of my screen changes? This doesn't seem to happen on any of the other sites I use.

Asked by mmartha61 1 month ago

Last reply by zeroknight 1 month ago

How to debug FF startup, not using the profiler? After reboot, FF always takes 14 minutes to start the first time.

I run the latest Firefox (v122.0.1) on Windows 11. Since last week, FF takes 14 minutes to start the first time after a boot. :-( Usually FF starts in ~3 seconds. … (read more)

I run the latest Firefox (v122.0.1) on Windows 11.

Since last week, FF takes 14 minutes to start the first time after a boot. :-( Usually FF starts in ~3 seconds.

I reboot the laptop. I wait a minute. I start FF. Nothing happens for 14 minutes. Finally the browser window suddenly appear and everything is working normally. I exit FF (no remaining firefox.exe processes are running). I start FF again. Now it starts immediately as usual. :-) But: I reboot and start FF. Again, it takes 14 minutes to start. This is reproduceable every time.

I haven't tried to *solve* this by refreshing FF or simillar. Right now I'm more interested in debugging this and finding out what is wrong.

I found https://profiler.firefox.com/docs/#/./guide-startup-shutdown which states how to automatically start the profiler at startup.

12:40 I boot the computer, login and wait a minute. 12:43 I start CMD.EXE and run:

 cd c:\Program Files\Mozilla Firefox
 set MOZ_PROFILER_STARTUP=1
 set MOZ_PROFILER_STARTUP_ENTRIES=20000000
 set MOZ_PROFILER_STARTUP_INTERVAL=100

12:44 I run:

 firefox.exe

No GUI appear. (it won't appear until 14 minutes later) I open the Task Manager and see one (1) firefox.exe process, taking 0% cpu. (pid 17668) 12:48 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:50 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:52 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:54 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:56 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:58 The browser GUI finally appear. Everything is now normal. It is showing one (1) tab with my start-page (google) just as it should. (my Task Manager now show 12 FF processes running, with various options) 12:59 I click the icon to stop the profiling.

I open the profile. [Profile Info] says:

 Recording started: Sat 17 Feb 2024 12:58
 Recording length: 1m12s 

So my profiling data don't show what happens between 12:44 to 12:58 :-(

Just for the sake of it, I'm attaching a pic of the first 10 seconds of the profile (at 12:58).

PS: Between 12:44 and 12:58 no FF window exists at all. Alt+Tab show no FF and in Task Manager I can't do any "Window" management, it is greyed out. I.e. no FF window exists for this process.

Question 1) What should I do to debug what happens between 12:44 and 12:58?

Question 2) How can it be that it takes 14 minutes to start FF from scratch (boot) while it starts quickly (~3 seconds) if it has been started once? I mean, all firefox.exe processes are gone when I exit FF, so starting FF again should be like starting from scratch, but apparently something is different.

Question 3) Is it normal that a FF, with only one tab (https://google.com/), run 12 processes in Task Manager?

Asked by elofu17 1 month ago

Last reply by zeroknight 1 month ago

Backup

Last time I tried backing up my bookmarks, they were saved in a file that was basically a list, a list that can't be imported back to Firefox bookmarks, but just a list. … (read more)

Last time I tried backing up my bookmarks, they were saved in a file that was basically a list, a list that can't be imported back to Firefox bookmarks, but just a list. I would like to know if there's a way to actually export and import bookmarks with one click, rather than me having to add 200 pages from the list manually. When I tried importing the file, the list ended up somewhere random and not where bookmarks are

Asked by Devin M V 1 month ago

Last reply by jscher2000 - Support Volunteer 1 month ago

Web browser bug

Very often, recently, I can't communicate with an organization via their form on the WWW internet. After minutes of frustration, I change to a Chrome or Safari browser o… (read more)

Very often, recently, I can't communicate with an organization via their form on the WWW internet. After minutes of frustration, I change to a Chrome or Safari browser on my Mac, and it works just fine.

One of the problems is when filling out a form, Firefox says over and over there is an error. Safari takes that same data just fine, no error.

There are others, but I'll have to wait until Firefox fails again since it's not that easy to reproduce what happened days or weeks ago!

Asked by forrest1 1 month ago

Last reply by cor-el 1 month ago

Outlook automatically links to Microsoft Edge

Firefox is my default browser. Up until a few months ago, if I clicked a link in an Outlook email, it took me to Firefox and opened the site. Now it takes me to Microso… (read more)

Firefox is my default browser. Up until a few months ago, if I clicked a link in an Outlook email, it took me to Firefox and opened the site. Now it takes me to Microsoft Edge.

At the same time, another problem arose, albeit minor. When I am using Firefox and attempt to email a link, there is a message, "Navigation failed" and a blank screen appears. This is not a big problem, since when I open Outlook the email is waiting to be sent. But this too smacks of something Microsoft is doing to sabotage the competition. Thanks, Bob Katz Bob@VRA-Rehab.ca

Asked by BobKatz 1 month ago

Last reply by cor-el 1 month ago

Kaspersky flagging firefox

Hi dear Community! As of recent, my AntiVirus software is flagging Firefox.exe (Full path: C:\Program Files\Mozilla Firefox\firefox.exe) as a vulnerable application. I h… (read more)

Hi dear Community!

As of recent, my AntiVirus software is flagging Firefox.exe (Full path: C:\Program Files\Mozilla Firefox\firefox.exe) as a vulnerable application. I have been using firefox for years (Because I love it, you guys are heroes) and i have been using Kaspersky for years. Firefox has only been flagged as of recent.........

I hope someone knows why, has this too or can calm my paranoia

Some Additional information:

Have you clicked any suspicious links? No i have not. The links i have visited were all https, checked and acknowledged by Kaspersky and i can say with full certainty that the sites were legit

Have i downloaded any files as of recent? Yes, but from reputable sources and always checked using Hashes and validating using KSN (Kaspersky security network).

(For the Mods, im sorry for previously posting this in the wrong forum.)

Asked by averticalhorizontal 1 month ago

Last reply by jonzn4SUSE 1 month ago