How to recover tabs lost when FF 100.0.2 crashed?

Hello, When FF on my Windows 10 machine crashed FF asked if I wanted to refresh FF. I said yes, and FF reopened as usual with all my tabs. After I closed and reopened F… (read more)

Hello,

When FF on my Windows 10 machine crashed FF asked if I wanted to refresh FF. I said yes, and FF reopened as usual with all my tabs. After I closed and reopened FF the next time, it reopened without any of my tabs. I then discovered that FF had unchecked the “Startup Open previous windows and tabs” box, which I had previously religiously monitored to be sure it was checked. So I lost all my previous tabs.

In my sessionstore-backups folder I found the file upgrade.jsonlz4-20 as last in a list of three more recent file names. I then dropped the file upgrade.jsonlz4-20 in the scrounger tool on this site: https://www.jeffersonscher.com/ffu/scrounger.html. It expanded in the big window, and when I clicked on Save uncompressed JSON as text, I see all the URLs run together in a text file.

How can I use this information to recover my tabs, please? If so, how? Or is there a better way to use the Scrounger – or another – tool?

Otherwise if I delete the three more recent file names in the list above the upgrade.jsonlz4-20 file, and restart FF will I recover the missing tabs? If so would I the check or uncheck the Startup Open previous windows and tabs box?

Lastly, can I restore my missing tabs using Windows’ “System restore” tool from 3 days before the crash?

Many thanks for any help!

Asked by Rasika Michael 2 days ago

Last reply by Rasika Michael 43 minutes ago

Lost access to primary email, but can access secondary email - Firefox Login

MY ORIGINAL ACCOUNT EMAIL IS NO LONGER AVAILABLE. WHEN I TRY TO LOG IN ON A NEW COMPUTER FIREFOX SENDS A CODE TO AN EMAIL ADDRESS THAT I CAN NOT ACCESS. HOW DO I GET THE … (read more)

MY ORIGINAL ACCOUNT EMAIL IS NO LONGER AVAILABLE. WHEN I TRY TO LOG IN ON A NEW COMPUTER FIREFOX SENDS A CODE TO AN EMAIL ADDRESS THAT I CAN NOT ACCESS. HOW DO I GET THE CODE SENT TO MY SECONDARY EMAIL?

Asked by psalm241 1 hour ago

AP watchdog expired

Error Message: AP watchdog expired. Received it twice. What does this mean. Computer makes a fizz sound. Error Message: AP watchdog expired. Received it twice. What doe… (read more)

Error Message: AP watchdog expired. Received it twice. What does this mean. Computer makes a fizz sound.



Error Message: AP watchdog expired. Received it twice. What does this mean. Computer makes a fizz sound.

Asked by sthurgood 2 hours ago

Account Auth. 6 Digit Code

I recently downloaded firefox on my new computer, and want to login on my account. I am supposed to get this 5 min auth code (that is actually 20 min according to some so… (read more)

I recently downloaded firefox on my new computer, and want to login on my account. I am supposed to get this 5 min auth code (that is actually 20 min according to some sources) on email. Funny thing is I am getting this email one hour or so later. I have added firefox as a contact and done everything in my might to get my mail services to run faster, however I am still getting my 6 digit code way to slow. I've been doing this for a day now, is there another option?

Asked by Waddle 1 day ago

Last reply by Waddle 2 hours ago

Videos won't play.

Random videos will not load following 100.0.2 install. These symptoms started @ May 21. (See attached file "Recently installed") This problem is 100% reproducible at: htt… (read more)

Random videos will not load following 100.0.2 install.

These symptoms started @ May 21. (See attached file "Recently installed")

This problem is 100% reproducible at: https://www.reddit.com/r/CatastrophicFailure/

Lenovo Thinkpad x140e Windows 7 (all updates installed) Mozilla 100.2.8174

Scrolling down the Reddit page, videos will auto-play when exposed, and stop when scrolled past.

A video not loading/playing will occur on different posts/videos, but will ALWAYS occur. Once this occurs some previously exposed / played videos, when scrolling up, will play when exposed again, and some will not.

This will also randomly occur on Youtube (also observed on Twitter a few times) when multiple tabs are open. Sometimes closing other open tabs corrects the problem. Other times closing Firefox and relaunching is required and is 100% effective.

I have additional diag data / Inspector log files and page source if needed.

Thank you in advance for your help and consideration. - LudditePro

Asked by LudditePro 17 hours ago

Last reply by LudditePro 3 hours ago

Secure Connection Failed

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I… (read more)

Hello. On some of my sites that i try to get onto with Firefox its says performing TLS handshake then it goes to Secure Connection Failed and says PR_End_Of_File_Error. I am totally updated with Firefox, plus i cleared out everything in my history. That did not help. When i tried to get onto these websites with Chrome web browser i do not have this problem at all. Why is this? I have BitDefender Total Security newest version for home. My firewall is through them along with virus protections. So can you help me out with this ongoing problem getting on some websites?

Thanks Firefox raftman111@yahoo.com

Asked by raftman111 2 hours ago

Possible IPC memory leak - how to pinpoint the culprit?

Hey there, I'm having trouble with Firefox. Something inside Firefox is eating up my RAM and CPU. Usually I recognize the problem happening because my laptop fans ramp up… (read more)

Hey there, I'm having trouble with Firefox. Something inside Firefox is eating up my RAM and CPU. Usually I recognize the problem happening because my laptop fans ramp up. The problem occurs on my laptop as well on my desktop (both on latest stable Firefox[Build ID: 20220513165813] and Windows 11). The workaround is to kill the Firefox subprocess which is using most of the CPU and RAM. Then everything is back to normal for some time, until Firefox starts messing with me again.

While trying to pinpoint the problem I'm stuck. I can't find a culprit other than the fact it has something to do with Firefox. Clean reinstalling did not help. The Firefox Task Manager doesn't know anything about huge amounts of RAM being taken. I searched for solutions on the net and the about:memory indicates the problem is some IPC related stuff:

 {
  "process": "Main Process (pid 12648)",
  "path": "queued-ipc-messages/content-parent(Browser, pid=9612, open channel, 0x22e4b33fc30, refcnt=38)",
  "kind": 2,
  "units": 1,
  "amount": 0,
  "description": "The number of unset IPC messages held in this ContentParent's channel.  A large value here might indicate that we're leaking messages.  Similarly, a ContentParent object for a process that's no longer running could indicate that we're leaking ContentParents."
 }

The bug reporting guidelines(https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html) are encouraging me to attach steps to reproduce and try the steps listed on https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources . But I've exhausted the steps there (Except for upgrading the PC / RAM).

Especially on the go this Firefox-RAM-Party takes quite some battery and right now while writing this Firefox has >100GB virtual RAM reserved for some IPC messages, I personally think this is too much. So I'd like to file a report, but without steps to reproduce I'm afraid the developers are going to say 'well, that's something we are not able to diagnose', because I am unable to explain how to reproduce it. It just happens from time to time.

The anonymized about:memory report: https://bin.disroot.org/?2ba01ef78154cce4#8PLVqLTd9qgaRn2QVX2P17hkbHQyrTDuVAwoykj2cBxg

I left Firefox running like this for about half an hour and at 138GB reserved RAM Windows slaughtered my Firefox. The resulting crash report: https://bin.disroot.org/?0bc57492585dde4b#5YtbWgXcbZSkWYmg2CGkVn9iiipYwfYbxUfCLhmMJh7d

Do you have a clue where I might find out who sends those IPC messages, and therefore who is responsible for this?

Asked by Sewana 1 week ago

Last reply by Sewana 3 hours ago

new 100.0.1 browser issues

I can't sing in to banking accounts with newest version of Firefox. no problem with Microsoft Edge. I keep getting this message. System Unavailable warning System is unav… (read more)

I can't sing in to banking accounts with newest version of Firefox. no problem with Microsoft Edge. I keep getting this message.

System Unavailable warning System is unavailable at this time. Please try again or contact Member Services at 315-894-9924 for assistance.

Asked by robwilloughby 1 week ago

Last reply by robwilloughby 4 hours ago

Domain labeled as Ad Network (it is not!)

Hello, a domain is labeled as ad network by Firefox, and causes content from it to not be loadable cross-origin. The domain was an ad network in the past but is not anymo… (read more)

Hello, a domain is labeled as ad network by Firefox, and causes content from it to not be loadable cross-origin. The domain was an ad network in the past but is not anymore, and causes big issues for users. Who can we contact to remove the domain from Firefox internal list of "known trackers"?

Asked by ph20 5 hours ago

I lose the connection with google (gmail, drive, translator)

When I open gmail in Firefox browser, I lose the connection very often, it also happens with google drive. But it does not happen to me if I use Outlook from the web, I o… (read more)

When I open gmail in Firefox browser, I lose the connection very often, it also happens with google drive. But it does not happen to me if I use Outlook from the web, I only lose the connection with Google from Firefox.

However, if I open the same thing using Google Chrome, this does not happen, it works correctly throughout the day, and I do not lose the connection.

My version of Firefox is 100.0.2 (64-bit) on my notebook I have Windows 10 Pro installed.

Asked by elserhumano 6 hours ago

WIll not search

I moved my old hard drive to a new ssd. Everything works but Firefox . I uninstalled and reinstalled when i try to use it I put in a search term hit enter and nothing ha… (read more)

I moved my old hard drive to a new ssd. Everything works but Firefox . I uninstalled and reinstalled when i try to use it I put in a search term hit enter and nothing happens. Also the drop down on right side nothing can be used

When I did the reinstall a error message came up about The code execution can not be found because VCRUNTIME 140-1 was not found reinstall Firefox again I did that did help

Thank you in advance

Asked by stbr51 6 hours ago

Awful bookmark spacing

I managed to restore the single-spacing for bookmarks, kept a prior version of FF, and fought off nags to update every time I opened FF . . . until now when I was tricked… (read more)

I managed to restore the single-spacing for bookmarks, kept a prior version of FF, and fought off nags to update every time I opened FF . . . until now when I was tricked into "allowing this app to make updates to your PC". It wasn't the usual nag button and I thought it was some kind of simple bug fix, but no, I was "upgraded" to v. 100.0.2 and my bookmark spacing fix was overwritten. Furious isn't strong enough to describe my reaction. All this time, and all the other complaints, yet I find no way to decrease the excessive spacing between bookmarks. I understand that this design may be better for those who use a finger on their screens, but what about us mouse-pointer users? Why are we so disrespected? What can I do to decrease the space between bookmarks?

Asked by StandingO 7 hours ago

Desktop URLs not working today, Firefox as default browser -- but work if default browser toggled to Edge

Hi folks, I've asked this same question of Microsoft, as I cannot tell if this is a quirk in Firefox 100.0.2, or in Windows 10 Home, or something to do with what they put… (read more)

Hi folks,

I've asked this same question of Microsoft, as I cannot tell if this is a quirk in Firefox 100.0.2, or in Windows 10 Home, or something to do with what they put in the water here (besides flouride)...

Over the last few days I've had to reinstall Office on this Windows 10 Home system, and had a Firefox update to 100.0.2 as well. Everything working fine up through last night -- URL shortcuts on the desktop would open Firefox (default browser) just fine.

Shut down. Cold boot this morning. Manually open Firefox as usual. Double-click on desktop URL shortcuts (or right-click, Open) gets a real quick hourglass and then nothing. No error, no browser tab.

So I checked: default browser still set to Firefox; .URL filetype still set to "Internet Browser."

I toggled the default browser to Edge, and the links work just fine. Same links. No changes to them.

Toggle it back to the much more privacy-protecting Firefox and... they won't work.

This seems spooky.

Note that the desktop icons for these shortcuts correctly show either the Firefox icon, or the logo/icon for the web page itself (ie, Google Maps). And the toggle of default browser did NOT update the icons.

Any ideas?

Thanks!

Asked by notonyourtintype 8 hours ago

How to unblock VTT files not being loaded into HTML video pages viewed on local disk?

I asked this question some time back here: https://support.mozilla.org/en-US/questions/1362859 I'm asking again to reframe the question. The problem is - if my experience… (read more)

I asked this question some time back here: https://support.mozilla.org/en-US/questions/1362859 I'm asking again to reframe the question. The problem is - if my experience is a guide to the rest of the world - VTT files (which are used to caption HTML video) are no longer read/loaded by Firefox when it is viewing the HTML file locally (i.e. file://). On the web they are loaded as expected. Presumably there's a security setting somewhere in Firefox that now refuses to load the VTTs locally. Maybe under Help > More troubleshooting information there is a setting to change to fix that?

Asked by roberto32 1 day ago

Last reply by roberto32 10 hours ago

Firefox does not display Facebook feed

There are a number of old threads regarding this and having worked through them it is still unresolved. 1) I have cleared cache/cookies 2) I have disabled all extensions … (read more)

There are a number of old threads regarding this and having worked through them it is still unresolved. 1) I have cleared cache/cookies 2) I have disabled all extensions 3) I have turned off tracking 4) I have tried in safe mode - still the same.

This is not just on one website - it is on ALL that have Facebook feeds. It is NOT just on my laptop - I have asked others to try - they have the same result - blank page. ...so please don't suggest re-installing Firefox!!

An example is: https://dragonsdensoftplay.co.uk/News-Events/news-events.html

The feed works ok in other browsers.

Thank you

Asked by gprit1 3 days ago

Last reply by gprit1 8 hours ago

Tab name for PDF document = Filename

How do you make sure the tab name is the same as the filename in Firefox? It actually is some other property of the PDF document such as Title, which is metadata inside t… (read more)

How do you make sure the tab name is the same as the filename in Firefox?

It actually is some other property of the PDF document such as Title, which is metadata inside the file.

Asked by moz_spt 10 hours ago