Showing questions tagged: Show all questions
  • Archived

How can an addon with no ID be sideloaded?

We are trying to deploy Firefox to many computers on a network. We require several addons be installed as part of this automated rollout. We are following the method in t… (read more)

We are trying to deploy Firefox to many computers on a network. We require several addons be installed as part of this automated rollout. We are following the method in this article: https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/Distribution_options/Sideloading_add-ons Under the "Installation using the standard extension folders" heading.

For one of our required addons, though, the manifest.json file inside the xpi archive does not contain an applications/gecko/id section. Is there a way to retrieve the ID some other way, or is there any other way to distribute the xpi and have Firefox install it for all users?

The target systems are running Redhat 7.6 Server if that is relevant.

Asked by tjetson 1 year ago

Last reply by cor-el 1 year ago

  • Archived

There is a rectangle outline box at the bottom of my webpages

When I create webpages in Nvu or Dreamweaver there is always a rectangle outline box at the bottom of the firefox page. How do I stop this from happening? There is no pro… (read more)

When I create webpages in Nvu or Dreamweaver there is always a rectangle outline box at the bottom of the firefox page. How do I stop this from happening? There is no problem in Chrome of IE

Asked by TomWooly 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

We have a wordpress page with the tableau graphs tool and it loads properly on both chrome and edge, but we get an error message in firefox anyone know why?

We built a WordPress page with various graphs to display data using the Tableau app, it works great on Chrome and Edge but when we went to test it on Firefox we got an er… (read more)

We built a WordPress page with various graphs to display data using the Tableau app, it works great on Chrome and Edge but when we went to test it on Firefox we got an error message and the graphs won't display. Any idea why or how we can fix it?

Webpage (graphs are in the toggles): https://www.somervision2040.com/somervision-numbers/ Error message: http://www.somervision2040.com/wp-content/uploads/sites/3/2018/11/error.png

Asked by vnasci 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

remove a redirection when typing www. in the search bar

When I write my website in the search bar : "www.performanceoutsidethebox.com". It goes directly to another url that is my Wordpress Admin. It happens only on Mozilla br… (read more)

When I write my website in the search bar : "www.performanceoutsidethebox.com". It goes directly to another url that is my Wordpress Admin. It happens only on Mozilla browser. I need to remove this direction that is not correct. I want to be and stay in my website when I type it in the search bar.

Thanks for your help, DelphineC

Asked by DelphineC 1 year ago

Last reply by cor-el 1 year ago

  • Archived

update firefox with deepfreeze installed

I have 90 public computers that are frozen and will not keep Firefox updates once they are frozen. I can use a batch file to update Firefox. Does anyone know of a Batch f… (read more)

I have 90 public computers that are frozen and will not keep Firefox updates once they are frozen. I can use a batch file to update Firefox. Does anyone know of a Batch file i can use that will work to update Firefox. Public Computers have Windows 7 and Windows 10 installed though I am working on updating the Operating systems to Windows 10. All are 64bit versions. Thanks

Asked by BillCoffey 1 year ago

Last reply by user633449 1 year ago

  • Archived

firefox showing alter text in images when loading for a few seconds but not by other browsers

Im a developer when loading a web page firefox first load the alter text and then load the images where as other browsers load the images first.I have check with couple … (read more)

Im a developer when loading a web page firefox first load the alter text and then load the images where as other browsers load the images first.I have check with couple of sites same issue is happening.Alter text appeared for around for 1sec and load the image.but for other browsers it is ok.how can i overcome this issue My internet connection is also a good one

Asked by Charith424 1 year ago

Last reply by cor-el 1 year ago

  • Archived

We are a school trying to connect with more than 8 simultaneous users using the same username and password

We are a school trying to connect with more than 8 simultaneous users, using the same username and password, when dialing user No. 9, user No. 1 wiil be removed? The pro… (read more)

We are a school trying to connect with more than 8 simultaneous users, using the same username and password, when dialing user No. 9, user No. 1 wiil be removed? The problem does not occur with "Internet Explorer or Chrome, what do I do?" Bjarne IT support, KonTiki school bjarne.irlind at kontiki-skolen dk mobil tlf: + ....

Asked by EgoBjarne 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

How to fix "The bookmarks and history system will not be functional"

On one of our machines, we get the message > The bookmarks and history system will not be functional because one of Firefox's files is in use by another application. S… (read more)

On one of our machines, we get the message

> The bookmarks and history system will not be functional because one of Firefox's files is in use by another application. Some security software can cause this problem.

According to the user, this started after we upgraded the machine to MacOS 10.14 Mojave. We already tried to

  • restart the computer
  • start Firefox in safe mode
  • reinstall Firefox
  • move places.sqlite to have Firefox create a new one
  • create a new profile
  • refresh Firefox
  • granted Firefox full disk access under "System Preferences - Security & Privacy - Privacy"

all without success. I even tried to open places.sqlite with sqlite3, but wasn't able to find any tables, despite the file being +500kb.

The integrity verification of the places database produced the following output:

Task: checkIntegrity - Unable to check places.sqlite integrity: Error: Could not open connection to /home/g001570/Library/Application Support/Firefox/Profiles/scuoog8q.default-1541591890759/places.sqlite: 2153971714

> Task: invalidateCaches - The task queue was cleared by an error in another task.

> Task: checkCoherence - The task queue was cleared by an error in another task.

> Task: expire - The task queue was cleared by an error in another task.

> Task: originFrecencyStats - The task queue was cleared by an error in another task.

> Task: vacuum - The task queue was cleared by an error in another task.

> Task: stats - The task queue was cleared by an error in another task.

> Task: _refreshUI - The task queue was cleared by an error in another task.

This error code (0x80630002) leads me to "NS_ERROR_STORAGE_IOERR". Is this a correct assumption?

I'm wondering whether there are ways to find the original error that caused Firefox to show this error message (like "could not open file xy"), or is there a debug log that can be used to get more information about this problem? What's also puzzling me is the fact that this error persists even with a new profile or a fresh install.

Any help or advice appreciated. Thanks in advance.

Asked by pvitt 1 year ago

Last reply by cor-el 1 year ago

  • Archived

default profile setting for each session

Hi i have a public computer for my employees and everyone have his own username to access windows.. firefox is my main app as i save some logins and adjust some security … (read more)

Hi i have a public computer for my employees and everyone have his own username to access windows.. firefox is my main app as i save some logins and adjust some security in it, and would like to let any new user have a default profile settings that i already adjusted like a clone when a new user created firefox create a new empty profile that i have to adjust settings + security manually is there is any way to clone the adjusted profile with each new user created?

Asked by vectorya 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Android Apk is not downloading

Hi All, We have android app that customers can download directly from WordPress website. It works perfectly fine on google chrome, but does not on Firefox, both mobile an… (read more)

Hi All, We have android app that customers can download directly from WordPress website. It works perfectly fine on google chrome, but does not on Firefox, both mobile and PC. When you are trying to download the file, the browser opens it instead and shows bunch of random text. https://pasteboard.co/HLKQzA4.png Any ideas how to fix it please?

Asked by YanaQuark 1 year ago

Last reply by TyDraniu 1 year ago

  • Archived

Web page display well on all browsers except Firefox

I created a page with few dynamic widgets. The page renders well on all browsers except Firefox. Here are the results: Win 7: IE, Chrome - fine (Firefox not fine) Win10… (read more)

I created a page with few dynamic widgets. The page renders well on all browsers except Firefox. Here are the results:

Win 7: IE, Chrome - fine (Firefox not fine)

Win10: Edge, Chrome - Fine (Firefox not fine)

iPhone: Chrome, Safari fine.

I am using jquery 2.11 and modernizr for one of those widgets.

Asked by Bobafett777 1 year ago

Last reply by Shadow110 1 year ago

  • Archived

Debug js script embedded in html page

I'm trying to debug an html page which has a <script type="text/javascript"> tag in it. This is the page: http://visjs.org/examples/timeline/basicUsage.html I press… (read more)

I'm trying to debug an html page which has a <script type="text/javascript"> tag in it.

This is the page: http://visjs.org/examples/timeline/basicUsage.html

I press F12, go to Debugger tab, sources, and I cant find the js script to put a breakpoint in it.

I tried using google chrome, there I can find it in Sources tab, under "examples/timeline/basicUsage.html", and I can set breakpoints and debug code with no problem.

Asked by opensas 1 year ago

Last reply by Pj 1 year ago

  • Archived

My site will work in all other browers but firefox.

https://www.aibonline.org/en/ You can open this link in chrome, IE and safari but not firefox. Firefox can't seem to find our security certificate but all the other bower… (read more)

https://www.aibonline.org/en/

You can open this link in chrome, IE and safari but not firefox. Firefox can't seem to find our security certificate but all the other bowers can. Is there something we're missing?

Asked by Amy9 1 year ago

Last reply by jscher2000 1 year ago

  • Archived

Icons are not displaying properly

Please see attached image. I have latest FF installed on iMac. I had ublock origin, flashblocker, adblock plus, WEBRTC disabled plugins installed. I assumed it was one o… (read more)

Please see attached image. I have latest FF installed on iMac. I had ublock origin, flashblocker, adblock plus, WEBRTC disabled plugins installed. I assumed it was one of those so I disabled ALL plugins, and icons still don't display. Any ideas?

Asked by jiffybandana 1 year ago

Last reply by cor-el 1 year ago

  • Archived

My page made with react renders too many times

I am making a page with react and when I run it locally on Firefox specifically my page renders too many times. This results in unexpected behavior that is inconsistent a… (read more)

I am making a page with react and when I run it locally on Firefox specifically my page renders too many times. This results in unexpected behavior that is inconsistent across browsers. Is there a known issue with Firefox auto-rerendering or is there something I can do on my end to prevent this?

Asked by hdenisenko 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Firefox going into crash-and-respawn loops after proxy installation

After installation of a web proxy/security agent - Cyren Web Security - at our organization, users are getting a misbehaviour of firefox. Upon opening, the message "Safe… (read more)

After installation of a web proxy/security agent - Cyren Web Security - at our organization, users are getting a misbehaviour of firefox.

Upon opening, the message "Safe Mode is a special mode of Firefox ..." appears and the buttons "Start in Safe Mode" and "Refresh Firefox" appears.

Choosing any of the above options results in the following: Firefox opens. Disappears momentarily after a few seconds. Re-opens, saying all the tabs have crashed. Disappears again momentarily after a few seconds. Re-opens, saying all the tabs have crashed. Goes on in a loop

Trying to kill the process from Task Manager. Firefox appears again, new process respawns and goes in the loop above. Operation (Task kill) must either be repeated a number of times (approx 10) or workstation restart so that firefox goes off.


We have sadly had to resort to Google Chrome in the meantime the issue is under investigation. Affected versions vary from 52 to 60.01 (latest)

I have tried to deploy Firefox ESR 52.8.0 to resolve the matter. This resolved the matter for some users. For others, issue persists on Firefox ESR as well.

PLease help.

Asked by N1T15H 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Firefox cache video

Hello everyone, We have implemented a bunch of Debian machines at work which essentially display information via Firefox. Pictures, information about random stuff, foreca… (read more)

Hello everyone,

We have implemented a bunch of Debian machines at work which essentially display information via Firefox. Pictures, information about random stuff, forecast, etc...

Some guy has developed a Web application which affords to upload pictures, videos and text message. All the videos uploaded end up in RAM. The problem is that these videos are loaded in memory each and every time they are displayed.

Have you guys ever noticed that behavior? Do you think the problem lies in applicative end (web development) or can I set it right from Firefox config?

Thank you all.

Asked by Charlypop 1 year ago

Last reply by Shadow110 1 year ago

  • Archived

Method of detecting add-ons that are installed

I am working on a project to be able to parse all extensions installed on a computer for each user profile on the computer. I have researched what I can, and haven't rea… (read more)

I am working on a project to be able to parse all extensions installed on a computer for each user profile on the computer. I have researched what I can, and haven't really found a good method of doing so. I was hoping that you may be able to assist me with a PowerShell (or the like) script that can be run which would output that type of information?

Thanks!

Asked by bpthomps 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Missing chars on fast typing into text fileds

Hi, My name is Yaniv and I'm the CPO of Click2Speak. We are developing an on-screen keyboard software which enables people with motor disabilities to communicate and to … (read more)

Hi,

My name is Yaniv and I'm the CPO of Click2Speak. We are developing an on-screen keyboard software which enables people with motor disabilities to communicate and to have full access to Windows-based PCs and Tablets. Our website: https://www.click2speak.net/

Since Quantum update, our users can't use our integrated prediction engine on Firefox. It seems that FF input fields can't handle well our typing speed, so it causes skipping of some chars and the user gets incomplete words.

Please try to write an email on Gmail or type a status update on Facebook using our prediction engine.

As I mentioned, the bug occurs only on Quantum versions. In prior versions and in other browsers everything works fine.

Hope you can find a fix for this problem and help our users around the globe keep working Mozilla Firefox.

Thank you and looking forward to hearing from you soon. Best Regards, Yaniv Aviran

[Personal information removed by moderator. Please read Forum rules and guidelines, thanks.]

Asked by yaniva 2 years ago

Last reply by cor-el 2 years ago

  • Archived

i cant open ssl websites

hi my web site is https://azardata.net and only in waterfox and firefox i cant open my website with iran ip! and this problem in 2 latest versions, icant open most ssl we… (read more)

hi my web site is https://azardata.net and only in waterfox and firefox i cant open my website with iran ip! and this problem in 2 latest versions, icant open most ssl website and my business going down, pls help me. error massage is : Secure Connection Fail

Asked by sportcom 2 years ago

Last reply by FredMcD 2 years ago