Firefox keeps changing my url from http to https

Hello, I'm developing a web application. Yesterday I could access it with http://localhost:8000, then, I implemented https and it worked too. Today I needed to use http … (read more)

Hello,

I'm developing a web application. Yesterday I could access it with http://localhost:8000, then, I implemented https and it worked too. Today I needed to use http again for my tests, but everytime I type http://localhost:8000, Firefox changes it to https://localhost:8000.

I already tried to clear everything in the history, even the cookies, but it didn't work.

What should I do?

Also, could you fix this bug? I've found articles from 5 years ago reporting this issue, but the bug hasn't been fixed yet

Asked by Ildomar Gomes de Carvalho Junior 8 hours ago

Last reply by TyDraniu 8 hours ago

drag and drop url to bookmarks bar not working with >100% default page zoom

I was in the middle of asking this question when I fixed (worked around) the problem so I'm posting more as a informative post as there is a lot of old misdirection out t… (read more)

I was in the middle of asking this question when I fixed (worked around) the problem so I'm posting more as a informative post as there is a lot of old misdirection out there now.

I am(was) unable to drag any URLs from the URI drop down field in the main interface to my bookmarks toolbar. Nor was any drag and drop functionality working in the "Customise Firefox" screen (right click space on url bar -> Customise Toolbar).

I have now found that resetting my zoom setting in preferences to 100% restores this functionality. The problem arose when I was using 120% zoom, NOT text only.

Asked by 4t0m1c4 1 day ago

Last reply by 4t0m1c4 8 hours ago

Language in menu of FF 126.0 is mixed up

Hello, I have a problem: After an automatic update of the language packs, parts of the Firefox menu (version 126.0) are displayed in EN. Parts in DE. Seems to be related… (read more)

Hello, I have a problem: After an automatic update of the language packs, parts of the Firefox menu (version 126.0) are displayed in EN. Parts in DE. Seems to be related to the update... how can I change this again? I have already changed the language settings. Didn't help...it appeared after an automatic update on May 28. Thanks for an idea :)

Asked by fibroblast 1 day ago

Last reply by Paul 8 hours ago

Translation does not work

I have installed the German language extension. I can go to a site written in German and it translates fine. THE SECOND I USE ANY SUB MENU WITHIN THE SITE, IT DOES NOT TR… (read more)

I have installed the German language extension. I can go to a site written in German and it translates fine. THE SECOND I USE ANY SUB MENU WITHIN THE SITE, IT DOES NOT TRANSLATE. Right clicking and choosing "Translate" does not work since "translate" does not exist on the tab.

The Firefox translate feature only works on the initial screen!

I can find no setting to fix this

Asked by ronaldchampagne49 5 days ago

Last reply by Paul 9 hours ago

Language Pack didn't apply properly

After applied Chinese Language Pack, the menu didn't change ,even after restart firefox or the system. I tried refresh firefox and re-install the language pack, the same … (read more)

After applied Chinese Language Pack, the menu didn't change ,even after restart firefox or the system. I tried refresh firefox and re-install the language pack, the same situation appeared.

Asked by Copyerder 15 hours ago

Last reply by Paul 9 hours ago

Establishing a WebRTC connection from the Firefox browser (VP8 inactive)

Hello, maybe someone else seen the same issue. When trying to establish a webrtc connection with the Firefox browser, my server sends a following message (video H264): ``… (read more)

Hello, maybe someone else seen the same issue. When trying to establish a webrtc connection with the Firefox browser, my server sends a following message (video H264): ``` 0:00:01.701967159 90 0x7fc2a0002030 LOG webrtcsrc-signaller net/webrtc/src/signaller/imp.rs:172:gstrswebrtc::signaller::imp::Signaller::connect::{{closure}}::{{closure}}: Sending websocket message Peer(PeerMessage { session_id: "56a17f8d-2585-4d4b-9f2e-3009450a19e9", peer_message: Sdp(Offer { sdp: "v=0\r\no=- 9144757257615355393 0 IN IP4 0.0.0.0\r\ns=-\r\nt=0 0\r\na=ice-options:trickle\r\na=group:BUNDLE video0 audio1 application2\r\nm=video 9 UDP/TLS/RTP/SAVPF 96 98 99 100 101\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=rtcp-mux\r\na=rtcp-rsize\r\na=sendonly\r\na=rtpmap:96 H264/90000\r\na=rtcp-fb:96 nack\r\na=rtcp-fb:96 nack pli\r\na=rtcp-fb:96 ccm fir\r\na=rtcp-fb:96 transport-cc\r\na=fmtp:96 packetization-mode=1;profile-level-id=42001f;level-asymmetry-allowed=1\r\na=rtpmap:98 red/90000\r\na=rtpmap:99 ulpfec/90000\r\na=rtpmap:100 rtx/90000\r\na=fmtp:100 apt=96\r\na=rtpmap:101 rtx/90000\r\na=fmtp:101 apt=98\r\na=ssrc-group:FID 2834502081 1415006916\r\na=ssrc:2834502081 msid:user1488703113@host-437c139 webrtctransceiver0\r\na=ssrc:2834502081 cname:user1488703113@host-437c139\r\na=ssrc:1415006916 msid:user1488703113@host-437c139 webrtctransceiver0\r\na=ssrc:1415006916 cname:user1488703113@host-437c139\r\na=mid:video0\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\na=rtcp-mux-only\r\nm=audio 0 UDP/TLS/RTP/SAVPF 97\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=bundle-only\r\na=rtcp-mux\r\na=rtcp-rsize\r\na=sendonly\r\na=rtpmap:97 OPUS/48000/2\r\na=rtcp-fb:97 transport-cc\r\na=fmtp:97 sprop-stereo=1;sprop-maxcapturerate=48000\r\na=ssrc:1127273264 msid:user1488703113@host-437c139 webrtctransceiver1\r\na=ssrc:1127273264 cname:user1488703113@host-437c139\r\na=mid:audio1\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\na=rtcp-mux-only\r\nm=application 0 UDP/DTLS/SCTP webrtc-datachannel\r\nc=IN IP4 0.0.0.0\r\na=setup:actpass\r\na=ice-ufrag:uOJFtPAyRCKX4NDQcU3VExzLsFcfCWYc\r\na=ice-pwd:jRots1p0FnmxmwLoVqAq7lK84rAwBk/4\r\na=bundle-only\r\na=mid:application2\r\na=sctp-port:5000\r\na=fingerprint:sha-256 9E:33:DF:EB:63:72:42:77:49:8D:0C:0E:FC:61:51:C1:56:53:AF:05:D9:F7:61:8F:95:DD:7D:FF:99:1A:64:E8\r\n" }) }) ``` and Firefox responds with VP8 inactive message: ``` 0:00:02.007638187 90 0x7fc2a0002030 TRACE webrtcsrc-signaller net/webrtc/src/signaller/imp.rs:324:gstrswebrtc::signaller::imp::Signaller::handle_message:<GstWebRTCSignaller@0x563ce91ed190> Received message {"type": "peer", "sessionId": "56a17f8d-2585-4d4b-9f2e-3009450a19e9", "sdp": {"type": "answer", "sdp": "v=0\r\no=mozilla...THIS_IS_SDPARTA-99.0 2114996636650547664 0 IN IP4 0.0.0.0\r\ns=-\r\nt=0 0\r\na=sendrecv\r\na=fingerprint:sha-256 16:EC:66:ED:36:A1:D4:E0:CB:95:24:4A:E2:40:CA:53:E5:AB:D5:FF:F5:9C:5C:81:EB:83:F8:E4:BD:89:9F:03\r\na=ice-options:trickle\r\na=msid-semantic:WMS *\r\nm=video 0 UDP/TLS/RTP/SAVPF 120\r\nc=IN IP4 0.0.0.0\r\na=inactive\r\na=mid:video0\r\na=rtpmap:120 VP8/90000\r\nm=audio 9 UDP/TLS/RTP/SAVPF 97\r\nc=IN IP4 0.0.0.0\r\na=recvonly\r\na=fmtp:97 maxplaybackrate=48000;stereo=1;useinbandfec=1\r\na=ice-pwd:d5a493a07b92e452116a851e083e1c78\r\na=ice-ufrag:721f69a3\r\na=mid:audio1\r\na=rtcp-mux\r\na=rtpmap:97 opus/48000/2\r\na=setup:active\r\na=ssrc:3561002322 cname:{bb14ec44-0966-49c0-bccb-5e6242dd83d7}\r\nm=application 9 UDP/DTLS/SCTP webrtc-datachannel\r\nc=IN IP4 0.0.0.0\r\na=sendrecv\r\na=ice-pwd:d5a493a07b92e452116a851e083e1c78\r\na=ice-ufrag:721f69a3\r\na=mid:application2\r\na=setup:active\r\na=sctp-port:5000\r\na=max-message-size:1073741823\r\n"}} ``` which leads to: ``` 0:00:02.007849785 90 0x7fc2a0002030 WARN webrtcsink net/webrtc/src/webrtcsink/imp.rs:3238:gstrswebrtc::webrtcsink::imp::BaseWebRTCSink::handle_sdp_answer: consumer from session 56a17f8d-2585-4d4b-9f2e-3009450a19e9 refused media 0: Some("m=video 0 UDP/TLS/RTP/SAVPF 120\r\nc=IN IP4 0.0.0.0\r\na=inactive\r\na=mid:video0\r\na=rtpmap:120 VP8/90000\r\n") ``` and a connection close.

Why Firefox could respond with VP8 to the H264 request?

Asked by Robert Ayrapetyan 9 hours ago

SSL Certificate Issue on Mozilla Firefox

Hello everyone! I am having a pretty strange issue with my [website ], it shows an SSL certificate on all the other browsers, but, on Mozilla Firefox, it shows not secure… (read more)

Hello everyone! I am having a pretty strange issue with my [website ], it shows an SSL certificate on all the other browsers, but, on Mozilla Firefox, it shows not secure issue, which is quite pressing. Can anybody tell me what's wrong here?

Asked by Akash Malik 9 hours ago

browser history broken

after the download of v.126.0 i discover my history, all of it, has been deleted. in its place is a single web site, which shows up as the only web site visited across a … (read more)

after the download of v.126.0 i discover my history, all of it, has been deleted. in its place is a single web site, which shows up as the only web site visited across a time span going back months. this single web site cannot be deleted from the history. it cannot be deleted through the settings menu. no new history is created by web visits. the persisting single web site is among the sites in my tool bar, but is also a site i have not recently visited (months before this happened).

Asked by drollere 10 hours ago

  • Solved

Tab dragging stops working at random times

Sometimes drag functionality stops working. I can't grab a tab to move it to another position or to a new window. (Holding left click on the tab and moving the cursor doe… (read more)

Sometimes drag functionality stops working. I can't grab a tab to move it to another position or to a new window. (Holding left click on the tab and moving the cursor does nothing). Also, re-merging the tab with another firefox window stops working. (Dragging a tab to a firefox window from another firefox window doesn't merge them. It does nothing) I can right click on the tab and select Move to move it to a new window but dragging stops working. I have to close Firefox and start it again (sometimes twice), then dragging starts working again. This happens multiple times a day. I am on Linux Mint and the version is 126.0 (64-bit). This problematic behavior has only recently began.

Asked by tenkayr 2 days ago

Answered by TyDraniu 11 hours ago

QR Code Passkeys

I use passkey verification for a website. In other browsers, I can get a QR code to scan with my phone to login. In Firefox, I only get a popup saying Touch your security… (read more)

I use passkey verification for a website. In other browsers, I can get a QR code to scan with my phone to login. In Firefox, I only get a popup saying Touch your security key to continue with <site> (image attached). In Chromium, I have options for both (image attached). Is this possible in Firefox?

Asked by Caleb-W 11 hours ago

Can't open Firefox

I used CCleaner this morning to scan and clean up my computer. (I did it over the weekend as well and it didn't affect my Firefox). Now I can't even open Firefox. the ic… (read more)

I used CCleaner this morning to scan and clean up my computer. (I did it over the weekend as well and it didn't affect my Firefox). Now I can't even open Firefox. the icon on my windows taskbar is gone as well. I tried to uninstall and then reinstall Firefox, but that didn't work. I also tried to "refresh" Firefox (or whatever it is called that is recommended when trying to uninstall).

Please help. I really need my Firefox to work!

Thank you, Jeri

Asked by Jeri Newlin 11 hours ago

Dev toolbar not loading

For some reason the developer tool on Firefox is just completely blank when I open it. Nothing will load and I can't even close out of it. Any ideas on how to fix this? … (read more)

For some reason the developer tool on Firefox is just completely blank when I open it. Nothing will load and I can't even close out of it. Any ideas on how to fix this?

Asked by Anonymous 12 hours ago

Check spelling is enabled but won't work on FB and Instagram desktop sites

On firefox 126.0 (64-bit) the option for spelling check is enabled, but will not appear on the context menu box when right clicked. This happens for the desktop sites of … (read more)

On firefox 126.0 (64-bit) the option for spelling check is enabled, but will not appear on the context menu box when right clicked. This happens for the desktop sites of Facebook and Instagram.

Asked by ghand_aurealis 19 hours ago

Last reply by ghand_aurealis 12 hours ago

Firefox Hangs Upon Launch, Cannot Connect to any Websites (Mac Sonoma)

On Mac OS 14.4 Firefox hangs on launch and crashes, requiring "Force Quit" when I try to Refresh or Troubleshoot. Uninstalled and reinstalled multiple times, and restarte… (read more)

On Mac OS 14.4 Firefox hangs on launch and crashes, requiring "Force Quit" when I try to Refresh or Troubleshoot. Uninstalled and reinstalled multiple times, and restarted computer several times. Have spent several hours trying multiple community suggestions to now avail.

I am not a programmer, but am able to follow instructions. I clearly need someone to hold my hand and walk me through the solution. (I even checked out the Kaspersky suggestion, but cannot install it because Firefox cannot connect to the Internet.)

I have downloaded and saved "Raw Data.docx" and "Application Basics tex.docx" from one of the crash reports.

P.S. On this question form Firefox guessed that my operation system was Mac OS x 10_15_7, but it is 14.4

Julian

Asked by julian.donahue 2 months ago

Last reply by julian.donahue 13 hours ago

OCSP error after changing security.ocsp settings

We are receiving the following error when we change the security.OCSP.enabled to "1" and security.OCSP.require to "true": (Invalid OCSP signing certificate in OCSP respo… (read more)

We are receiving the following error when we change the security.OCSP.enabled to "1" and security.OCSP.require to "true":

(Invalid OCSP signing certificate in OCSP response(Error code: sec_error_ocsp_invalid_signing_cert)

We are in an airgapped environment and have our own OCSP responder we are attempting to get Firefox to work with. What configuration does Firefox need in order to solve this error?

Asked by joshua.j.tyler 13 hours ago

Cannot reach a website except in private browsing but...

I have been using firefox for years. My current version is 126.0.1 (64 bit). Within the last couple of months(?) I am unable to reach a website that I use on a semi-regu… (read more)

I have been using firefox for years. My current version is 126.0.1 (64 bit). Within the last couple of months(?) I am unable to reach a website that I use on a semi-regular basis axisgis.com/AshbyMA The problem exists on 3 different devices, an HP laptop running win 10, an older desktop running win 10, and an older mac desktop running Catalina 10.15.7 which apple says is up to date. If I use Safari on the mac the website works perfectly. If I use private browsing on the laptop the website works perfectly. If I use private browsing on the desktop the website works perfectly. On the laptop I ran the firefox in troubleshoot mode and the website still would not work. I cleared the cache on the laptop and the website still won't work. Since the problem occurs on 3 different devices that are not synced to each other I can't believe it is a cookie problem. Rebooting devices makes no difference. I rebooted the Comcast modem and the house router, no change.

Any ideas would be welcome.

Thanks, mike

Asked by mike745 13 hours ago

Major issues using some sites

Hi there, Can anyone help me please. Ive been using Firefox forever and yesterday I signed into a Gmail account to send an email to someone, I typed in who it was to, the… (read more)

Hi there, Can anyone help me please. Ive been using Firefox forever and yesterday I signed into a Gmail account to send an email to someone, I typed in who it was to, then subject and then when I went to type into the body of text, the keyboard wont work.

I thought there was an issue with the keyboard but I then I tried to type in issues on firfox and loads of text is missing, I basically cant use firefox at the moment as Im only viewing half the info.

Ive been sent a credit not from someone and this is what its viewing like.

I didnt change anything that Im aware of

Thanks and fingers crossed in anticipation. Andrea

Asked by thestudio1 4 days ago

Last reply by jscher2000 - Support Volunteer 14 hours ago

URL autocomplete - I want to start over.

I don’t understand what Firefox is doing. For example, I used to start typing the first few letters of “weather.com”, which I visit pretty much daily, and it would auto f… (read more)

I don’t understand what Firefox is doing. For example, I used to start typing the first few letters of “weather.com”, which I visit pretty much daily, and it would auto fill “weather.com”. Now it auto fills every time with http://www.weatherbase.com/. I don’t know where that came from. Similarly, I used to type the first few letters of “duckduckgo.com” and it would bring up “duckduckgo.com”. Now it brings up a magnifying glass below the url with “Search with duckduckgo”. I am thinking it might be best if I can start over, i.e. clear out any information it’s saved about where it thinks I want to go, and start remembering the sites I am entering now.

Asked by WAYNEOO 2 weeks ago

Last reply by jscher2000 - Support Volunteer 14 hours ago

crash in xdg-mime lookup (cache_alias_lookup) when printing or saving

Here is my crash report. https://crash-stats.mozilla.org/report/index/ac6dbca9-a495-4b78-a72f-8102b0240528#tab-details Based on https://gitlab.gnome.org/GNOME/glib/-/iss… (read more)

Here is my crash report. https://crash-stats.mozilla.org/report/index/ac6dbca9-a495-4b78-a72f-8102b0240528#tab-details

Based on https://gitlab.gnome.org/GNOME/glib/-/issues/2833, I gather that this crash happens when you have some malformed xdg-mime data. I'm trying to figure out what data that is and where it's stored so I can fix it.

The crash report doesn't show me the arguments, so I can't tell what mime type it's trying to load. Maybe it's not available due to the way the library is built, or maybe it's not available due to the crash report hiding potentially private data. Or both. Can anyone tell me how to see what mime type it's looking up? Or do you know what mime type it would be looking up when saving a PDF? `xdg-mime query default application/pdf` works fine so it's not just looking for a handler, there must be some sort of weird "MIME type" for "file browser" that it's trying to use.

Asked by mleuchtenburg 14 hours ago