Showing questions tagged: Show all questions

Firefox crashes mac?

Hi, for the past week whenever I open Firefox (FF) it works normally for about two minutes, then slows, then causes my entire mac to slow and freeze. If I don't force qui… (read more)

Hi, for the past week whenever I open Firefox (FF) it works normally for about two minutes, then slows, then causes my entire mac to slow and freeze. If I don't force quit FF quickly, my mac crashes. Once I force quit FF everything is fine. I've been using Chrome for the past week or so hoping FF would fix itself with an update but no go.

Anyone else having this issues?

Asked by houseofderron 22 hours ago

Last reply by houseofderron 1 hour ago

HAD it with this platfoerm - upgraded, STILL taking FOREVER to load fully but, what's WORSE - corrupting my mouse, keyboard, USB functionality.....

FIX what seem to be CLEAR conflicts with relationship between platform and user's device (desktop, Dell Optiplex 790 in my case - that do NOT occur with Opera, otherwise)… (read more)

FIX what seem to be CLEAR conflicts with relationship between platform and user's device (desktop, Dell Optiplex 790 in my case - that do NOT occur with Opera, otherwise) as WELL as aforementioned ATROCIOUS performance quality - BTW, this is the SECOND update / upgrade I've done in LESS than a WEEK.....

Asked by ogam5 3 days ago

Last reply by ogam5 2 days ago

YouTube randomly stops loading

About a month ago, I started having a problem where all pages on YouTube randomly stop loading. It does this with no rhyme or reason and usually for around a minute at a … (read more)

About a month ago, I started having a problem where all pages on YouTube randomly stop loading. It does this with no rhyme or reason and usually for around a minute at a time. It just hangs until it abruptly starts working again. Occasionally (like if I try to log out while this is happening), it will give me an error saying I'm "offline", even though I am most definitely not offline. During this time, all other websites (Google, Wikipedia, Hulu, etc) work fine, so I know it's not my Internet. Other than that, it doesn't give me any errors.

I am using a MSI laptop on Windows 10. Oddly enough, YouTube loads properly in incognito mode and in Windows Edge, but clearing my cache and cookies, disabling my extensions, and updating Firefox to the latest version didn't solve the problem. I even enabled each of my extensions separately in incognito mode while YouTube wasn't loading in a normal window, and each time YouTube loaded properly in the private window while simultaneously not loading in the normal one, so I know none of my extensions are causing the problem. Restarting my computer also didn't do anything. This problem persists when logged in or out of YouTube, no matter the account.

I reported this issue to YouTube back on December 29, but it hasn't been fixed. I also made a post on the YouTube Community a few days ago, but I didn't get any helpful answers. Any help would be appreciated!

Asked by David_H23 1 week ago

Last reply by David_H23 4 days ago