How does omnibox addSuggest work in private mode?

I tried omnibox with the following code from MDN. When I trying, I temporarily loaded manifest.json from about:debugging. This worked in a normal browser, and typing cs a… (read more)

I tried omnibox with the following code from MDN. When I trying, I temporarily loaded manifest.json from about:debugging. This worked in a normal browser, and typing cs a show a some suggestion.

However, this suggestion feature is not working in private mode. This did not change even if I allowed it to run in a private window. How can I get the omnibox suggestion feature to work in private mode?

Asked by desertpureolive 29 minutes ago

Last reply by jscher2000 3 minutes ago

How do I recover passwords deleted in last Firefox update?

Greetings All, as a consequence of the last update of Firefox (16/1/21) I have lost all my passwords and bookmarks! I have deleted and reinstalled the program and was abl… (read more)

Greetings All, as a consequence of the last update of Firefox (16/1/21) I have lost all my passwords and bookmarks! I have deleted and reinstalled the program and was able to retrieve 6 passwords (that are more than 8 months old) the rest are missing. I have read and attempted to follow the instructions about the logins.json code without any luck. My system won't allow me to rename the file, there are as far as I can see no other corrupt versions of such a file. I have already spent fruitless hours on this. I have lost all my social media access as a consequence, lost my access to on-line learning and numerous other important access points. Can anyone help? Please! Yes, I am running AVG and something similar happened last year but on that occasion a fix from AVG solved the problem quickly. What can I do?

Asked by catmcdonald 2 hours ago

Last reply by catmcdonald 4 minutes ago

Why does print and print preview take about 30 to 60 seconds to appear?

I have tried the existing recommendations to delete item(s) beginning with print_ that had no effect. I copied prefs.js and removed all items beginning with print and rep… (read more)

I have tried the existing recommendations to delete item(s) beginning with print_ that had no effect. I copied prefs.js and removed all items beginning with print and replaced existing prefs file. Curiously that change worked at least twice before trying PDF print preview. After trying the preview the print function went back to taking 30 to 60 seconds to respond.

Print and print preview work fine in Chrome and Safari.

I have a macbook air and a new macbook pro. The macbook pro works well. I compared the config print items and found no obvious discrepancies. Both macbooks are on Firefox 84.0.2

My significant other blames Apple. I am convinced the problem lies with Firefox. Oh -- print screens are not worthwhile since we're talking a major time delay.

MikeDos

Asked by MikeDos 12 minutes ago

Videos are all played with sound at once...

I have a website I built with ruby on rails with a bunch of posts where people can post images and videos. The videos are coded with :controls => true, :loop => tru… (read more)

I have a website I built with ruby on rails with a bunch of posts where people can post images and videos. The videos are coded with :controls => true, :loop => true, :autoplay => true, muted: true, so they are playing as soon as the website is loaded on mute. The problem I have now is that when using firefox, ALL of the videos get played WITHOUT MUTE TOGETHER when the user goes to any other page. So whenever the user for example goes to the "about" page, the videos of the homepage are still playing on a loop with 100% volume and there is no way to stop it except for closing the website. This isnt really supporting for my user experience if you know what I mean.

What may also be worth mentioning is that I have a script which makes videos only play when on the user actually scrolled to their position.^

If you are interested in tinitus, you can try it out and listen to a concert of earrape videos (im not responsible for any braindamage). https://www.darkerr.co/posts This issue is not happening for Chrome, Safari or Edge. It must be something exclusively for firefox. Does anybody know how to fox this problem? Thank you so much!

Asked by wittek.vincent 3 hours ago

Last reply by jscher2000 14 minutes ago

Firefox does not update a site's Favicon in history or bookmarks after the site has changed its icon

This is a bug report, not a question. When I access a web site for the first time, Firefox (version 84.0.2 [64-bit] under Windows 10) displays that site's Favicon in Fire… (read more)

This is a bug report, not a question. When I access a web site for the first time, Firefox (version 84.0.2 [64-bit] under Windows 10) displays that site's Favicon in Firefox's search history. If the site then changes its Favicon, Firefox does not update its own copy of the site's Favicon and continues displaying the old one. I had a site like this in my search history but I had not bookmarked it. The site changed its Favicon but the icon displayed in Firefox's search history remained unchanged. I later bookmarked the site, thinking that this might inspire Firefox to update the Favicon but it did not; Firefox displays the old Favicon in its bookmarks as well.

Asked by daveziffer 8 hours ago

Last reply by jscher2000 16 minutes ago

I refreshed Firefox today at Firefoxes suggestion, and now all my bookmarks are gone. I added the bookmark toolbar to try readd my bookmarks, but nothing sticks

I refreshed Firefox today on Firefoxes recommendation and now all my bookmarks are gone. I added the bookmark toolbar to try re-add my bookmarks, but nothing sticks. Th… (read more)

I refreshed Firefox today on Firefoxes recommendation and now all my bookmarks are gone. I added the bookmark toolbar to try re-add my bookmarks, but nothing sticks. There is a sentence on the bookmark line saying it would be easier for me if I put bookmarks on the line and a link to manage bookmarks. Nothing sticks to the bookmark toolbar and nothing happens when I click the link. Other than switching to a new browser, which I am now seriously considering, how can I fix this? It took me a long time to get many of the important bookmarks in the folder

Asked by kendp 46 minutes ago

Last reply by FredMcD 27 minutes ago

  • Solved

Videos playing slow

Hello! On a certain adult website, all the videos play verrrry slooooly. YouTube videos play fine. And this certain site works fine when I try it with Chrome. I recently … (read more)

Hello! On a certain adult website, all the videos play verrrry slooooly. YouTube videos play fine. And this certain site works fine when I try it with Chrome. I recently added a bunch of adblockers like Ghostery and Adblocker plus and Badger and Decentraleyes and HTPPS Everywhere. Is the problem with one of these? What can I do to get the videos to play at full speed?

Thanks in advance!

John

Asked by yohejohn 10 hours ago

Answered by FredMcD 8 hours ago

I have a big problem, I seem to have lost my emails. I am having 'stroke' memory loss....a little confused....I tried everything I know, (courtesy of you beautiful peeps out there....Help, it's really big mess this time...

Not sure this time.......you guys have helped me before, (thanks heaps...BTW) luckily I did my Banking before it crashed! groan.....my guy has no idea...('cos he's dyslex… (read more)

Not sure this time.......you guys have helped me before, (thanks heaps...BTW) luckily I did my Banking before it crashed! groan.....my guy has no idea...('cos he's dyslexic) ... years ago he did a course, then left it up to me! It's to do with the fact that I didn't understand how to create/data into emails & such in the first place properly...now it's a big mess, plus for the life of me I couldn't remember how to fix up my emails, plus I had that problem of the long string of data that I have 'nursed' & that has now totally disappeared! Not very easy to explain, sorry! I had about 5 years worth, Hmmmmm... But I can't explain where my emails have gone! I do still have a few listed 'bookmarks' in alphabetical order but I don't know how to restore them, (she said hopefully)! I still cannot find out where the emails 'live'.....they seem to have located themselves into a new format! (Oh yeah, about 9 months ago I figured out how to insert a 'NEW FOLDER' ..lol... that really helped.) Sigh...this has taken me about 6 hours to sort out.....I am so very grateful, I hope this time who knows, I might get to flex my Wings!! LOL....SlimSylv.....Happy New Year to you all...Stay Safe......

Asked by SlimSylv 34 minutes ago

both lastpass and onetab icons disappeared from firefox

Sometime in the last week or so, the lastpass and onetab icons that normally reside just to the right of the URL display and to the left of the download icon and the hist… (read more)

Sometime in the last week or so, the lastpass and onetab icons that normally reside just to the right of the URL display and to the left of the download icon and the history icon in the upper right of my FF browser disappeared. I think maybe it was the result of an update, but I wasn't paying close attention, then when I did notice it, couldn't find anything on the interweb about it.

They are both still installed since if I go to the onetab on the playstore it only shows uninstall and if I restart the computer, one of my open browser windows will restart with the onetab open as a new tab. If I close the tab, there is then no evidence apparent that it is still there. I have hovered my mouse over that area but nothing shows to be there.

Any ideas? BTW, if not apparent from the above, I am not very technical. Thanks

Win 10 Home, FF browser

Asked by ff44 6 hours ago

Last reply by jscher2000 1 hour ago

Mozilla Passport

Hello guys, I was wandering if it would be a good idea for the Mozilla Foundation to create a new service: The Mozilla Passport Service, where it would store users legal … (read more)

Hello guys,

I was wandering if it would be a good idea for the Mozilla Foundation to create a new service: The Mozilla Passport Service, where it would store users legal information (in blockchain) and act as an intermediate with other services on the internet without exposing our information to those services. There have been many companies that are trying to achieve that but they lack something that the Mozilla Foundation has (to some point) and that's Trust from their customers. Also i don't see how Mozilla will survive in the future without providing future-proof services. Another thing is that in 2021 i really find it weird that there's not an easy way (off the social network) to contact Mozilla if someone has a new idea about their services (even if its stupid).

Anyways thanks for your time

Asked by superjohnv 5 hours ago

Last reply by jscher2000 1 hour ago

Firefox does not start automatically when I restart Windows

Hi everyone, I have the opposite problem to "Firefox starts automatically when I restart Windows" (https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-… (read more)

Hi everyone, I have the opposite problem to "Firefox starts automatically when I restart Windows" (https://support.mozilla.org/en-US/kb/firefox-starts-automatically-when-i-restart-window)

toolkit.winRegisterApplicationRestart is on "true"

It was working well before I had an update on Windows that crushed my connection to my printer. So I reinstalled W10. I now have version 10.0.19042, n°19042 (according to system information) and I have the last version according to windows update.

Thanks for helping me restoring firefoxe automatical update!

Asked by belmondo1 3 hours ago

Last reply by jscher2000 1 hour ago

How Do I Add Norton Safe as Search Engine Option?

Norton Safe is not an option in the drop down list of possible search engines. When my husband installed Firefox, Norton asked whether to make it the default search engin… (read more)

Norton Safe is not an option in the drop down list of possible search engines. When my husband installed Firefox, Norton asked whether to make it the default search engine, and he did. I was not given that option, and I find no way to add Norton as an option.

Asked by Andria 3 hours ago

Last reply by jscher2000 1 hour ago

  • Solved

Avg deleted firefox

I tried downloading wondershare dvd maker and avg popped up saying it wasnt trusted. I tried leaving the alert but it wouldnt let me so i tried pressing alt f4. Alt f4 di… (read more)

I tried downloading wondershare dvd maker and avg popped up saying it wasnt trusted. I tried leaving the alert but it wouldnt let me so i tried pressing alt f4. Alt f4 didnt work, so i chose deletion option. But it deleted my firefox browser. Naturally i had no idea what was happening when i tried clicking the firefox shortcut and it said the file didnt exist or had been moved or deleted. I checked my uninstall option on my computer and firefox wasnt even listed. I downloaded imyfoneanyrecover app after a quick google search but for some reason when i opened the app it couldnt go in window mode and half the page is off the screen and i dont know how to switch the app to window mode. I even tried downloading firefox again and it wouldnt install. I am really confused right now and i am afraid all my history, bookmarks, etc. Are gone forever. Is it avg or was the wondershare dvd maker a malware that did this? Please someone help me!

Asked by archaeltryke 19 hours ago

Answered by Scribe 13 hours ago

  • Solved

option to customize new bookmark gone (linux)

Suddenly, when on a new page and "bookmark this page" I do NOT (and cannot) get the menu that allows me to pick a folder and/or tag and/or rename the bookmark WHEN I save… (read more)

Suddenly, when on a new page and "bookmark this page" I do NOT (and cannot) get the menu that allows me to pick a folder and/or tag and/or rename the bookmark WHEN I save it. I now have to save the bookmark into OTHER folder and then choose EDIT bookmark.

Asked by info3517 11 hours ago

Answered by info3517 6 hours ago

Speed tests shows normal uploads on Firefox and Edge but on Firefox only downloads show 0.0

Good evening. I have run the Ookla speed test through Edge and my download is 212.94 Mbps and my upload is 11.76 Mbps and uses the Spectrum Syracuse Server. Running Spe… (read more)

Good evening. I have run the Ookla speed test through Edge and my download is 212.94 Mbps and my upload is 11.76 Mbps and uses the Spectrum Syracuse Server. Running Spectrum speed test on Edge registers Spectrum Syracuse as the optimum server and download is 236.2 and upload 11.6. Both are using my Spectrum server in Syracuse, NY.

When I run Ookla through Firefox I got 227.17 down and 11.63 up. Spectrum's speed test through Firerefox's Syracuse server 231.8 up and 11.5 down.

However for a while earler this evening when I ran both programs on both browsers and both through Syracuse's servers I was getting downs of 0.0 to 0.7. I reset the modem and router and still had low speeds but shortly after I got the readings I wrote in the first two paragraphs.

What would be the reason for this? Anything particular with Firefox? Something I should look out for in the future? Partially a curiosity while the other part being proactive.

Thanks for anybody who can take time to answer.

Asked by Figureguy 21 hours ago

Last reply by Figureguy 2 hours ago

My location

My location is Rockford, Ill. Until a few days ago, I had no problem with websites accessing my correct location. Now, I have some sites that show my location as Sacramen… (read more)

My location is Rockford, Ill. Until a few days ago, I had no problem with websites accessing my correct location. Now, I have some sites that show my location as Sacramento, Ca. !!! I'm planning some travel this summer(hopefully), so this can be a problem. I have tried clearing the cache and a few other suggestions, to no avail. Anyone have an idea what to do about this? Thanks, Mike P.

Asked by Grunt 4 hours ago

Last reply by jscher2000 3 hours ago

My only search engine in firefox is google but automaticaaly switches over to BING

I have been using Firefox for many years now and it uses Google, but for the past week or so when I have typed in my search it automatically switches it to BING search. I… (read more)

I have been using Firefox for many years now and it uses Google, but for the past week or so when I have typed in my search it automatically switches it to BING search. I have checked all my settings and programs but BING is not listed, so why the automatic change over, and how can I fix the problem?

Asked by Robin S 11 hours ago

Last reply by jscher2000 3 hours ago

vams.cdc.gov covid vaccine portal showing blank page

Hi, The vams.cdc.gov portal is just showing a blank page, the cdc site says that firefox is a browser to use and also says chrome,safari etc. I need to get on the site be… (read more)

Hi, The vams.cdc.gov portal is just showing a blank page, the cdc site says that firefox is a browser to use and also says chrome,safari etc. I need to get on the site because I have to register my mother for over 75 to get the vaccine. I have a phone modem and windows 7. Trying to download either of the other browsers is a long long long download. Anybody know the fix to getting this portal working. I noticed that it uses the Aura framework ie window.Aura By the way the page source is there, and the title bar does show VAMS Portal, just the blank page though. Thanks for helping if you can. Steve

Asked by bsteveebee 9 hours ago

Last reply by jscher2000 3 hours ago