Showing questions tagged: Show all questions

Firefox browser extremely slow, but not chrome

I've been using firefox for many years now without any trouble. But just last week, I found it takes a very long time to load even a simple web page. For example, google.… (read more)

I've been using firefox for many years now without any trouble. But just last week, I found it takes a very long time to load even a simple web page. For example, google.com takes 4-5 minutes to just show the text, and 7-8 minutes to fully load. I also use Chrome and it does not have this problem. I've already tried "refresh firefox", and uninstalled all plugins, and it is still slow. I am using Firefox version 78.0.1 (64-bit) and using Windows 10.

Asked by BluePenguin 4 hours ago

Last reply by BluePenguin 56 minutes ago

High Memory Usage Windows Audio Device Graph Isolation while using Firefox

Hi, I've encounter this problem. Whenever I play Youtube video using Firefox, my Windows Audio Device Graph Isolation tends to use high memory (sometimes up to 1.5GB). T… (read more)

Hi,

I've encounter this problem. Whenever I play Youtube video using Firefox, my Windows Audio Device Graph Isolation tends to use high memory (sometimes up to 1.5GB). This issue didn't happen to Chrome, Edge or Media Player. What went wrong? Attached are the screenshots of the memory usage by each of the browsers and media player

Asked by truxpher91 1 hour ago

restored session is missing a lot of pages - anything i can do?

hi, Firefox 77.0.1 (32-bit) in Windows 7 crashed completely and i had to taskkill /im firefox.exe /f this has happened a few times before, and up to this point Firefox co… (read more)

hi, Firefox 77.0.1 (32-bit) in Windows 7 crashed completely and i had to taskkill /im firefox.exe /f

this has happened a few times before, and up to this point Firefox could always restore the last session when reopened (maybe minus any last minute pages or any pages causing errors)

this time, the browser restored many pages, some of them are pages/tabs that i had already closed days before the crash (that i do not need) and also it didn't restore tens of tabs that i had opened afterwards (that i need) the missing tabs are not tabs that i opened right before the crash, they were open for at least one or two days in other words, the session restored is an earlier/older version and not the session i was having during/near the crash

is there something i can try to restore the correct session fully? would there be another restore file i can use? thank you for your time

Asked by teoepi2 4 hours ago

Session restore

Does anybody knows why firefox sometimes restores to a previous session, like the one atleast a couple weeks ago, instead of the one I had when I closed it for the last t… (read more)

Does anybody knows why firefox sometimes restores to a previous session, like the one atleast a couple weeks ago, instead of the one I had when I closed it for the last time? and if I can do something about it, I tried using the files from sessionstore backup but they just update to the new session

Asked by Dany 00 7 hours ago

Last reply by jscher2000 6 hours ago

Laggy Firefox

I am facing two issues with Firefox. I am using Firefox on Macbook Pro 2017 with i7 processor and 16GB Ram, but after importing all my bookmarks from chrome its laggy lik… (read more)

I am facing two issues with Firefox. I am using Firefox on Macbook Pro 2017 with i7 processor and 16GB Ram, but after importing all my bookmarks from chrome its laggy like when i move mouse hover the bookmarks its animation response time is slow ie :- Moving cursor up and down the blue animation strip its bit delay comparatively mouse cursor movement.

Secondly i am having issue with YouTube, when i am double click on YouTube video to full-screen its give blank screen for a sec its bit annoying i think it need to fix.

Asked by Iqubal Singh 1 day ago

Last reply by Iqubal Singh 7 hours ago

Firefox doesn't load Facebook

Greetings. Yesterday facebook was loading fine, now it doesn't load. The login page appears, i enter my credentials and all i get is the blue top bar and a couple of butt… (read more)

Greetings. Yesterday facebook was loading fine, now it doesn't load. The login page appears, i enter my credentials and all i get is the blue top bar and a couple of buttons that don't work. It is working fine on microsoft edge and on my laptop also running firefox. I tried running in safe mode and deleting facebook cookies, it didn't help. I used an extension to change my user agent to a mobile one and the mobile facebook page seems to load fine. User agents for other browsers don't load as well. What is going on?

Asked by Mike 7 hours ago

Last reply by Mike 7 hours ago

browser problem

When I signed on to my computer this a.m. and clicked on the Firefox icon from my Task Bar (on the bottom of the page) to bring up my homepage, it wouldn't go. I rec'd a… (read more)

When I signed on to my computer this a.m. and clicked on the Firefox icon from my Task Bar (on the bottom of the page) to bring up my homepage, it wouldn't go. I rec'd a msg stating it "couldn't find" a .dll file or something. When I clicked on the icon on my desktop, it started a whole new page - I lost all my "saved" pages and my "favorites" menu was gone! What happened and how can I get my "normal" Firefox page ?

Asked by lbgny58 9 hours ago

Scrolling and pages jumps

Firefox Version 78.0.1 Build ID 20200630195452 How do I stop pages from jumping while scrolling? Happens when scrolling on lots of websites: Youtube and yahoo for exam… (read more)

Firefox Version 78.0.1 Build ID 20200630195452

How do I stop pages from jumping while scrolling? Happens when scrolling on lots of websites: Youtube and yahoo for example.

Any help?

Asked by digitalshooter 16 hours ago

Last reply by digitalshooter 9 hours ago

firefox 78.0.1 ask privillenges to download files at c:

Why when i update to firefox 78.0.1 DOESN'T let me to download anything at c:??? The previews version 77.0.1 i can download at c: normally. Now i can't. WHY???? … (read more)

Why when i update to firefox 78.0.1 DOESN'T let me to download anything at c:???

The previews version 77.0.1 i can download at c: normally.

Now i can't.

WHY????

Asked by Gregory 2 days ago

Last reply by Gregory 9 hours ago

Firefox 76.01 on Windows 7 broke audio completely

The 76.01 update of Firefox has completely broken the audio function in my browser. Youtube and Yahoo Finance specifically. I have not checked further. Yes I know Windows… (read more)

The 76.01 update of Firefox has completely broken the audio function in my browser. Youtube and Yahoo Finance specifically. I have not checked further. Yes I know Windows 7 is not supported by Microsoft, but Firefox has claimed that it would support Windows 7 indefinitely. Yesterday when I opened Firefox a message said that audio and video might not work if I did not have DRM enabled. I checked and saw that I had DRM enabled, but audio did not work. A button in the message said Enable DRM, I clicked the button anyway. No audio. I restarted Firefox, no audio. I restarted my computer, no audio. I opened Chrome and everything is working fine. I did not even okay this update. I have my preferences set to NOT automatically update. it seems like Firefox is ignoring my preferences. Firefox should provide an instant downgrade to the previous version that supported audio. In the past I have downgraded a few times until things were working smoothly, but it's a headache. Now I understand Firefox makes it even harder to do that. I may just switch to Chrome permanently.

Asked by brtew 1 month ago

Last reply by brtew 10 hours ago

An issue with displaying images on certain sites/FF's profile folder/storage?

Hey all - been trying to troubleshoot an issue with Firefox (multiple of the latest versions, but 77 currently) on Mac OSX Catalina, appreciate any help! Issue: Certain … (read more)

Hey all - been trying to troubleshoot an issue with Firefox (multiple of the latest versions, but 77 currently) on Mac OSX Catalina, appreciate any help!

Issue: Certain websites intermittently display strange behavior, such as not loading interactive content (videos/gifs on reddit, for example, displaying as static images) and some sites not loading images at all (Twitter shows empty boxes where images would be) and a few other similar issues.

Steps I've tried: - Using a private window solves almost all the issues. But disabling all extensions and plugins in a normal window doesn't solve it. (I believe I understand private windows to use the RAM for caching but use the HDD under normal circumstances?) - Enabling/disabling VPN makes no difference, nor does what network I'm on, and other devices on this network have no similar issues - Other browsers on the same computer have no issues - Malware, anti-virus, etc all are active and scan has been run a few times. - Apple's hardware diagnostic turns up no issues, and this has happened now in FF over multiple of the latest versions (not sure when exactly it started) on two different Macbooks, though the new one is from an image of the old one (maybe that's something?) - Uninstalling/reinstalling FF does not make a difference

Where I'm at: The only thing that sort of worked (But it's now stopped working on certain sites, but continues to work for others) is moving FF's profile folder, uninstalling, and reinstalling. I was lead to believe FF would then create a new folder when this happened, but it just kicked up an error for me and wouldn't start. When I moved the old profile folder back and started up the freshly installed version with the old profile folder, the problems were all solved. Though as mentioned, they are starting to happen again on some of the sites. No errors or changes have been made that I can identify, plenty of space available on the HDD, etc.

I've become a big fan of FF over the years (over Chrome), and want to stay in a privacy-focused browser, but I haven't been able to find much that seems to help this specific situation online. Any help is appreciated!

Asked by alex144 15 hours ago

Last reply by Shashank Shekhar 12 hours ago

FirefoxCP WebExtensions stopping web pages being loaded

Hi all, In the last couple of days, Firefox has stopped loading any web pages on start-up. When I look at the activity manager on my mac, I see a FirefoxCP WebExtensions … (read more)

Hi all,

In the last couple of days, Firefox has stopped loading any web pages on start-up. When I look at the activity manager on my mac, I see a FirefoxCP WebExtensions task right at the top of the queue using 99 - 100% CPU. When I cancel this task, Firefox immediately starts loading pages as normal. There are also FirefoxCP Web Content and FirefoxCP Privileged Content tasks, but they don't seem to be causing any problems.

I'm running Firefox 78.0.1 on a mid-2012 MacBook Pro with MacOS High Sierra 10.13.6. My only extensions are Adblock Plus, Browsec VPN and Greasemonkey. My Plugins are OpenH264 Video Codec, Shockwave Flash 32.0 r0 and Widevine Content Decryption Module

Any help greatly appreciated.

Asked by mark_woronowicz 18 hours ago

Can't install FIREFOX application

Firefox stopped working on MacBook pro running OS 10.13.6. I deleted the app and tried to download a new one, the icon is crossed out and a prompt saying the app may be d… (read more)

Firefox stopped working on MacBook pro running OS 10.13.6. I deleted the app and tried to download a new one, the icon is crossed out and a prompt saying the app may be damaged or incomplete. Nothing had been changed on my system when this happened.

Asked by rick914 18 hours ago

Last reply by ARMAN KHAN 18 hours ago

Compiling FF78: "Could not find artifacts for ... "win32-minidump-stackwalk""

So I'm trying to compile the newest FF78 (W7x64). hg pull && hg update Now as usual, "mach" annoyingly complains about some compiler being outdated, so as ev… (read more)

So I'm trying to compile the newest FF78 (W7x64).

   hg pull && hg update


Now as usual, "mach" annoyingly complains about some compiler being outdated, so as every month I have to

   mach bootstrap


I select 2 (normal FF), it downloads "node.tar.bz2", then "fix-stacks.tar.bz2" and then crashes with "Could not find artifacts for a toolchain build named `win32-minidump-stackwalk`".

So what exactly does it want me to do and why does this happen?

"mach clobber python" does not work.


Thank you


Full log:

    0:05.83 Setting up artifact node.tar.bz2
    0:05.84 Using artifact from local cache: ...\mozbuild\toolchains\97a30da439a065e2-node.tar.bz2
    0:05.93 rm tree: ...\mozbuild\node
    0:09.68 untarring "...\mozbuild\node.tar.bz2"
    0:05.72 Setting up artifact fix-stacks.tar.bz2
    0:05.73 Using artifact from local cache: ...\mozbuild\toolchains\7857866b42f45825-fix-stacks.tar.bz2
    0:05.79 rm tree: ...\mozbuild\fix-stacks
    0:05.79 untarring "...\mozbuild\fix-stacks.tar.bz2"
    0:05.53 Could not find artifacts for a toolchain build named `win32-minidump-stackwalk`. Local commits, dirty/stale files, and other changes in your checkout may cause this error. Make sure you are on a fresh, current checkout of mozilla-central. If you are already, you may be able to avoid this error by running `mach clobber python`. Beware that commands like `mach bootstrap` and `mach artifact` are unlikely to work on any versions of the code besides recent revisions of mozilla-central.
   Error running mach:
       ['bootstrap']
   The error occurred in code that was called by the mach command. This is either
   a bug in the called code itself or in the way that mach is calling it.
   You can invoke |./mach busted| to check if this issue is already on file. If it
   isn't, please use |./mach busted file| to report it. If |./mach busted| is
   misbehaving, you can also inspect the dependencies of bug 1543241.
   If filing a bug, please include the full output of mach, including this error
   message.
   The details of the failure are as follows:
   subprocess.CalledProcessError: Command '['...\\mozilla-build\\python3\\python3.exe', '...\\mozilla-source\\mozilla-relea
   se\\mach', 'artifact', 'toolchain', '--from-build', 'win32-minidump-stackwalk']' returned non-zero exit status 1.
     File "...\mozilla-release\python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
       bootstrapper.bootstrap()
     File "...\mozilla-release\python/mozboot\mozboot\bootstrap.py", line 544, in bootstrap
       checkout_root)
     File "...\mozilla-release\python/mozboot\mozboot\bootstrap.py", line 400, in maybe_install_private_packages_or_exit
       self.instance.ensure_minidump_stackwalk_packages(state_dir, checkout_root)
     File "...\mozilla-release\python/mozboot\mozboot\mozillabuild.py", line 156, in ensure_minidump_stackwalk_packages
       minidump_stackwalk.WINDOWS_MINIDUMP_STACKWALK)
     File "...\mozilla-release\python/mozboot\mozboot\base.py", line 358, in install_toolchain_artifact
       subprocess.check_call(cmd, cwd=state_dir)
     File "...\mozilla-build\python3\lib\subprocess.py", line 291, in check_call
       raise CalledProcessError(retcode, cmd)

Asked by sdagfk 1 day ago

Last reply by sdagfk 20 hours ago

Youtube.com 8k Video Problem

I'm unable to watch 8k Videos On Youtube ,I can Just See Some Frames In Video. But I'm Able To Watch 8k Videos on Chrome & Edge There Is Problem With Firefox Only... … (read more)

I'm unable to watch 8k Videos On Youtube ,I can Just See Some Frames In Video. But I'm Able To Watch 8k Videos on Chrome & Edge There Is Problem With Firefox Only...

Asked by pranavnage0 20 hours ago