X
Tap here to go to the mobile version of the site.

Support Forum

PBS and CBS video won't play; ABC, FOX and NBC do.

Posted

I run Firefox version 28 on a 64-bit Lenovo G700 laptop running Windows 8.1. I am trying to view videos on news sites. Most of them (ABCNews, CNN, FOXNews, NBCNews) give me no trouble, but two of them--CBSNews and PBS--won't let me view videos. (In IE11 and Chrome, PBS works, but CBS doesn't.) On PBS, I get an error message of "Plug-in file missing". On CBSNews, all I get is a black placeholder (which doesn't respond to either left- or right-clicking) where the video is to play; sometimes, I don't even get that, just white space. I've updated my plug-ins, reinstalled Shockwave Flash several times, and I've gone through my plug-ins turning them on and off, testing them as recommended; I couldn't find any plug-in that was causing trouble. All I know is that PBS uses a "JW" program to put its videos out. I've emailed CBS tech support to see if they could give me some guidance; all they do is recommend Chrome, which (as I mentioned above) doesn't work. I'm at my wits' end; has anyone else run into this kind of thing? Note: there is probably a different solution for each website, since the manifestations are different.

I run Firefox version 28 on a 64-bit Lenovo G700 laptop running Windows 8.1. I am trying to view videos on news sites. Most of them (ABCNews, CNN, FOXNews, NBCNews) give me no trouble, but two of them--CBSNews and PBS--won't let me view videos. (In IE11 and Chrome, PBS works, but CBS doesn't.) On PBS, I get an error message of "Plug-in file missing". On CBSNews, all I get is a black placeholder (which doesn't respond to either left- or right-clicking) where the video is to play; sometimes, I don't even get that, just white space. I've updated my plug-ins, reinstalled Shockwave Flash several times, and I've gone through my plug-ins turning them on and off, testing them as recommended; I couldn't find any plug-in that was causing trouble. All I know is that PBS uses a "JW" program to put its videos out. I've emailed CBS tech support to see if they could give me some guidance; all they do is recommend Chrome, which (as I mentioned above) doesn't work. I'm at my wits' end; has anyone else run into this kind of thing? Note: there is probably a different solution for each website, since the manifestations are different.

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • Google Update
  • VLC media player Web Plugin 2.1.3
  • Vulnerable application scanner.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 28.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • Support URL: https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

Extensions

  • avast! Online Security 9.0.2013.75 (wrc@avast.com)
  • Bible Toolbar 4.0.0 (bibletoolbar@bibletoolbar.net)
  • Brief 1.7.2 (brief@mozdev.org)
  • DuckDuckGo Plus 0.3.16 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Free eBook Search 3.0.0 ({7585C31E-1E94-4498-ACEC-CB913A05FC52})
  • FromDocToPDF 6.20.3.33692 (65ffxtbr@FromDocToPDF_65.com)
  • HTTPS-Everywhere 3.4.5 (https-everywhere@eff.org)
  • QuickSearchBar 2.3 (info@quick-search.org)
  • Search in YouTube 1.0 (searchyoutube@searchyoutube.fr)
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Weather Watcher Live 1.0.23 (weatherwatcherlive@singerscreations.com)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0156
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 1-22-2014
  • driverDate2:
  • driverVersion: 10.18.10.3412
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1395527863
  • places.history.expiration.transient_current_max_pages: 104210
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npauthz: 2
  • plugin.state.npctrl: 2
  • plugin.state.npgoogleupdate: 2
  • plugin.state.nppcmaticplugin: 2
  • plugin.state.npspwrap: 2
  • plugin.state.npvlc: 2
  • privacy.cpd.cookies: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.brief.sqlite: 1394762311
  • storage.vacuum.last.index: 2
  • storage.vacuum.last.places.sqlite: 1394327259

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 10 Contributor
712 solutions 5609 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Please check if all your plugins are up-to-date. To do this, go to the [http://mozilla.com/plugincheck Mozilla Plugin Check site]. Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow ''Update'' button or a red ''Update now'' button, please update these immediately. To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.
Wesley Branton
  • Top 10 Contributor
712 solutions 5609 answers

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.

Fx23MixedContentBlocker

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: [[How does content that isn't secure affect my safety?]] To temporarily allow the mixed content to be displayed: *Click the '''shield icon''' [[Image:Mixed Content Shield]] in the address bar and choose '''Disable Protection on This Page''' from the dropdown menu. [[Image:Fx23MixedContentBlocker]] To allow insecure content to be displayed in all secure pages, enter '''about:config''' in the address bar and double-click on this preference, to toggle it from true to false: '''security.mixed_content.block_active_content''' You can also use this add-on instead, to toggle the preference: *[https://addons.mozilla.org/firefox/addon/toggle-mixed-active-content/ Toggle Mixed active content] add-on You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about. Let us know if this helps!
jscher2000
  • Top 10 Contributor
8903 solutions 72815 answers

Helpful Reply

I don't know whether this is relevant to you, but another poster discovered that PBS's site did not play video if you use the HTTPS Everywhere extension. See: PBS says "plug-in file not found". That's all. Can't stream Downton Abby. Could last season.

To check how these sites work with no extensions active, you could visit them in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Or you could manually disable extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions.

I don't know whether this is relevant to you, but another poster discovered that PBS's site did not play video if you use the '''HTTPS Everywhere''' extension. See: [https://support.mozilla.org/questions/982663 PBS says "plug-in file not found". That's all. Can't stream Downton Abby. Could last season.] To check how these sites work with no extensions active, you could visit them in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled ''(Flash and other plugins still run)'' In the dialog, click "Start in Safe Mode" (''not'' Reset) Or you could manually disable extensions on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions.

Helpful Reply

I disabled "HTTPS Everywhere"; PBS works, but CBSNews doesn't, so I'm halfway there. Thanks for the help. Roger Blair

I disabled "HTTPS Everywhere"; PBS works, but CBSNews doesn't, so I'm halfway there. Thanks for the help. Roger Blair

Question owner

Sorry.

Sorry.

Question owner

Sorry again.

Sorry again.

Question owner

jscher2000 recommended disabling "HTTPS Everywhere", so I tried that; I can now view PBS video (thanks, jscher2000), but CBSNews video showed no change--I still can't view it. I installed the recommended "Toggle Mixed Active Content" extension, but it makes no difference whether the flag is on or off. Does anyone have any other ideas?

jscher2000 recommended disabling "HTTPS Everywhere", so I tried that; I can now view PBS video (thanks, jscher2000), but CBSNews video showed no change--I still can't view it. I installed the recommended "Toggle Mixed Active Content" extension, but it makes no difference whether the flag is on or off. Does anyone have any other ideas?
jscher2000
  • Top 10 Contributor
8903 solutions 72815 answers

Previously I looked at the CBS site. When I look at the CBSNews site, the server is sending "unavailable video" on Firefox 28, Chrome, and IE8. Chrome and IE play ads and then the "unavailable video" snippet. Not sure that's an improvement...

I'm not sure why the scripts aren't turning the data in the page into a Flash player in Firefox. ??

Previously I looked at the CBS site. When I look at the CBSNews site, the server is sending "unavailable video" on Firefox 28, Chrome, and IE8. Chrome and IE play ads and then the "unavailable video" snippet. Not sure that's an improvement... I'm not sure why the scripts aren't turning the data in the page into a Flash player in Firefox. ??

Question owner

Folks, believe it or not, CBS News video now works for me. I didn't do anything, so the people at the website must have changed something to allow it to work. Thanks for all your help

Folks, believe it or not, CBS News video now works for me. I didn't do anything, so the people at the website must have changed something to allow it to work. Thanks for all your help
lburg 1 solutions 8 answers

My problem is on PBS website and removing HTTPS Everywhere helped in that I can now see video with play button; unfortunately, when I click play, I now get this error message: "Error loading stream: Manifest not found or invalid.", even when Firefox is running in safe mode.

My problem is on PBS website and removing HTTPS Everywhere helped in that I can now see video with play button; unfortunately, when I click play, I now get this error message: "Error loading stream: Manifest not found or invalid.", even when Firefox is running in safe mode.

Modified by lburg

lburg 1 solutions 8 answers

Darn. Got rid of HTTPS Everywhere and PBS video clip shows up now, but when I click on play, I get this error message: Error loading stream: Manifest not found or invalid. I have no problem if I use Chrome, dammit. Don't want to use Chrome.

Darn. Got rid of HTTPS Everywhere and PBS video clip shows up now, but when I click on play, I get this error message: Error loading stream: Manifest not found or invalid. I have no problem if I use Chrome, dammit. Don't want to use Chrome.
jscher2000
  • Top 10 Contributor
8903 solutions 72815 answers

Hi lburg, I don't use the PBS video site very often. When I try to play a clip today, there are two pre-roll sponsorship statements. If you are using an ad blocking extension, that could be causing the error.

To determine whether this is an extension issue, you could you test the page in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi lburg, I don't use the PBS video site very often. When I try to play a clip today, there are two pre-roll sponsorship statements. If you are using an ad blocking extension, that could be causing the error. To determine whether this is an extension issue, you could you test the page in Firefox's Safe Mode. That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled ''(Flash and other plugins still run)'' In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
jscher2000
  • Top 10 Contributor
8903 solutions 72815 answers

Hi lburg, now I see your earlier post, "even in Safe Mode." Here is some more general advice then.

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


Do you use any proxy services which could affect your detected geographic locale (private VPN, TOR, etc.)? These can create problems on some media sites that have geographic restrictions; not sure whether this applies to PBS.

To test changes to your proxy setting, you can open:

(Win) orange Firefox button (or Tools menu) > Options > Advanced
(Mac) Firefox menu > Preferences > Advanced
('nix) Edit menu > Preferences > Advanced

On the Network mini-tab, click the "Settings" button. The default is "Use system proxy settings" but you also could try "No proxy".

Hi lburg, now I see your earlier post, "even in Safe Mode." Here is some more general advice then. When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help? ---- Do you use any proxy services which could affect your detected geographic locale (private VPN, TOR, etc.)? These can create problems on some media sites that have geographic restrictions; not sure whether this applies to PBS. To test changes to your proxy setting, you can open: (Win) orange Firefox button (or Tools menu) > Options > Advanced<br> (Mac) Firefox menu > Preferences > Advanced<br> ('nix) Edit menu > Preferences > Advanced On the Network mini-tab, click the "Settings" button. The default is "Use system proxy settings" but you also could try "No proxy".
lburg 1 solutions 8 answers

Should have begun this with a big thank you, despite having no luck. These steps did not fix the problem.

One thing I notice when I check the update status of plugins on the Mozilla site is that after updating Java, it still shows these as outdated. I did not upgrade the Java Tools as Mozilla views that as risky, but I did upgrade Java and the site says that I have the latest versions.

Per another poster's response, I updated optional Win 7 upgrades. I also checked for graphics updates through Dell.

I have rebooted and restarted Firefox several times during these steps to no avail.

Another oddity: There are two Shockwave for Director plugins. One is ver 12.1.0.150 and the other is 12.0.7.148

Should have begun this with a big thank you, despite having no luck. These steps did not fix the problem. One thing I notice when I check the update status of plugins on the Mozilla site is that after updating Java, it still shows these as outdated. I did not upgrade the Java Tools as Mozilla views that as risky, but I did upgrade Java and the site says that I have the latest versions. Per another poster's response, I updated optional Win 7 upgrades. I also checked for graphics updates through Dell. I have rebooted and restarted Firefox several times during these steps to no avail. Another oddity: There are two Shockwave for Director plugins. One is ver 12.1.0.150 and the other is 12.0.7.148

Modified by lburg

jscher2000
  • Top 10 Contributor
8903 solutions 72815 answers

Hi lburg, please disregard the plugin check site warning you about Java 7 Update 51. That is the correct release for most people. The plugin check site was updated to recognize Java 8 as the current release, but Oracle only recommends it for developers. You'll have to rely on the Java updater to keep you updated until everything comes back into sync.

Regarding an extra Shockwave for Director plugin, it could be that the Adobe updater did not clean up the old file. You can set it to "Never Activate" to avoid a conflict. However, I doubt that is impacting many sites.

Back to PBS, I don't recognize the error message. Perhaps it will sound familiar to another volunteer.

Hi lburg, please disregard the plugin check site warning you about Java 7 Update 51. That is the correct release for most people. The plugin check site was updated to recognize Java 8 as the current release, but Oracle only recommends it for developers. You'll have to rely on the Java updater to keep you updated until everything comes back into sync. Regarding an extra Shockwave for Director plugin, it could be that the Adobe updater did not clean up the old file. You can set it to "Never Activate" to avoid a conflict. However, I doubt that is impacting many sites. Back to PBS, I don't recognize the error message. Perhaps it will sound familiar to another volunteer.

Question owner

jscher2000, I tried your suggestions. First, I cleared the cache (which was already empty) and reloaded the page; nothing changed. Next, I tried to change the proxy settings, but Firefox doesn't seem to remember my changes, and always goes back to the default. Is there. some config setting I need to change so Firefox will remember my changes? Also, I've noticed that sometimes (very rarely, but sometimes), I can view CBS News video without making any adjustments to my machine. (I also just found out that I can't use either the bold or the italic buttons to format text, but that's another matter.) Most of the time, though, I can't view the video at all. Any ideas on something else I could try? Thanks

Roger Blair

jscher2000, I tried your suggestions. First, I cleared the cache (which was already empty) and reloaded the page; nothing changed. Next, I tried to change the proxy settings, but Firefox doesn't seem to remember my changes, and always goes back to the default. Is there. some config setting I need to change so Firefox will remember my changes? Also, I've noticed that sometimes (very rarely, but sometimes), I can view CBS News video without making any adjustments to my machine. (I also just found out that I can't use either the bold or the italic buttons to format text, but that's another matter.) Most of the time, though, I can't view the video at all. Any ideas on something else I could try? Thanks Roger Blair
cor-el
  • Top 10 Contributor
  • Moderator
17786 solutions 160898 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If you do not keep changes after a restart or otherwise have problems with preferences, see: *http://kb.mozillazine.org/Preferences_not_saved

Question owner

Thanks, jscher2000 and Cor-el. I checked out my extensions; the good news is that I found what seemed to be the offending extension, while the bad news was that the extension in question was put there by my antivirus program (avast). After checking a couple more forums, I was eventually advised to download and reinstall a fresh copy of Firefox; I did so, and everything that was wrong got fixed (including the CBS News video problem which I started out with). Again, many thanks for your help.

Roger Blair

Thanks, jscher2000 and Cor-el. I checked out my extensions; the good news is that I found what seemed to be the offending extension, while the bad news was that the extension in question was put there by my antivirus program (avast). After checking a couple more forums, I was eventually advised to download and reinstall a fresh copy of Firefox; I did so, and everything that was wrong got fixed (including the CBS News video problem which I started out with). Again, many thanks for your help. Roger Blair