Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

homepage is missing on startup

  • 24 replies
  • 2 have this problem
  • 1443 views
  • Last reply by spacedad

more options

After windows 7 starts and I start Firefox 26.0 my homepage is only a '/' (as in http:///) then when i restart Firefox my homepage is back. I've tried disabling add-ons and installing a fresh Firefox too. I've checked for spy ware and used ccleaner. Does anyone know what could cause this?

Chosen solution

yeah,i'm pretty savi but i've noticed installers getting very tricky these days. thanks again. all the best.

Read this answer in context 👍 0

All Replies (20)

more options

Open a new window or tab. In the address bar, type about:Config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Enter browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page),
about:newtab (shows the sites most visited),
about:blank (a blank page),
or you can enter any web page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

more options

hi,thanks for the reply, i tried it,but my problem only occures when i restart windows,it was already set to my homepage address and does work on second ff start,so i'm thinking it could be a slow startup problem.do you think it would give a blank address if it is starting to slow? gary.

more options

Okay. Several things you need to try.

First, save your home / new tab pages as you want them. Then do this;
Firefox > Help > Restart With Add-ons Disabled (Safe Mode). Once the browser is open, check your page settings. Are they the way you want them?

Second, use several of the programs listed below to scan for malware.

=======================================

Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Modified by FredMcD

more options

thanks for your advice,i have done a full scan with eset (it found a couple of video codec programs,setups in my download folder,which could even be false positives ,nothing found in my system.also scanned with ms safety scanner,clean.i also use ms security essentials.so it doesn't seem to be a virus,and it still only loads this blash (/) address on first startup after windows has booted up,if i close ff then start it,my home page is back. any other suggestions appreciated. cheers, gary.

more options

Keep an eye out, and if there is another problem, create a new question. Good luck.

more options

sorry,i don't think you understood that the problem is still there. if it's not malware,then do you know what else may be causing it?

more options

Sorry. Thought we were done. Okay. Reboot the COMPUTER in SAFE MODE with network. See if the problem is still there and report back.

more options

it works ok in safe mode.

more options

Are you running software like Advanced SystemCare or other software that protects browser settings?

more options

not that i;m aware of.

more options

not that i'm aware of.

more options

Which security software (firewall, anti-virus) do you have?

more options

ms security essentials

more options

pls update ur firefox browser

more options

i have updated firefox,also reset it to defaults.

more options

Is the problem still there?

more options

yes it's still doing it.

more options

Open a new window or tab. In the address bar, type about:Config. If a warning screen comes up, press the Be Careful button. This is where Firefox finds information it needs to run. At the top of the screen is a search bar. Enter browser.newtab.url and press enter. browser.newtab.url tells Firefox what to show when a new tab is opened. If you want, right click and select Modify. You can change the setting to;

about:home (Firefox default home page),
about:newtab (shows the sites most visited),
about:blank (a blank page),
or you can enter any web page you want.

The same instructions are used for the new window setting, listed as browser.startup.homepage.

more options

yes,i know,i was told to do that earlier on in the thread.we seem to be going round in circles.

more options

Sometimes you have to circle back to find what you are looking for. You said that when you run the computer is safe mode that the problem was gone? Then it's likely one of your other programs is causing problems for Firefox. Can you get a list of all running programs, including the background stuff?

  1. 1
  2. 2