Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does www.mouser.com take me to de.mouser.com, while IE works as intended?

more options

FF 26.0

In the URL bar I can enter www.mouser.com and it takes me to de.mouser.com (the German website for Mouser). IE on the same computer takes me to Mouser.com in the US.

Mouser's IP in the US is 12.5.163.52 if I enter that into the URL bar, that too takes me to de.mouser.com

This is the only website I have a problem with. At work I use FF 26.0 without issue. I thought it was a DNS issue until I punched in the IP address directly. ISP is Comcast in Chicago suburbs.

Mouser is a commercial website supplying electronic components to manufacturers and engineers.

Chosen solution

No problem here using Comcast in the northern Chicago suburbs.

Some site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

No problem here using Comcast in the northern Chicago suburbs.

Some site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.