Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Geolocation stopped working in Firefox 24 after update (Win7 64). Downgraded to FF 23.0.1 solved the problem. Same with other FF installation at another PC.

  • 16 replies
  • 144 have this problem
  • Last reply by tsanidas

more options

Visiting this page: or any other website using geolocation to track my location, shows a blank map and no prompt "Share location: Allow, Block, Not now".

This happened since upgrading to FF 24 (Desktop Win7 64). Downgrading to FF 23.0.1, solves the problem: FF prior to 24 supports geolocation with no problem. Tried in both my desktop and laptop with separate FF installations, using different plugins.

Thank you in advance.

[ NOTE: Now using Firefox 23.0.1, the problem only occurs after upgrading to Firefox 24 ]

Chosen solution

Uninstalling Firefox completely from my laptop and installing it again, solved the problem.

I haven't tried with my desktop yet.

The laptop uses wifi while the desktop ethernet. The problem existed in the laptop installation of FF 24 too, so I don't think that was the root of the problem, at least in my case.

Read this answer in context 👍 2

All Replies (16)

more options

You should see a notification icon on the left hand side of the location bar to ask for permission, similar to the key icon for saving passwords and other notifications that you see in the location bar. Current Firefox versions no longer have the info notification bar.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options


Firefox 24, re-started in Safe Mode with all addons disabled, using the default theme, having unhecked the "use hardware acceleration" option (Options > Advanced), but still no luck.

Tried disabling all plugins too (Adobe Acrobat, Flash, Silverlight e.g.) just in case but nothing happened.

FF24 does not ask me if I want my location to be shared, not even if I set site permissions to always share my location with the current domain (

Please see the attached screenshot, no prompt, no target (geolocation) icon, no nothing.

Any clues? Is it only me?

Thank you in avance.

more options

What is the setting for "Share Location" in "Tools > Page Info > Permissions" when you visit this web page?

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

more options

Thank you for your reply, but, as I mentioned above, even if I set site permissions to always share my location with the current domain) the permissions are not the problem:

Store passwords: Allow | Share location: Allow | Set Cookies: Allow

Neither "allow: or "always ask" solve the problem.

I did not alter any values in about:config [geo.enabled and it is set to true]

I don't know if this helps, but I am using Palemoon (a custom edition of Firefox) in both machines, but Palemoon uses its own profile.

Palemoon 24 has the same issue as Firefox 24 regarding geolocation - downgrading either of them to an earlier version solves the problem for each one.

I will try to uninstall both, remove all preferences and install a fresh copy of Firefox 24 to see if it makes any difference.

I will inform you tor the result.

Thank you in advance.

more options

Hi SotirisKalathas,

I was wondering if you have any update on your tests ? I also have found the same issues with Safari, Chrome, and Firefox 24; IE 10 works as far as getting a map object back but then fails to pin an infoWindow. Would be interested to know if anyone has the same issue or has found a solution ?


more options

Hi all,

For people interested I've found the reason (although not sure why this behavior has been adopted by the browser developers unless due to accuracy). I have an old Apple PowerBook G4 and tried the geolocation code out using Ten Four Fox. When connected to Ethernet the geolocation API fails; whilst once wireless connectivity is present it works !!!

I replaced my wired connection in my development PC with a wireless card and hey presto all the functionality of the geolocation API returns.

Now I can only assume the default behavior is to ignore the calls if there isn't a wireless connection present as the wired connection will provide inaccurate location data (IE 10 thinks I'm in London at the address of my ISP), but the wireless connection will provide a location within a couple of hundred meters of the true latitude and longitude intersection.

Perhaps someone from Mozilla could confirm if this is the case i.e. gelocation calls for getCurrentPosition will fail unless a wireless connection is present, is this correct ?

Anyway my code is working via Firefox and Chrome again.

Hope this helps someone out,

cheers guys,


more options

Chosen Solution

Uninstalling Firefox completely from my laptop and installing it again, solved the problem.

I haven't tried with my desktop yet.

The laptop uses wifi while the desktop ethernet. The problem existed in the laptop installation of FF 24 too, so I don't think that was the root of the problem, at least in my case.

more options

I have exactly the same problem here, geolocation doesn't work anywhere in Firefox 24.

more options

Same problem here: FF 24.0 on Ubuntu 13.04 The confirmation is not even displayed. Save mode did not help. What helped a bit was starting FF with fresh profile firefox -profileManage

I got confirmation , but geolocation was not still working - location error event: --

Geolocation error: timeout.

Not sure if these two problems are related.

more options

Hi guys,

I still get the same functionality; I switch to an Ethernet only connection and try geolocation.getCurrentPosition this gives me the request in FF24 to permit my location to be shared. I grant permission and then nothing, I try the same in IE10 and I get back the location (although highly inaccurate) and the google map using the maps API. I switch back to a wireless only connection and then everything works again !!! I change nothing else except disable the Ethernet card and enable the wireless card, nothing else is changed on the machine. Must be something to do with access via the wireless protocol ??

more options

Still doesnt work in Firefox 24 or 25. Works like a charm in 23.0.1

more options

I have this problem on a fresh installed Windows 7 with all updates. Also on a Suse with FF 26. On my Mac it works. The Mac is connected with WLAN, Windows and Suse are running in VMware, so they have ethernet connection. But this worked also in earlier version (but not as accurate as on the Mac using WLAN).

more options

I was having this problem and it was driving me crazy. After trying to start and restart several dozen times, I noticed there was a file creation error message in the console. Trying to outsmart that, I ran Firefox as administrator (Win 7), and suddenly geolocation was working again. I noticed that FF had created a new folder:

 c:/Program Files (x86)/Mozilla Firefox/browser/defaults
 right around the time this started working.  Either I did something or my company recently locked down the Firefox directories, which is highly likely.
 I hope this helps someone else.

Modified by tsanidas

more options

After starting FF as administrator I allowed to locate. But it didn't work at this time. After then, I startet FF as user, now it works.

more options

Did exactly the same. Ran FF 27 as administrator, and geolocater worked as it should. Restarted FF as regular user and it works too! Thanks tsanidas for your diligent efforts!

more options

Glad my obsessing over this yielded some fruit! I'm asking because I've never done this, but is this something that I should report as a bug? If so, how?