X
Tap here to go to the mobile version of the site.

Support Forum

I'm only getting one quarter of a screen on Flash Player on Firefox.

Posted

Only the upper left quadrant of the Flash Player screen has content. The rest of the screen is either blank or the original static image. This occurs on YouTube and any website that has Flash Player content. Computer is a Macbook Pro Retina using OSX 10.8.4. I've uninstalled and reinstalled Flash Player (twice) and uninstalled and reinstalled Firefox. The problem doesn't occur when I'm using Safari.

Only the upper left quadrant of the Flash Player screen has content. The rest of the screen is either blank or the original static image. This occurs on YouTube and any website that has Flash Player content. Computer is a Macbook Pro Retina using OSX 10.8.4. I've uninstalled and reinstalled Flash Player (twice) and uninstalled and reinstalled Firefox. The problem doesn't occur when I'm using Safari.

Chosen solution

This solved it for me. After selecting "Use hardware acceleration when available" in Firefox Advanced preferences, reboot Firefox - and viola - now see the other three quarters...

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Version 4.4.2.14502
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • WebEx64 General Plugin Container Version 205
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • AmazonMP3DownloaderPlugin 1.0.16
  • eMusic DLM 4.1.3.2
  • npmnqmp 071303000006
  • iPhoto6

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/Darwin/en-US/

Extensions

  • Evernote Web Clipper 5.7 ({E0B8C461-F8FB-49b4-8373-FE32E9252800})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://mail.google.com/mail/u/0/?shva=1#inbox
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.blacklist.webgl.msaa: 4
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1377014247
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.adobepdfviewernpapi: 0
  • plugin.state.java: 0
  • plugin.state.silverlight: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 2
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376929726

Misc

  • User JS: No
  • Accessibility: No
kobe 441 solutions 5048 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension (or hardware acceleration), and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension (or hardware acceleration), and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

Thanks, but unfortunately, it didn't work. I tried it twice and still only get a quarter screen on Flash Player applications. Any other suggestions? I've searched Mozilla and Adobe forums and haven't found anything that works...yet.

Thanks, but unfortunately, it didn't work. I tried it twice and still only get a quarter screen on Flash Player applications. Any other suggestions? I've searched Mozilla and Adobe forums and haven't found anything that works...yet.
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

The Retina display may have unique issues...

A couple questions:

  • Is this a new issue with the recent .1 update (Friday August 16th) -- in other words, did the Flash player work normally in Firefox 23.0 or Firefox 22.0?
  • Does the Flash Player plugin's full screen mode work correctly, or does switching the player between normal and full screen make any difference?

You may already have tried the following, but just in case:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

(WIN) orange Firefox button (or Tools menu) > Options > Advanced
(MAC) Edit menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

The Retina display may have unique issues... A couple questions: * Is this a new issue with the recent .1 update (Friday August 16th) -- in other words, did the Flash player work normally in Firefox 23.0 or Firefox 22.0? * Does the Flash Player plugin's full screen mode work correctly, or does switching the player between normal and full screen make any difference? ---- You may already have tried the following, but just in case: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: (WIN) orange Firefox button (or Tools menu) > Options > Advanced<br> (MAC) Edit menu > Preferences > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?

Question owner

I tried all your suggestions but still no luck. To answer your questions: 1) yes it worked prior to the latest upgrade on Friday. 2) Yes, it works in full screen mode.

I did notice a footer on one page: "javascript: void(null)"

Any other ideas?

I tried all your suggestions but still no luck. To answer your questions: 1) yes it worked prior to the latest upgrade on Friday. 2) Yes, it works in full screen mode. I did notice a footer on one page: "javascript: void(null)" Any other ideas?
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

The below bug wasn't the relevant one. The correct bug is: 903296 – With hardware acceleration off, Flash displayed only in the top left quarter on Mac OSX.


Earlier Post:

This has been submitted to the bug tracking system this morning: 907792 – Embedded YouTube videos only display 1/4 of the video on Retina MBP/OSX.

A note regarding the bug tracking system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:


The first comment in the bug reports:

If I disable HiDPI support by setting the gfx.hidpi.enabled pref to -1, then the embedded videos are displayed correctly.

If you want to try this, the steps are:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste gfx and pause while the list is filtered

(3) Double-click gfx.hidpi.enabled and edit the value from 1 to 0 or lower (e.g., -1). I don't know whether this works immediately or you need to exit and restart Firefox in order to see the effect.

According to a comment in the source code, these are the possible values for that preference (must be a whole number with no decimal):

// gfx.hidpi.enabled is an integer with the meaning:
//    <= 0 : HiDPI support is disabled
//       1 : HiDPI enabled provided all screens have the same backing resolution
//     > 1 : HiDPI enabled even if there are a mixture of screen modes
The below bug wasn't the relevant one. The correct bug is: [https://bugzilla.mozilla.org/show_bug.cgi?id=903296 903296 – With hardware acceleration off, Flash displayed only in the top left quarter on Mac OSX]. ---- '''''Earlier Post:''''' This has been submitted to the bug tracking system this morning: [https://bugzilla.mozilla.org/show_bug.cgi?id=907792 907792 – Embedded YouTube videos only display 1/4 of the video on Retina MBP/OSX]. A note regarding the bug tracking system: If forum members can contribute to the development, please feel free to pitch in. Otherwise, it's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See: * [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] * [https://bugzilla.mozilla.org/page.cgi?id=voting.html Voting] ---- The first comment in the bug reports: <blockquote>If I disable HiDPI support by setting the gfx.hidpi.enabled pref to -1, then the embedded videos are displayed correctly.</blockquote> If you want to try this, the steps are: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''gfx''' and pause while the list is filtered (3) Double-click '''gfx.hidpi.enabled''' and edit the value from 1 to 0 or lower (e.g., -1). I don't know whether this works immediately or you need to exit and restart Firefox in order to see the effect. According to a comment in the source code, these are the possible values for that preference (must be a whole number with no decimal): // gfx.hidpi.enabled is an integer with the meaning: // <= 0 : HiDPI support is disabled // 1 : HiDPI enabled provided all screens have the same backing resolution // > 1 : HiDPI enabled even if there are a mixture of screen modes

Modified by jscher2000

tenaciousg3 0 solutions 2 answers

Hello,

I have exactly the same issue, running pretty much the exact same setup as the OP (including the kind of computer). I have also tried every remedy listed here and nothing works. The only thing that DOES work is restarting the computer. When I do that, it works properly for a little while and then reverts back to the problem. Also, the same content will work in Safari without issues.

Hello, I have exactly the same issue, running pretty much the exact same setup as the OP (including the kind of computer). I have also tried every remedy listed here and nothing works. The only thing that DOES work is restarting the computer. When I do that, it works properly for a little while and then reverts back to the problem. Also, the same content will work in Safari without issues.
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Hi tenaciousg3, I'm not sure why it would work for a while and then change. That could be a different issue. Does turning off HiDPI support for your Retina display change it? See: https://support.mozilla.org/en-US/questions/968863#answer-470905

Hi tenaciousg3, I'm not sure why it would work for a while and then change. That could be a different issue. Does turning off HiDPI support for your Retina display change it? See: https://support.mozilla.org/en-US/questions/968863#answer-470905

Question owner

Jscher2000 - duly noted about reporting bugs. The answer you cited was the 1st one I tried yesterday, to no avail. However, I only entered "1" as a value. Just now, when I entered "-1" and "0" as values, it worked. But, the text on all websites has blurry edges. So it looks like a choice between clear text and a full picture on reduced Flash Player. Possibly related to the retina view?

Jscher2000 - duly noted about reporting bugs. The answer you cited was the 1st one I tried yesterday, to no avail. However, I only entered "1" as a value. Just now, when I entered "-1" and "0" as values, it worked. But, the text on all websites has blurry edges. So it looks like a choice between clear text and a full picture on reduced Flash Player. Possibly related to the retina view?

Question owner

Sorry. It should read: So it looks like a choice between clear text and a quarter picture on reduced Flash Player.

Sorry. It should read: So it looks like a choice between clear text and a '''quarter''' picture on reduced Flash Player.
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Hi Fosterbeach, yes, I believe it's Retina-specific.

I think for now your choices are:

  • Use HiDPI support and fullscreen Flash content to work around the bug. This will be annoying on sites where you want to see the Flash media in the context of the page.
  • Disable HiDPI support and suffer degraded anti-aliasing.
  • Roll back to Firefox 23.0 -- you will lose a few other bug fixes, but I'm not aware of any security patches between 23.0 and 23.0.1.
Hi Fosterbeach, yes, I believe it's Retina-specific. I think for now your choices are: * Use HiDPI support and fullscreen Flash content to work around the bug. This will be annoying on sites where you want to see the Flash media in the context of the page. * Disable HiDPI support and suffer degraded anti-aliasing. * Roll back to Firefox 23.0 -- you will lose a few other bug fixes, but I'm not aware of any security patches between 23.0 and 23.0.1.

Question owner

Thanks for exploring this jscher2000. I'm unsure of how to downgrade to 23.0 even after reading this: https://support.mozilla.org/en-US/kb/install-older-version-of-firefox#os=win7&browser=fx23. I checked the directory of older versions but that's beyond my knowledge base on how to install. Any suggestions?

Thanks for exploring this jscher2000. I'm unsure of how to downgrade to 23.0 even after reading this: https://support.mozilla.org/en-US/kb/install-older-version-of-firefox#os=win7&browser=fx23. I checked the directory of older versions but that's beyond my knowledge base on how to install. Any suggestions?
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Hi Fosterbeach, you can download the .dmg file for U.S. English Firefox 23.0 here:

https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/23.0/mac/en-US/

If you prefer a different language, click Parent Directory and select from the long list of available folders

As a Windows user, the process of installing DMG files is a mystery to me, but maybe this article will help: How to download and install Firefox on Mac -- using the link above replaces steps 1 and 2 in the article.

Hi Fosterbeach, you can download the .dmg file for U.S. English Firefox 23.0 here: https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/23.0/mac/en-US/ ''If you prefer a different language, click Parent Directory and select from the long list of available folders'' As a Windows user, the process of installing DMG files is a mystery to me, but maybe this article will help: [[Install Firefox on Mac]] -- using the link above replaces steps 1 and 2 in the article.

Question owner

Shoot. Ff 23.0 doesn't correct it either. I'll keep checking to see if future updates fix it.

Shoot. Ff 23.0 doesn't correct it either. I'll keep checking to see if future updates fix it.
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Thank you for trying that.

I wonder whether that bug report being filed this morning was a coincidence? There may be a different issue that wasn't discovered in beta testing for Firefox 23.0.

Have you restarted MacOSX since this problem started?

Thank you for trying that. I wonder whether that bug report being filed this morning was a coincidence? There may be a different issue that wasn't discovered in beta testing for Firefox 23.0. Have you restarted MacOSX since this problem started?

Question owner

I'm the one who filed the bug. Wasn't sure where else to turn.

Regarding restarting MacOSX - do you mean restarting the computer or something else? I have restarted the computer.

I'm the one who filed the bug. Wasn't sure where else to turn. Regarding restarting MacOSX - do you mean restarting the computer or something else? I have restarted the computer.
tenaciousg3 0 solutions 2 answers

Hello all, thanks for all your help.

So - I changed the "gfx.hidpi.enabled" setting as you suggested, and it worked for the video, but like Fosterbeach said, it made the text all blurry.

Something to note - that setting was on "2" when I first opened it. I set it to "-1" and it fixed the video issue, but only after I restarted Firefox. I set it back to "2", restarted Firefox, and the problem returned. Leaving the setting on "2", I restarted the computer (since that had somehow temporarily corrected the problem before). I opened Firefox, chose a YouTube video and sure enough, it worked fine - no 1/4 screen problem. So I checked that gfx setting again and it was set to "1" now.

So far, it is still working properly. It has not spontaneously reverted back to the problem yet like it did before. I'll keep you posted.

Hello all, thanks for all your help. So - I changed the "gfx.hidpi.enabled" setting as you suggested, and it worked for the video, but like Fosterbeach said, it made the text all blurry. Something to note - that setting was on "2" when I first opened it. I set it to "-1" and it fixed the video issue, but only after I restarted Firefox. I set it back to "2", restarted Firefox, and the problem returned. Leaving the setting on "2", I restarted the computer (since that had somehow temporarily corrected the problem before). I opened Firefox, chose a YouTube video and sure enough, it worked fine - no 1/4 screen problem. So I checked that gfx setting again and it was set to "1" now. So far, it is still working properly. It has not spontaneously reverted back to the problem yet like it did before. I'll keep you posted.

Question owner

In about:config, I noticed that gfx.blacklist.webgl.msaa notes in the status column that it's "user set" and that it's set to "4" for a value. I know I didn't change it on that page. Could this be a possible root cause?

In about:config, I noticed that gfx.blacklist.webgl.msaa notes in the status column that it's "user set" and that it's set to "4" for a value. I know I didn't change it on that page. Could this be a possible root cause?
jscher2000
  • Top 10 Contributor
8707 solutions 71164 answers

Hi Fosterbeach, I'm not sure how WebGL acceleration affects Flash, so gfx.blacklist.webgl.msaa might be related. This article mentions NVIDIA products, but I didn't dig around to understand the relevance of the numeric value.

https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Mac

Hi Fosterbeach, I'm not sure how WebGL acceleration affects Flash, so gfx.blacklist.webgl.msaa might be related. This article mentions NVIDIA products, but I didn't dig around to understand the relevance of the numeric value. https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Mac
spodletela 0 solutions 2 answers

I had the same issue - reverted back to V22 Firefox and it's OK again! Phew!

MPB Retina, FF 23.0.1. Nothing else helped.

https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/22.0/mac/en-US/

I had the same issue - reverted back to V22 Firefox and it's OK again! Phew! MPB Retina, FF 23.0.1. Nothing else helped. https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/22.0/mac/en-US/
davebesag 0 solutions 7 answers

Exactly the same issue (Retina screen and suddenly quarter-screen on Flash videos). No issue on Safari (I don't have IE or Chrome on the machine).

Changing gfx.hidpi.enabled to -1 does work but as has been said it makes the text worse on the screen.

I've gone back to FF22.0 and the issue has gone.

Is there any likelihood of a solution to this?

Exactly the same issue (Retina screen and suddenly quarter-screen on Flash videos). No issue on Safari (I don't have IE or Chrome on the machine). Changing gfx.hidpi.enabled to -1 does work but as has been said it makes the text worse on the screen. I've gone back to FF22.0 and the issue has gone. Is there any likelihood of a solution to this?

Modified by davebesag